aboutsummaryrefslogtreecommitdiff
path: root/cad/geda/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>1998-12-06 14:11:53 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>1998-12-06 14:11:53 +0000
commit3ec6e84c698dbc246f68de713d02678641a81bf9 (patch)
treec65411ac40178313d01a3134d951bd6bf99653b0 /cad/geda/Makefile
parent907226876212700c6697e31b994112eea604ff15 (diff)
GNU Electronic Design Automation.
Notes
Notes: svn path=/head/; revision=15151
Diffstat (limited to 'cad/geda/Makefile')
-rw-r--r--cad/geda/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/cad/geda/Makefile b/cad/geda/Makefile
new file mode 100644
index 000000000000..9d98eac759a9
--- /dev/null
+++ b/cad/geda/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: geda
+# Version required: 19981117
+# Date created: 24 Nov 1998
+# Whom: Vanilla I. Shu <vanilla@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= gEDA-19981117
+PKGNAME= geda-19981117
+CATEGORIES= cad
+MASTER_SITES= http://www.geda.seul.org
+
+MAINTAINER= vanilla@FreeBSD.ORG
+
+LIB_DEPENDS= gtk.1:${PORTSDIR}/x11-toolkits/gtk \
+ guile.4:${PORTSDIR}/lang/guile
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CFLAGS}"
+
+post-install:
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>