aboutsummaryrefslogtreecommitdiff
path: root/cad/gerbv/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-15 20:00:33 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-15 20:00:33 +0000
commitb71019d0c971e4e651fab3661f970ef09d72ede9 (patch)
treec0702ec6274c0405242bcd83cf88a393afc426f6 /cad/gerbv/Makefile
parente2cb8f5517e0d9d2a8e5e6146711b9fd4e448853 (diff)
downloadports-b71019d0c971e4e651fab3661f970ef09d72ede9.tar.gz
ports-b71019d0c971e4e651fab3661f970ef09d72ede9.zip
Notes
Diffstat (limited to 'cad/gerbv/Makefile')
-rw-r--r--cad/gerbv/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/cad/gerbv/Makefile b/cad/gerbv/Makefile
new file mode 100644
index 000000000000..0db09da1ba3e
--- /dev/null
+++ b/cad/gerbv/Makefile
@@ -0,0 +1,40 @@
+# ex:ts=8
+# Ports collection makefile for: gerbv
+# Date created: Jul 16, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gerbv
+PORTVERSION= 0.0.9
+CATEGORIES= cad
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gdk_pixbuf:${PORTSDIR}/graphics/gdk-pixbuf \
+ png:${PORTSDIR}/graphics/png \
+ gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+USE_REINPLACE= yes
+USE_GTK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+
+MAN1= gerbv.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|g" ${WRKSRC}/src/amacro.c
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/doc/* ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/example/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>