aboutsummaryrefslogtreecommitdiff
path: root/cad/gerbv
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-11-01 20:59:30 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-11-01 20:59:30 +0000
commitf3bb6fac5c08ad2be919a50cf15a3d7342f10a97 (patch)
tree289ae4cdecce10b2ff237fe6c23d3da9ff06cceb /cad/gerbv
parenta4c6eeb78f037d64d2832c0a1977a7a3cb146e4a (diff)
downloadports-f3bb6fac5c08ad2be919a50cf15a3d7342f10a97.tar.gz
ports-f3bb6fac5c08ad2be919a50cf15a3d7342f10a97.zip
Notes
Diffstat (limited to 'cad/gerbv')
-rw-r--r--cad/gerbv/Makefile82
-rw-r--r--cad/gerbv/distinfo4
-rw-r--r--cad/gerbv/pkg-descr2
-rw-r--r--cad/gerbv/pkg-plist56
4 files changed, 103 insertions, 41 deletions
diff --git a/cad/gerbv/Makefile b/cad/gerbv/Makefile
index ffcd22877d5f..577894826c69 100644
--- a/cad/gerbv/Makefile
+++ b/cad/gerbv/Makefile
@@ -2,20 +2,23 @@
# $FreeBSD$
PORTNAME= gerbv
-PORTVERSION= 2.6.0
-PORTREVISION= 1
+PORTVERSION= 2.6.1
CATEGORIES= cad
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A Free Gerber Viewer
+COMMENT= Gerber file viewer
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pathfix pkgconfig
-USE_GNOME= desktopfileutils gtk20
-USE_AUTOTOOLS= libtool
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+USES= desktop-file-utils gmake pathfix pkgconfig
+USE_GNOME= gtk20
+USE_AUTOTOOLS= libtoolize aclocal autoheader automake autoconf
+LIBTOOLIZE_ARGS=--copy --force
+AUTOMAKE_ARGS= --add-missing --copy --foreign
+CONFIGURE_ENV= ac_aux_dir="."
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
@@ -24,39 +27,46 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= VERSION="${PORTVERSION}"
-MAN1= gerbv.1
-
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e '/^SUBDIRS =/s|desktop||g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|^AM_NLS|#AM_NLS| ; \
+ s|^AM_GNU_GETTEXT|#AM_GNU_GETTEXT| ; \
+ /intl\/Makefile/d ; \
+ /po\/Makefile/d' ${WRKSRC}/configure.ac
+ @${REINPLACE_CMD} -e \
+ '/^SUBDIRS/s|=.*|= src man scheme|' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e \
+ '/^man_MANS/s|gerbv.ru.1|| ; \
+ s|^PO_|#PO_|' ${WRKSRC}/man/Makefile.am
+ @${REINPLACE_CMD} -e \
+ '/^pkgconfigdir/s|$$(libdir)|$$(prefix)/libdata|' \
+ ${WRKSRC}/src/Makefile.am
post-install:
- ${INSTALL_DATA} ${WRKSRC}/desktop/gerbv.desktop \
- ${PREFIX}/share/applications
- @${MKDIR} ${PREFIX}/share/icons/hicolor/scalable/apps
- ${INSTALL_DATA} ${WRKSRC}/desktop/gerbv.svg \
- ${PREFIX}/share/icons/hicolor/scalable/apps
+ @${MKDIR} ${STAGEDIR}${DESKTOPDIR}
+ (cd ${WRKSRC}/desktop && ${INSTALL_DATA} gerbv.desktop \
+ ${STAGEDIR}${DESKTOPDIR})
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
+ (cd ${WRKSRC}/desktop && ${INSTALL_DATA} gerbv.svg \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps)
.for i in 16 22 24 32 48
- @${MKDIR} ${PREFIX}/share/icons/hicolor/${i}x${i}/apps
- ${INSTALL_DATA} ${WRKSRC}/desktop/gerbv-${i}.png \
- ${PREFIX}/share/icons/hicolor/${i}x${i}/apps/gerbv.png
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${i}x${i}/apps
+ (cd ${WRKSRC}/desktop && ${INSTALL_DATA} gerbv-${i}.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${i}x${i}/apps/gerbv.png)
.endfor
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/*.fig ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/*.txt ${DOCSDIR}
- @${MKDIR} ${DOCSDIR}/PNG-print
- ${INSTALL_DATA} ${WRKSRC}/doc/PNG-print/*.jpg ${DOCSDIR}/PNG-print
- ${INSTALL_DATA} ${WRKSRC}/doc/PNG-print/*.txt ${DOCSDIR}/PNG-print
- @${MKDIR} ${DOCSDIR}/eagle
- ${INSTALL_DATA} ${WRKSRC}/doc/eagle/*.pl ${DOCSDIR}/eagle
- ${INSTALL_DATA} ${WRKSRC}/doc/eagle/*.txt ${DOCSDIR}/eagle
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}/example && ${FIND} . ! -name "*Makefile*" | \
- ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
-.endif
- -@update-desktop-database
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${INSTALL_DATA} *.fig *.txt \
+ ${STAGEDIR}${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/PNG-print
+ (cd ${WRKSRC}/doc/PNG-print && ${INSTALL_DATA} *.jpg *.txt \
+ ${STAGEDIR}${DOCSDIR}/PNG-print)
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/eagle
+ (cd ${WRKSRC}/doc/eagle && ${INSTALL_DATA} *.pl *.txt \
+ ${STAGEDIR}${DOCSDIR}/eagle)
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/example && ${FIND} . \
+ ! \( -name "*Makefile*" -or -name ".cvsignore" \) \
+ | ${CPIO} --quiet -pdm -L -R ${SHAREOWN}:${SHAREGRP} \
+ ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>
diff --git a/cad/gerbv/distinfo b/cad/gerbv/distinfo
index a32443e48919..b282de3dcbe8 100644
--- a/cad/gerbv/distinfo
+++ b/cad/gerbv/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gerbv-2.6.0.tar.gz) = 5c55425c3493bc8407949be8b4e572434a6b378f5727cc0dcef97dc2e7574dd0
-SIZE (gerbv-2.6.0.tar.gz) = 2346299
+SHA256 (gerbv-2.6.1.tar.gz) = 7aa6a2c622dc9ff7acd88411dddf95ae25ae3b5d97020f3ea91e97d82bf0d96c
+SIZE (gerbv-2.6.1.tar.gz) = 4432481
diff --git a/cad/gerbv/pkg-descr b/cad/gerbv/pkg-descr
index 16ebdd07a098..9cc34b1cfb8f 100644
--- a/cad/gerbv/pkg-descr
+++ b/cad/gerbv/pkg-descr
@@ -16,4 +16,4 @@ The different layers of the PCB are separated into different files. gerbv
can load all files at the same time and display them "on top of each
other". You can independently turn them on and off.
-WWW: http://gerbv.gpleda.org/
+WWW: http://gerbv.geda-project.org/
diff --git a/cad/gerbv/pkg-plist b/cad/gerbv/pkg-plist
index 902932a8e8a5..fe28927728c4 100644
--- a/cad/gerbv/pkg-plist
+++ b/cad/gerbv/pkg-plist
@@ -5,6 +5,7 @@ lib/libgerbv.la
lib/libgerbv.so
lib/libgerbv.so.1
libdata/pkgconfig/libgerbv.pc
+man/man1/gerbv.1.gz
share/applications/gerbv.desktop
%%PORTDOCS%%%%DOCSDIR%%/PNG-print/PNGPrintMiniHowto.txt
%%PORTDOCS%%%%DOCSDIR%%/PNG-print/gimp-window.jpg
@@ -17,6 +18,14 @@ share/applications/gerbv.desktop
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Mentor-BoardStation/README.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Mentor-BoardStation/artwork_1.grb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/am-test/am-test.gbx
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/amacro-ref/1.grb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/amacro-ref/README.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/amacro-ref/full-ex.grb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/amacro-ref/gerbv_am_expression_bug.ger
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/amacro-ref/jj1.drl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/amacro-ref/jj1.grb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/amacro-ref/limit-ex.grb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/amacro-ref/stp0.grb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cslk/README.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cslk/cslk.gbx
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cslk/cslk.ps
@@ -25,6 +34,10 @@ share/applications/gerbv.desktop
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dan/top_sr.gbx
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eaglecad1/top-cop.gbx
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eaglecad1/top-cop.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ekf/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ekf/ekf.gap
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ekf/ekf_08.apt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ekf/l1.off
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ekf2/README.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ekf2/d1.grb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ekf2/drill0.exc
@@ -48,6 +61,14 @@ share/applications/gerbv.desktop
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exposure/README.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exposure/example.grb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exposure/example.jpg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellboard/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellboard/hellboard.back.gbr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellboard/hellboard.fab.gbr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellboard/hellboard.front.gbr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellboard/hellboard.group1.gbr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellboard/hellboard.group2.gbr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellboard/hellboard.pcb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hellboard/hellboard.plated-drill.cnc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/jj/README.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/jj/l1-1.grb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/jj/l1-2.grb
@@ -80,6 +101,29 @@ share/applications/gerbv.desktop
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pick-and-place/LED.xy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/polarity/6_vbat.gbr
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/polarity/README.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/Assembly_Drawings.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/Final_Artwork_Prints.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/Pick_Place_for_SE_SG_IF_V2.csv
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/Pick_Place_for_SE_SG_IF_V2.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/README.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.DRL
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.DRR
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.GBL
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.GBO
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.GBS
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.GD1
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.GG1
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.GM1
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.GM2
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.GTL
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.GTO
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.GTS
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.LDP
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.REP
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.RUL
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.TXT
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/SE_SG_IF_V2.apr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protel-pnp/Status_Report.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/thermal/README.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/thermal/bpB.GP1
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/thermal/bpB.png
@@ -88,6 +132,11 @@ share/applications/gerbv.desktop
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/trailing/README.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/trailing/cd1r2.1_sieb0.off
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/trailing/cd1r2.1_sieb1.off
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/uwe/example-cairo.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/uwe/example-gdk.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/uwe/example-viewmate.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/uwe/example.gbr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/uwe/mail.txt
%%DATADIR%%/scheme/gerb-debug.scm
%%DATADIR%%/scheme/gerb-ps.scm
%%DATADIR%%/scheme/init.scm
@@ -99,19 +148,24 @@ share/icons/hicolor/48x48/apps/gerbv.png
share/icons/hicolor/scalable/apps/gerbv.svg
@dirrm %%DATADIR%%/scheme
@dirrm %%DATADIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/uwe
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/trailing
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/thermal
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/protel-pnp
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/polarity
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/pick-and-place
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/orcad
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/numpres
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/nollezappare
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/jj
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/hellboard
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/exposure
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/ekf2
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/ekf
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/eaglecad1
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/dan
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/cslk
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/amacro-ref
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/am-test
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/Mentor-BoardStation
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@@ -119,5 +173,3 @@ share/icons/hicolor/scalable/apps/gerbv.svg
%%PORTDOCS%%@dirrm %%DOCSDIR%%/PNG-print
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/gerbv-%%VERSION%%
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true