aboutsummaryrefslogtreecommitdiff
path: root/cad/irsim/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-12-02 23:54:48 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-12-02 23:54:48 +0000
commit556159610b3176e8d22029662fb057fe13ba4040 (patch)
treeda729a3cd8a987a77db90bf036edefbe57bddba0 /cad/irsim/Makefile
parent38f62903f9946cea344b159247241d6359bd2308 (diff)
Notes
Diffstat (limited to 'cad/irsim/Makefile')
-rw-r--r--cad/irsim/Makefile54
1 files changed, 43 insertions, 11 deletions
diff --git a/cad/irsim/Makefile b/cad/irsim/Makefile
index 48e19d48137b..e1c4286b9c3c 100644
--- a/cad/irsim/Makefile
+++ b/cad/irsim/Makefile
@@ -6,28 +6,60 @@
#
PORTNAME= irsim
-PORTVERSION= 9.5
-PORTREVISION= 1
+PORTVERSION= 9.7.38
+PORTREVISION= 0
CATEGORIES= cad
-MASTER_SITES= http://mos.stanford.edu/group/magic/
-EXTRACT_SUFX= .tar.Z
+MASTER_SITES= http://opencircuitdesign.com/irsim/archive/
+EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= stas@FreeBSD.org
COMMENT= An event-driven logic-level simulator for MOS circuis
USE_XLIB= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_WRKSRC= ${WRKSRC}/scripts/
+
+CFLAGS+= -I${X11BASE}/include
+LDFLAGS+= -L${X11BASE}/lib
+CONFIGURE_ENV+= PIC_CFLAGS="-fpic" LDFLAGS="${LDFLAGS}"
+
+OPTIONS= SCHEME "Enable built-in Scheme interpreter" on \
+ TCL "Enable built-in Tcl interpreter" off
+
MAN1= irsim.1
MAN3= irsim-analyzer.3
MAN5= netchange.5
+TK_VER= 8.4
+
.include <bsd.port.pre.mk>
-# othewise patch will complain
-post-extract:
- @${FIND} ${WRKSRC} -name RCS | ${XARGS} ${RM} -rf
+.if defined(WITH_TCL) && !defined(WITHOUT_SCHEME)
+IGNORE= you should select only one interpreter
+.elif !defined(WITH_TCL) && defined(WITHOUT_SCHEME)
+IGNORE= you should select at least one interpreter
+.endif
+
+.if defined(WITH_TCL)
+LIB_DEPENDS+= tk84.1:${PORTSDIR}/x11-toolkits/tk84
+CONFIGURE_ARGS+= --with-tcl=${LOCALBASE}/lib/tcl${TK_VER} \
+ --with-tk=${LOCALBASE}/lib/tk${TK_VER} \
+ --with-tcllibs=${LOCALBASE}/lib/ \
+ --with-tklibs=${LOCALBASE}/lib/ \
+ --with-tclincls=${LOCALBASE}/include/tcl${TK_VER} \
+ --with-tkincls=${LOCALBASE}/include/tk${TK_VER} \
+ --with-interpreter=tcl
+PLIST_SUB+= TCL=""
+.else
+PLIST_SUB+= TCL="@comment "
+.endif
-post-patch:
- @${EGREP} -lr '^#endif[^$$]' ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
- 's|\(^#.*endif\).*|\1|g'
+.if !defined(WITHOUT_SCHEME)
+CONFIGURE_ARGS+= --with-interpreter=scheme
+PLIST_SUB+= SCHEME=""
+.else
+PLIST_SUB+= SCHEME="@comment "
+.endif
.include <bsd.port.post.mk>