aboutsummaryrefslogtreecommitdiff
path: root/cad/klayout
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2011-01-04 12:20:07 +0000
committerHiroki Sato <hrs@FreeBSD.org>2011-01-04 12:20:07 +0000
commit6ba4e9ba414e00c73718a5f86e6d6ff220864cee (patch)
tree3a013eac96541cd5672391329451a5d5c1c75fb7 /cad/klayout
parentc191bf75cd15b75fa886e296cac52cf007dc87d0 (diff)
downloadports-6ba4e9ba414e00c73718a5f86e6d6ff220864cee.tar.gz
ports-6ba4e9ba414e00c73718a5f86e6d6ff220864cee.zip
Notes
Diffstat (limited to 'cad/klayout')
-rw-r--r--cad/klayout/Makefile3
-rw-r--r--cad/klayout/distinfo5
-rw-r--r--cad/klayout/files/patch-build.sh14
-rw-r--r--cad/klayout/files/patch-config-Makefile.conf39
4 files changed, 31 insertions, 30 deletions
diff --git a/cad/klayout/Makefile b/cad/klayout/Makefile
index ed4a6ff753bd..a863d7dad093 100644
--- a/cad/klayout/Makefile
+++ b/cad/klayout/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= klayout
-PORTVERSION= 0.19.3
-PORTREVISION= 1
+PORTVERSION= 0.21.3
CATEGORIES= cad
MASTER_SITES= http://www.klayout.de/
diff --git a/cad/klayout/distinfo b/cad/klayout/distinfo
index 709e62c97c82..da527923ce48 100644
--- a/cad/klayout/distinfo
+++ b/cad/klayout/distinfo
@@ -1,3 +1,2 @@
-MD5 (klayout-0.19.3.tar.gz) = 1c119310499b5ba166c94efd0c5f1e82
-SHA256 (klayout-0.19.3.tar.gz) = ba853af6f27c42faf4c15673eec8f4d534d373c2341ee3c4130825f88fcd3801
-SIZE (klayout-0.19.3.tar.gz) = 1428534
+SHA256 (klayout-0.21.3.tar.gz) = 91cc898841fc7a4529fa063025b19fb834c0ad2b67df80a585d7785c060369de
+SIZE (klayout-0.21.3.tar.gz) = 1966456
diff --git a/cad/klayout/files/patch-build.sh b/cad/klayout/files/patch-build.sh
index 3f084c0f889e..f18dbeb04beb 100644
--- a/cad/klayout/files/patch-build.sh
+++ b/cad/klayout/files/patch-build.sh
@@ -1,15 +1,15 @@
---- build.sh.orig 2009-12-18 07:52:08.000000000 +0900
-+++ build.sh 2009-12-22 02:13:06.000000000 +0900
+--- build.sh.orig 2010-12-28 05:22:08.000000000 +0900
++++ build.sh 2011-01-04 16:58:54.000000000 +0900
@@ -1,7 +1,7 @@
#!/bin/sh
EXEC_NAME=klayout
--OTHER_BIN="strm2gds strm2oas strmcmp strmclip"
-+OTHER_BIN="strm2gds strm2oas strm2txt strmcmp strmclip strmxor"
+-OTHER_BIN=""
++OTHER_BIN="strm2gds strm2oas strm2txt strm2cif strm2dxf strmcmp strmclip strmxor"
CURR_DIR=`pwd`
- USOURCE=$CURR_DIR/src
-@@ -158,11 +158,11 @@
+ PLATFORM="linux-32-gcc-release"
+@@ -217,11 +217,11 @@
;;
esac
@@ -23,7 +23,7 @@
echo "*** ERROR: unable to locate Qt UIC in $QTBIN"
exit 1
fi
-@@ -277,12 +277,12 @@
+@@ -331,12 +331,12 @@
if [ $WIN_CYGWIN = 0 ]; then
echo ""
echo "Final binary is ready in $BIN/$EXEC_NAME."
diff --git a/cad/klayout/files/patch-config-Makefile.conf b/cad/klayout/files/patch-config-Makefile.conf
index 08e6e5255667..c760c982dc2e 100644
--- a/cad/klayout/files/patch-config-Makefile.conf
+++ b/cad/klayout/files/patch-config-Makefile.conf
@@ -1,6 +1,6 @@
---- /dev/null 2009-12-22 01:22:00.000000000 +0900
-+++ config/Makefile.conf.freebsd-32-gcc-release 2009-12-22 01:05:33.000000000 +0900
-@@ -0,0 +1,45 @@
+--- /dev/null 2011-01-04 18:00:00.000000000 +0900
++++ config/Makefile.conf.freebsd-32-gcc-release 2011-01-04 18:03:14.000000000 +0900
+@@ -0,0 +1,48 @@
+
+# Configuration file for
+# gcc, FreeBSD
@@ -9,28 +9,31 @@
+# Compiler options
+
+AR=ar -r
-+CC=gcc
+
-+CCOPT_DEP=-MM -MG -x c++
++# Compiler general
++INC=-I$(TOP_SOURCE) -I$(SOURCE) -I. -I$(QTINCLUDE)
++DEFS=-DQT_THREAD_SUPPORT -DQT3_SUPPORT
+
-+CCWARN=-Wall -pedantic -Wno-deprecated -Woverloaded-virtual \
++# C++
++CXX=gcc
++CXXOPT_DEP=-MM -MG
++CXXWARN=-Wall -pedantic -Wno-deprecated -Woverloaded-virtual \
+ -Wsign-promo -Wsynth -Wno-long-long -Wno-strict-aliasing
++CXXOPT=-c -O3 -o
++CXXOPT_SO=-fPIC $(CXXOPT)
+
-+CCOPT=-c -O -x c++ -o
-+CCOPT_SO=-fPIC $(CCOPT)
-+
-+INC=-I$(TOP_SOURCE) -I$(SOURCE) -I. -I$(QTINCLUDE)
-+
-+DEFS=-DQT_THREAD_SUPPORT -DQT3_SUPPORT
-+
-+# Linker options
++# C
++CC=gcc
++CCOPT_DEP=-MM -MG
++CCWARN=
++CCOPT=-c -O3 -o
+
++# Linker
+LINK=g++
++LOPT=-g -Wl,-E -o
++LOPT_SO=-g -shared -fPIC -o
+
-+LOPT=-Wl,-E -o
-+LOPT_SO=-shared -fPIC -o
-+
-+LIBS=-L$(QTLIB) -pthread -lQtGui -lQtCore -lQtXml -lstdc++ -lcrypt
++LIBS=-L$(QTLIB) -lQtGui -lQtCore -lQtXml -lrt -lstdc++ -lcrypt
+
+.PHONY: install
+install: