aboutsummaryrefslogtreecommitdiff
path: root/cad/klayout
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2014-05-22 03:27:03 +0000
committerHiroki Sato <hrs@FreeBSD.org>2014-05-22 03:27:03 +0000
commit2a8229755adbf615f3c77251a9cf4be4013fd9ce (patch)
treed4aa1738af345e7a0739a487a909636322c69e79 /cad/klayout
parenta890339a6ec73edf9085ef3591fbfa882395da15 (diff)
downloadports-2a8229755adbf615f3c77251a9cf4be4013fd9ce.tar.gz
ports-2a8229755adbf615f3c77251a9cf4be4013fd9ce.zip
Notes
Diffstat (limited to 'cad/klayout')
-rw-r--r--cad/klayout/Makefile3
-rw-r--r--cad/klayout/files/patch-build.sh11
2 files changed, 12 insertions, 2 deletions
diff --git a/cad/klayout/Makefile b/cad/klayout/Makefile
index 9505f35a9305..10c8514f99a0 100644
--- a/cad/klayout/Makefile
+++ b/cad/klayout/Makefile
@@ -29,7 +29,8 @@ PLATFORMKEYWORD=freebsd-32-gcc-release
do-build:
cd ${WRKSRC} && \
- ${SH} build.sh -platform ${PLATFORMKEYWORD} \
+ ${SETENV} CC=${CC} CXX=${CXX} \
+ ${SH} build.sh -platform ${PLATFORMKEYWORD} \
-qtbin ${QT_PREFIX}/bin \
-qtinc ${QT_INCDIR} \
-qtlib ${QT_LIBDIR}
diff --git a/cad/klayout/files/patch-build.sh b/cad/klayout/files/patch-build.sh
index 8911725e541c..64bd14c63aad 100644
--- a/cad/klayout/files/patch-build.sh
+++ b/cad/klayout/files/patch-build.sh
@@ -1,5 +1,5 @@
--- build.sh.orig 2014-02-24 05:44:13.000000000 +0900
-+++ build.sh 2014-03-14 21:49:48.000000000 +0900
++++ build.sh 2014-05-22 11:58:57.000000000 +0900
@@ -1,7 +1,7 @@
#!/bin/sh
@@ -19,6 +19,15 @@
*)
# Assume Linux for the remaining variants
case `arch` in
+@@ -261,7 +264,7 @@
+ echo " 64 bit coordinates enabled"
+ fi
+
+-gcc_path=`type gcc 2>/dev/null`
++gcc_path=`type $CC 2>/dev/null`
+ if [ "$gcc_path" = "" ]; then
+ echo "*** ERROR: unable to locate gcc in path"
+ exit 1
@@ -284,11 +287,11 @@
;;
esac