aboutsummaryrefslogtreecommitdiff
path: root/cad/mars
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-12-09 19:09:41 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-12-09 19:09:41 +0000
commit5977dc1bf2e4de2dd1e173c061f8db70cdf7c53a (patch)
treee58598658873ccad9e189bf323d89e346da36df4 /cad/mars
parent51d92e7babb9e965163402257113c778b629cb3e (diff)
downloadports-5977dc1bf2e4de2dd1e173c061f8db70cdf7c53a.tar.gz
ports-5977dc1bf2e4de2dd1e173c061f8db70cdf7c53a.zip
Notes
Diffstat (limited to 'cad/mars')
-rw-r--r--cad/mars/Makefile5
-rw-r--r--cad/mars/files/patch-0534
-rw-r--r--cad/mars/files/patch-0934
-rw-r--r--cad/mars/files/patch-1010
4 files changed, 75 insertions, 8 deletions
diff --git a/cad/mars/Makefile b/cad/mars/Makefile
index f5baba0fec95..f523468b9324 100644
--- a/cad/mars/Makefile
+++ b/cad/mars/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mars
PORTVERSION= 2.1
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= ftp://ftp.cs.umd.edu/pub/sdag/MaRS/
DISTNAME= MaRS-${PORTVERSION}
@@ -31,10 +32,6 @@ MAN1= mars.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile with recent gcc: needs stdarg.h, not varargs.h"
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mars ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/man1/mars.1 ${PREFIX}/man/man1
diff --git a/cad/mars/files/patch-05 b/cad/mars/files/patch-05
index 2ab0dd56b91f..7bad1e75b276 100644
--- a/cad/mars/files/patch-05
+++ b/cad/mars/files/patch-05
@@ -1,9 +1,35 @@
---- sim/log.c.orig Tue Oct 6 20:52:51 1992
-+++ sim/log.c Mon Nov 18 21:18:07 1996
-@@ -80,7 +80,11 @@
+--- log.c.orig Wed Oct 7 04:52:51 1992
++++ log.c Tue Dec 9 19:59:48 2003
+@@ -23,7 +23,7 @@
+ #include "packet.h"
+ #include "event.h"
+ #include "log.h"
+-#include <varargs.h>
++#include <stdarg.h>
+
+ #ifdef DEBUG
+ extern Log debug_log;
+@@ -59,13 +59,7 @@
+ /* Debugging log-- writes name of component along with message */
+ /*VARARGS4*/
+ /*dbg_write(l, level, c, format, args)*/
+-dbg_write(l, level, c, format, va_alist)
+- Log l;
+- int level;
+- Component *c;
+- char *format;
+- va_dcl
+-
++dbg_write(Log l, int level, Component *c, char *format, ... )
+ {
+ va_list p;
+
+@@ -79,8 +73,12 @@
+ }
/* Add the time */
fprintf(l, "%d ", ev_now());
- va_start(p);
+- va_start(p);
++ va_start(p, format);
+#ifdef __FreeBSD__
+ vfprintf(l, format, p);
+#else
diff --git a/cad/mars/files/patch-09 b/cad/mars/files/patch-09
new file mode 100644
index 000000000000..a6276e0d0773
--- /dev/null
+++ b/cad/mars/files/patch-09
@@ -0,0 +1,34 @@
+--- sim/subr.c.orig Tue Dec 9 20:00:42 2003
++++ sim/subr.c Tue Dec 9 20:01:31 2003
+@@ -6,7 +6,7 @@
+ #include <ctype.h>
+ #include <sys/types.h>
+ #include <stdio.h>
+-#include <varargs.h>
++#include <stdarg.h>
+ #include <math.h>
+ #include "sim.h"
+ #include "q.h"
+@@ -610,12 +610,7 @@
+
+ /*VARARGS4*/
+ Neighbor *
+-add_neighbor(c, neighc, max_num_neighbors, num_classes, va_alist)
+- register Component *c; /* Comp to add neighbor to */
+- register Component *neighc; /* New neighbor */
+- int max_num_neighbors; /* Max number neighbors allowed (0=infinite)*/
+- int num_classes; /* How many classes follow */
+- va_dcl
++add_neighbor(register Component *c, register Component *neighc, int max_num_neighbors, int num_classes, ... )
+ {
+ va_list vp;
+ register Neighbor *n;
+@@ -644,7 +639,7 @@
+ if (num_classes > 0) {
+ /* Final check--may sure the new neighbor is one of the
+ legal classes */
+- va_start(vp);
++ va_start(vp, num_classes);
+ notlegal = TRUE;
+ while (num_classes--)
+ if (neighc->co_class == va_arg(vp, int)) {
diff --git a/cad/mars/files/patch-10 b/cad/mars/files/patch-10
new file mode 100644
index 000000000000..d409bf9d0005
--- /dev/null
+++ b/cad/mars/files/patch-10
@@ -0,0 +1,10 @@
+--- include/component.h.orig Tue Dec 9 20:04:47 2003
++++ include/component.h Tue Dec 9 20:05:04 2003
+@@ -153,6 +153,6 @@
+ } Neighbor;
+
+ Neighbor *find_neighbor();
+-Neighbor *add_neighbor();
++Neighbor *add_neighbor(register Component *c, register Component *neighc, int max_num_neighbors, int num_classes, ... );
+ Param *param_init();
+ #endif /* COMPONENT_H */