aboutsummaryrefslogtreecommitdiff
path: root/cad/netgen/files
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2010-07-01 19:47:47 +0000
committerStefan Walter <stefan@FreeBSD.org>2010-07-01 19:47:47 +0000
commita9b0be5f5818061de8120b072b447e0ee63d8148 (patch)
tree2d6cc0b3e9d5a3bb0a811ffd1cd6cb5b63021cb1 /cad/netgen/files
parent49494235f5033ae899aca186b0932fe427c7355f (diff)
downloadports-a9b0be5f5818061de8120b072b447e0ee63d8148.tar.gz
ports-a9b0be5f5818061de8120b072b447e0ee63d8148.zip
Notes
Diffstat (limited to 'cad/netgen/files')
-rw-r--r--cad/netgen/files/patch-Makefile64
-rw-r--r--cad/netgen/files/patch-demoapp::Makefile18
-rw-r--r--cad/netgen/files/patch-libsrc::makefile.inc23
-rw-r--r--cad/netgen/files/patch-libsrc_csg_csg.hpp11
-rw-r--r--cad/netgen/files/patch-libsrc_linalg_densemat.hpp10
-rw-r--r--cad/netgen/files/patch-libsrc_makefile.mach.FREEBSD16
-rw-r--r--cad/netgen/files/patch-libsrc_meshing_meshing.hpp11
-rw-r--r--cad/netgen/files/patch-libsrc_meshing_meshtype.hpp11
-rw-r--r--cad/netgen/files/patch-libsrc_visualization_mvdraw.hpp10
-rw-r--r--cad/netgen/files/patch-libsrc_visualization_tlmeshing.cpp13
-rw-r--r--cad/netgen/files/patch-ng_Makefile.am11
-rw-r--r--cad/netgen/files/patch-ng_Makefile.in11
-rw-r--r--cad/netgen/files/patch-ng_ng.tcl11
-rw-r--r--cad/netgen/files/patch-ng_ngappinit.cpp11
-rw-r--r--cad/netgen/files/patch-ng_onetcl.cpp11
-rw-r--r--cad/netgen/files/patch-ngcore::Makefile28
-rw-r--r--cad/netgen/files/patch-ngsolve.Makefile19
-rw-r--r--cad/netgen/files/patch-ngsolve::tutorial::Makefile47
-rw-r--r--cad/netgen/files/patch-ngsolve_basiclinalg_calcinverse.cpp11
-rw-r--r--cad/netgen/files/patch-ngsolve_basiclinalg_expr3.hpp70
-rw-r--r--cad/netgen/files/patch-ngsolve_comp_postproc.cpp21
-rw-r--r--cad/netgen/files/patch-ngsolve_linalg_order.cpp11
-rw-r--r--cad/netgen/files/patch-ngsolve_linalg_order.hpp11
-rw-r--r--cad/netgen/files/patch-ngtcltk_ngappinit.cpp45
-rw-r--r--cad/netgen/files/patch-togl::Makefile43
-rw-r--r--cad/netgen/files/patch-togl::togl.cpp20
-rw-r--r--cad/netgen/files/pkg-message.in9
27 files changed, 64 insertions, 513 deletions
diff --git a/cad/netgen/files/patch-Makefile b/cad/netgen/files/patch-Makefile
deleted file mode 100644
index 09311a5c64d5..000000000000
--- a/cad/netgen/files/patch-Makefile
+++ /dev/null
@@ -1,64 +0,0 @@
---- Makefile.orig Tue Nov 16 15:29:39 2004
-+++ Makefile Mon May 28 22:20:53 2007
-@@ -21,7 +21,7 @@
- # system libraries:
- #
- #
--tcltklib = -ltix8.1.8.4 -ltk8.4 -ltcl8.4
-+tcltklib = `echo $(TIX_BUILD_LIB_SPEC)` `echo $(TK_LIB_SPEC)` `echo $(TCL_LIB_FLAG)`
- # tcltklib = -ltix4.1.8.3 -ltk8.3 -ltcl8.3
- # tcltklib = -ltix8.2 -ltk8.3 -ltcl8.3
- # tcltklib = /usr/lib/libtix8.1.8.3.so -ltk8.3 -ltcl8.3
-@@ -29,7 +29,7 @@
- # tcltklib = -ltix8.2 -ltk8.4 -ltcl8.4
- #
- #
--syslib = $(tcltklib) -lGL -lGLU -lX11 -lXi -lm -ldl -lpthread $(SYSLIB2)
-+syslib = $(tcltklib) -lGL -lGLU -lX11 -lXi -lm $(PTHREAD_LIBS) $(SYSLIB2)
- # (maybe you have to remove -ldl)
- #
- #
-@@ -43,12 +43,12 @@
- # OCCINC_DIR=$(OCC_DIR)/inc
- # OCCLIB_DIR=$(OCC_DIR)/lib
- #
--OCC_DIR=/opt/OpenCASCADE5.2
--OCCINC_DIR=$(OCC_DIR)/ros/inc
--OCCLIB_DIR=$(OCC_DIR)/ros/lin/lib
-+#OCC_DIR=/opt/OpenCASCADE5.2
-+#OCCINC_DIR=$(OCC_DIR)/ros/inc
-+#OCCLIB_DIR=$(OCC_DIR)/ros/lin/lib
-
- # add libs in makefile.mach.$(MACHINE)
--# occlib = -L$(OCCLIB_DIR) -lTKIGES -lTKBRep -lTKSTEP -lTKSTL
-+# occlib = -L$(OCCLIB_DIR) -lTKIGES -lTKBRep -lTKSTEP -lTKSTL -pthread
- #
- include $(LIBSRC_DIR)/makefile.mach.$(MACHINE)
- #
-@@ -58,7 +58,7 @@
- #
- #
- #
--CPLUSPLUSFLAGS1 = -c -I$(LIBSRC_DIR)/include -I$(OCCINC_DIR) -I./ngsolve/include -Ilibsrc/interface -DOPENGL $(METISINC)
-+CPLUSPLUSFLAGS1 = -c -I$(LIBSRC_DIR)/include -I$(OCCINC_DIR) -I./ngsolve/include -Ilibsrc/interface -DOPENGL $(METISINC) $(PTHREAD_CFLAGS)
- #
- LINKFLAGS1 = -lGL -lGLU -lX11 -lXext -lXmu
- #
-@@ -74,7 +74,7 @@
- # Additional NETGEN Applications:
- #
- # the demo add-on application:
--# appdemo = -L./demoapp -ldemoapp
-+appdemo = -L./demoapp -ldemoapp
- #
- # appaddon = -L./addon -laddon
-
-@@ -102,7 +102,7 @@
- cd libsrc; $(MAKE)
- #
- applib:
--# cd demoapp; $(MAKE);
-+ cd demoapp; $(MAKE);
- # cd addon; $(MAKE)
- # cd ngsolve; $(MAKE);
- # cd metis; $(MAKE)
diff --git a/cad/netgen/files/patch-demoapp::Makefile b/cad/netgen/files/patch-demoapp::Makefile
deleted file mode 100644
index 9d9dabf76839..000000000000
--- a/cad/netgen/files/patch-demoapp::Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
---- demoapp/Makefile.orig Tue Feb 3 11:47:04 2004
-+++ demoapp/Makefile Mon May 3 22:16:08 2004
-@@ -10,13 +10,13 @@
- .SUFFIXES: .cc .o
- #
- .cc.o:
-- $(CPLUSPLUS) -c -O2 $<
-+ $(CPLUSPLUS) -c $(CPLUSPLUSFLAGS2) $<
- #
- #
- # make lib from sources:
- #
- $(lib):: $(src)
-- $(CPLUSPLUS) -c -O2 -I../libsrc/interface $(CPLUSPLUSFLAGS2) $?
-+ $(CPLUSPLUS) -c -I../libsrc/interface $(CPLUSPLUSFLAGS2) $(CPLUSPLUSFLAGS3) $?
- $(AR) $(ARFLAGS) $@ *.o
- -$(RM) *.o
- #
diff --git a/cad/netgen/files/patch-libsrc::makefile.inc b/cad/netgen/files/patch-libsrc::makefile.inc
deleted file mode 100644
index dff04e88ebcb..000000000000
--- a/cad/netgen/files/patch-libsrc::makefile.inc
+++ /dev/null
@@ -1,23 +0,0 @@
---- libsrc/makefile.inc.orig Wed Aug 25 13:06:28 2004
-+++ libsrc/makefile.inc Wed Nov 17 21:52:12 2004
-@@ -24,9 +24,9 @@
- .SUFFIXES: .cpp .c .o
- #
- .cpp.o:
-- $(CPLUSPLUS) $(CPLUSPLUSFLAGS1) $(CPLUSPLUSFLAGS2) $(CPLUSPLUSFLAGSLIBRARY) $<
-+ $(CPLUSPLUS) $(CPLUSPLUSFLAGS1) $(CPLUSPLUSFLAGS2) $(CPLUSPLUSFLAGS3) $(CPLUSPLUSFLAGSLIBRARY) $<
- .c.o:
-- $(CPLUSPLUS) $(CPLUSPLUSFLAGS1) $(CPLUSPLUSFLAGS2) $(CPLUSPLUSFLAGSLIBRARY) $<
-+ $(CPLUSPLUS) $(CPLUSPLUSFLAGS1) $(CPLUSPLUSFLAGS2) $(CPLUSPLUSFLAGS3) $(CPLUSPLUSFLAGSLIBRARY) $<
- #
- #
- $(LIBB):: $(LIB_DIR)
-@@ -34,7 +34,7 @@
- # make lib from sources:
- #
- $(LIBB):: $(src)
-- $(CPLUSPLUS) $(CPLUSPLUSFLAGS1) $(CPLUSPLUSFLAGS2) $(CPLUSPLUSFLAGSLIBRARY) $?
-+ $(CPLUSPLUS) $(CPLUSPLUSFLAGS1) $(CPLUSPLUSFLAGS2) $(CPLUSPLUSFLAGS3) $(CPLUSPLUSFLAGSLIBRARY) $?
- @$(AR) $(ARFLAGS) $@ *.o
- -@$(RM) *.o
- -@$(RANLIB) $@
diff --git a/cad/netgen/files/patch-libsrc_csg_csg.hpp b/cad/netgen/files/patch-libsrc_csg_csg.hpp
deleted file mode 100644
index a190167a5388..000000000000
--- a/cad/netgen/files/patch-libsrc_csg_csg.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./libsrc/csg/csg.hpp.orig Thu Oct 7 00:10:13 2004
-+++ ./libsrc/csg/csg.hpp Tue May 29 22:54:13 2007
-@@ -22,7 +22,7 @@
- #ifndef SMALLLIB
- #define _INCLUDE_MORE
- #endif
--#ifdef LINUX
-+#if defined(LINUX ) || defined(FREEBSD)
- #define _INCLUDE_MORE
- #endif
-
diff --git a/cad/netgen/files/patch-libsrc_linalg_densemat.hpp b/cad/netgen/files/patch-libsrc_linalg_densemat.hpp
deleted file mode 100644
index ec3d7c0b9d2e..000000000000
--- a/cad/netgen/files/patch-libsrc_linalg_densemat.hpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- libsrc/linalg/densemat.hpp.orig Wed Nov 10 14:22:43 2004
-+++ libsrc/linalg/densemat.hpp Tue May 29 18:45:09 2007
-@@ -255,6 +255,6 @@
-
-
-
--
-+extern void CalcInverse (const DenseMatrix & m1, DenseMatrix & m2);
-
- #endif
diff --git a/cad/netgen/files/patch-libsrc_makefile.mach.FREEBSD b/cad/netgen/files/patch-libsrc_makefile.mach.FREEBSD
deleted file mode 100644
index 64fc361fdd2e..000000000000
--- a/cad/netgen/files/patch-libsrc_makefile.mach.FREEBSD
+++ /dev/null
@@ -1,16 +0,0 @@
---- libsrc/makefile.mach.FREEBSD.orig 2004-05-06 05:24:29.000000000 +0800
-+++ libsrc/makefile.mach.FREEBSD 2008-09-01 22:24:10.000000000 +0800
-@@ -18,8 +18,11 @@
- tcltklib = `echo $(TIX_BUILD_LIB_SPEC)` `echo $(TK_LIB_SPEC)` `echo $(TCL_LIB_FLAG)`
-
- CFLAGS2 =
--CPLUSPLUSFLAGS2 = $(CXXFLAGS) -I$(X11BASE)/include -DLINUX -DOPENGL
--CPLUSPLUSFLAGS3 = -I$(LIBSRC_DIR)/step `echo $(TCL_INCLUDE_SPEC)` `echo -I$(TK_PREFIX)`/include/tk`echo $(TK_VERSION)`
-+CPLUSPLUSFLAGS2 = $(CXXFLAGS) -I$(LOCALBASE)/include -DFREEBSD -DOPENGL -DNGSOLVE \
-+ -ftemplate-depth-99 -finline-limit=20000 \
-+ -funroll-loops
-+
-+CPLUSPLUSFLAGS3 = -I$(LIBSRC_DIR)/step -I$(TCL_INCLUDEDIR) -I$(TK_INCLUDEDIR)
- #
- LINKFLAGS2 = -L$(LOCALBASE)/lib -L$(X11BASE)/lib
-
diff --git a/cad/netgen/files/patch-libsrc_meshing_meshing.hpp b/cad/netgen/files/patch-libsrc_meshing_meshing.hpp
deleted file mode 100644
index 22f742e085b3..000000000000
--- a/cad/netgen/files/patch-libsrc_meshing_meshing.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./libsrc/meshing/meshing.hpp.orig Thu Oct 7 00:23:46 2004
-+++ ./libsrc/meshing/meshing.hpp Tue May 29 22:55:52 2007
-@@ -34,7 +34,7 @@
- #ifndef SMALLLIB
- #define _INCLUDE_MORE
- #endif
--#ifdef LINUX
-+#if defined(LINUX ) || defined(FREEBSD)
- #define _INCLUDE_MORE
- #endif
-
diff --git a/cad/netgen/files/patch-libsrc_meshing_meshtype.hpp b/cad/netgen/files/patch-libsrc_meshing_meshtype.hpp
deleted file mode 100644
index 8d28315775bd..000000000000
--- a/cad/netgen/files/patch-libsrc_meshing_meshtype.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- libsrc/meshing/meshtype.hpp.orig Sun Nov 7 17:12:10 2004
-+++ libsrc/meshing/meshtype.hpp Tue May 29 18:43:39 2007
-@@ -962,7 +962,7 @@
- class Identifications
- {
- private:
-- Mesh & mesh;
-+ class Mesh & mesh;
-
- /// identify points (thin layers, periodic b.c.)
- INDEX_2_HASHTABLE<int> * identifiedpoints;
diff --git a/cad/netgen/files/patch-libsrc_visualization_mvdraw.hpp b/cad/netgen/files/patch-libsrc_visualization_mvdraw.hpp
deleted file mode 100644
index 828ed76ff080..000000000000
--- a/cad/netgen/files/patch-libsrc_visualization_mvdraw.hpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- libsrc/visualization/mvdraw.hpp.orig
-+++ libsrc/visualization/mvdraw.hpp
-@@ -250,6 +250,7 @@
- int seltria;
- };
-
-+extern VisualSceneSTLMeshing vsstlmeshing;
-
-
-
diff --git a/cad/netgen/files/patch-libsrc_visualization_tlmeshing.cpp b/cad/netgen/files/patch-libsrc_visualization_tlmeshing.cpp
deleted file mode 100644
index c61dc641e7ca..000000000000
--- a/cad/netgen/files/patch-libsrc_visualization_tlmeshing.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- libsrc/visualization/stlmeshing.cpp.orig
-+++ libsrc/visualization/stlmeshing.cpp
-@@ -1062,9 +1062,9 @@
- }
-
-
-+VisualSceneSTLMeshing vsstlmeshing;
-
-
--VisualSceneSTLMeshing vsstlmeshing;
-
- #endif
-
diff --git a/cad/netgen/files/patch-ng_Makefile.am b/cad/netgen/files/patch-ng_Makefile.am
new file mode 100644
index 000000000000..2050bc4835af
--- /dev/null
+++ b/cad/netgen/files/patch-ng_Makefile.am
@@ -0,0 +1,11 @@
+--- ng/Makefile.am.orig 2010-05-20 19:08:54.000000000 +0700
++++ ng/Makefile.am 2010-05-27 16:46:45.000000000 +0700
+@@ -16,7 +16,7 @@
+ $(top_builddir)/libsrc/gprim/libgprim.la \
+ $(top_builddir)/libsrc/linalg/libla.la \
+ $(top_builddir)/libsrc/general/libgen.la \
+- $(OCCLIBS) -L$(TK_BIN_DIR)/Togl1.7 $(TOGLLIBDIR) -lTogl1.7 $(LIBGLU) $(TK_LIB_SPEC) $(TCL_LIB_SPEC) $(MPI_LIBS) $(FFMPEG_LIBS) $(JPEGLIB_LIBS) $(PKG_LIBS)
++ $(OCCLIBS) -L$(TK_BIN_DIR)/Togl-1.7 $(TOGLLIBDIR) -ltogl $(LIBGLU) $(TK_LIB_SPEC) $(TCL_LIB_SPEC) $(MPI_LIBS) $(FFMPEG_LIBS) $(JPEGLIB_LIBS) $(PKG_LIBS)
+
+ # add for static linkage of ngsolve:
+ # /opt/netgen/lib/libngsolve.a /opt/netgen/lib/libngcomp.a /opt/netgen/lib/libngcomp.a /opt/netgen/lib/libngfemng.a /opt/netgen/lib/libngmg.a /opt/netgen/lib/libngla.a /opt/netgen/lib/libngbla.a /opt/netgen/lib/libngstd.a -L/opt/intel/mkl/10.2.1.017/lib/em64t /opt/intel/mkl/10.2.1.017/lib/em64t/libmkl_solver_lp64.a -lmkl_intel_lp64 -lmkl_gnu_thread -lmkl_core
diff --git a/cad/netgen/files/patch-ng_Makefile.in b/cad/netgen/files/patch-ng_Makefile.in
new file mode 100644
index 000000000000..14e039e8a582
--- /dev/null
+++ b/cad/netgen/files/patch-ng_Makefile.in
@@ -0,0 +1,11 @@
+--- ng/Makefile.in.orig 2010-06-03 15:08:20.000000000 +0700
++++ ng/Makefile.in 2010-06-03 15:08:42.000000000 +0700
+@@ -287,7 +287,7 @@
+ $(top_builddir)/libsrc/gprim/libgprim.la \
+ $(top_builddir)/libsrc/linalg/libla.la \
+ $(top_builddir)/libsrc/general/libgen.la \
+- $(OCCLIBS) -L$(TK_BIN_DIR)/Togl1.7 $(TOGLLIBDIR) -lTogl1.7 $(LIBGLU) $(TK_LIB_SPEC) $(TCL_LIB_SPEC) $(MPI_LIBS) $(FFMPEG_LIBS) $(JPEGLIB_LIBS) $(PKG_LIBS)
++ $(OCCLIBS) -L$(TK_BIN_DIR)/Togl1.7 $(TOGLLIBDIR) -ltogl $(LIBGLU) $(TK_LIB_SPEC) $(TCL_LIB_SPEC) $(MPI_LIBS) $(FFMPEG_LIBS) $(JPEGLIB_LIBS) $(PKG_LIBS)
+
+
+ # add for static linkage of ngsolve:
diff --git a/cad/netgen/files/patch-ng_ng.tcl b/cad/netgen/files/patch-ng_ng.tcl
new file mode 100644
index 000000000000..d0da1110008c
--- /dev/null
+++ b/cad/netgen/files/patch-ng_ng.tcl
@@ -0,0 +1,11 @@
+--- ng/ng.tcl.orig 2010-06-08 09:33:22.000000000 +0700
++++ ng/ng.tcl 2010-06-08 09:33:39.000000000 +0700
+@@ -26,7 +26,7 @@
+ set ngdir $env(NETGENDIR)
+ }
+ if { [string length $ngdir] == 0 } {
+- set ngdir "."
++ set ngdir "/usr/local/bin"
+ }
+
+ set nguserdir ""
diff --git a/cad/netgen/files/patch-ng_ngappinit.cpp b/cad/netgen/files/patch-ng_ngappinit.cpp
new file mode 100644
index 000000000000..d9ba3ff9b3db
--- /dev/null
+++ b/cad/netgen/files/patch-ng_ngappinit.cpp
@@ -0,0 +1,11 @@
+--- ng/ngappinit.cpp.orig 2010-06-08 09:13:06.000000000 +0700
++++ ng/ngappinit.cpp 2010-06-08 09:13:20.000000000 +0700
+@@ -151,7 +151,7 @@
+ if (getenv ("NETGENDIR") && strlen (getenv ("NETGENDIR")))
+ ngdir = getenv ("NETGENDIR");
+ else
+- ngdir = ".";
++ ngdir = "/usr/local/bin";
+
+ verbose = parameters.GetDefineFlag ("V");
+
diff --git a/cad/netgen/files/patch-ng_onetcl.cpp b/cad/netgen/files/patch-ng_onetcl.cpp
new file mode 100644
index 000000000000..94877f1c15ab
--- /dev/null
+++ b/cad/netgen/files/patch-ng_onetcl.cpp
@@ -0,0 +1,11 @@
+--- ng/onetcl.cpp.orig 2010-06-08 09:26:24.000000000 +0700
++++ ng/onetcl.cpp 2010-06-08 09:26:48.000000000 +0700
+@@ -16,7 +16,7 @@
+ " set ngdir $env(NETGENDIR) \n",\
+ "}\n",\
+ "if { [string length $ngdir] == 0 } {\n",\
+-" set ngdir \".\" \n",\
++" set ngdir \"/usr/local/bin\" \n",\
+ "}\n",\
+ "\n",\
+ "\n",\
diff --git a/cad/netgen/files/patch-ngcore::Makefile b/cad/netgen/files/patch-ngcore::Makefile
deleted file mode 100644
index 73d9d8d2a03a..000000000000
--- a/cad/netgen/files/patch-ngcore::Makefile
+++ /dev/null
@@ -1,28 +0,0 @@
---- ngcore/Makefile.orig Fri Jul 2 23:21:25 2004
-+++ ngcore/Makefile Sun Nov 21 18:11:55 2004
-@@ -108,6 +108,7 @@
- ../libsrc/general/mystring.cpp
- #
- #
-+include ../libsrc/makefile.mach.$(MACHINE)
- #
- allsrc = $(main).cpp $(src)
- #
-@@ -116,14 +117,14 @@
- #
- #
- .cpp.o:
-- gcc -c -O2 -w $< -o $(<:.cpp=.o) -I../libsrc/include -DNO_PARALLEL_THREADS
-+ $(CPLUSPLUS) -c $(CXXFLAGS) -w $< -o $(<:.cpp=.o) -I../libsrc/include -DNO_PARALLEL_THREADS
- #
- $(main) : $(main).o libng.a
-- gcc -w -o $@ $(main).o -L. -lng -lm -lpthread -lstdc++
-+ $(CPLUSPLUS) -w -o $@ $(main).o -L. -lng -lm $(PTHREAD_LIBS) $(SYSLIB2)
- #
- #
- libng.a : $(src:.cpp=.o)
-- ar r libng.a $(src:.cpp=.o)
-+ $(AR) r libng.a $(src:.cpp=.o)
- #
- clean:
- -@rm -r ngcore *.o */*.o */*/*.o */*/*/*.o */*/ii_files
diff --git a/cad/netgen/files/patch-ngsolve.Makefile b/cad/netgen/files/patch-ngsolve.Makefile
deleted file mode 100644
index 00e79fd8a772..000000000000
--- a/cad/netgen/files/patch-ngsolve.Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
---- ngsolve/Makefile.orig Tue Nov 16 10:14:27 2004
-+++ ngsolve/Makefile Wed Nov 17 23:18:39 2004
-@@ -89,14 +89,14 @@
- pebblesinc = -I../../pebbles_old/libsrc/setup -I../../pebbles_old/libsrc/solver -I../../pebbles_old/libsrc/prepro -I../../pebbles_old/libsrc/parallel -I../../pebbles_old/libsrc
- #
- $(lib):: $(src)
-- $(CPLUSPLUS) -c -I. -I../libsrc -I../libsrc/include -I../libsrc/interface -Iinclude $(pebblesinc) $(CPLUSPLUSFLAGS2) -DNETGEN_ELTRANS $?
-+ $(CPLUSPLUS) -c -I. -I../libsrc -I../libsrc/include -I../libsrc/interface -Iinclude $(pebblesinc) $(CPLUSPLUSFLAGS2) $(CPLUSPLUSFLAGS3) -DNETGEN_ELTRANS $?
- $(AR) $(ARFLAGS) $@ *.o
- mv *.o ../lib/$(MACHINE)
- -$(RM) *.o
- -@$(RANLIB) $@
- #
- $(lib2):: $(src2)
-- $(CPLUSPLUS) -c -I. -I../libsrc/interface -Iinclude $(CPLUSPLUSFLAGS2) $?
-+ $(CPLUSPLUS) -c -I. -I../libsrc/interface -Iinclude $(CPLUSPLUSFLAGS2) $(CPLUSPLUSFLAGS3) $?
- $(AR) $(ARFLAGS) $@ *.o
- -$(RM) *.o
- -@$(RANLIB) $@
diff --git a/cad/netgen/files/patch-ngsolve::tutorial::Makefile b/cad/netgen/files/patch-ngsolve::tutorial::Makefile
deleted file mode 100644
index c3f199fa2329..000000000000
--- a/cad/netgen/files/patch-ngsolve::tutorial::Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
---- ./ngsolve/tutorial/Makefile.orig Tue Nov 16 09:57:27 2004
-+++ ./ngsolve/tutorial/Makefile Sun Nov 21 18:20:37 2004
-@@ -1,10 +1,12 @@
--COMPILE = gcc -O2 -I../include -I../../libsrc/include -finline-limit=50000 -ftemplate-depth-99 -mcpu=pentium4 -funroll-loops -fforce-addr
-+include ../libsrc/makefile.mach.$(MACHINE)
-+
-+COMPILE = $(CPLUSPLUS) $(CXXFLAGS) -I../include -I../../libsrc/include -finline-limit=50000 -ftemplate-depth-99 -funroll-loops -fforce-addr
- # COMPILE = /opt/gcc40/bin/gcc -O2 -I../include -I../../libsrc/include -funroll-loops
- # -finline-limit=10000 -march=pentium4 -fforce-addr -ftemplate-depth-99
- # COMPILE = icc -xB -O3 -Ob2 -I../include -Qoption,c,-ip_ninl_max_stats=10000 -Qoption,c,-ip_ninl_min_stats=100 -Qoption,c,-ip_ninl_max_total_stats=4000
- # COMPILE = icc -xN -O3 -Ob2 -I../include -opt_report_fileopt.rep -Qoption,c,-ip_ninl_max_stats=10000 -Qoption,c,-ip_ninl_min_stats=100 -Qoption,c,-ip_ninl_max_total_stats=4000
-
--stdlib = -lm -pthread -lstdc++
-+stdlib = -lm $(PTHREAD_LIBS) $(SYSLIB2)
- # stdlib = -L/opt/gcc40/lib -lm -pthread /opt/gcc40/lib/libstdc++.a
-
- default:
-@@ -38,25 +40,25 @@
- libngstd.a: ../ngstd/bitarray.cpp ../ngstd/blockalloc.cpp ../ngstd/evalfunc.cpp ../ngstd/exception.cpp ../ngstd/flags.cpp ../ngstd/localheap.cpp ../ngstd/symboltable.cpp ../ngstd/table.cpp ../ngstd/templates.cpp ../../libsrc/general/moveablemem.cpp ../../libsrc/general/dynamicmem.cpp ../../libsrc/general/ngexception.cpp
- @-rm *.o
- $(COMPILE) -c $?
-- ar -r libngstd.a *.o
-+ $(AR) -r libngstd.a *.o
- @-rm *.o
-
- libngbla.a: ../basiclinalg/bandmatrix.cpp ../basiclinalg/eigensystem.cpp ../basiclinalg/calcinverse.cpp ../basiclinalg/vecmat.cpp ../basiclinalg/cholesky.cpp
- @-rm *.o
- $(COMPILE) -c $?
-- ar -r libngbla.a *.o
-+ $(AR) -r libngbla.a *.o
- @-rm *.o
-
- libngla.a:
- @-rm *.o
- $(COMPILE) -c ../linalg/*.cpp
-- ar -r libngla.a *.o
-+ $(AR) -r libngla.a *.o
- @-rm *.o
-
- libngfem.a: ../fem/bdbequations.cpp ../fem/hdivhofe.cpp ../fem/coefficient.cpp ../fem/highorderfe.cpp ../fem/elementtopology.cpp ../fem/integrator.cpp ../fem/equilibrium.cpp ../fem/intrule.cpp ../fem/fastmat.cpp ../fem/l2hofe.cpp ../fem/finiteelement.cpp ../fem/maxwellintegrator.cpp ../fem/h1hofe.cpp ../fem/hcurlfe.cpp ../fem/recursive_pol.cpp ../fem/hcurlhofe.cpp ../fem/recursive_pol_trig.cpp ../fem/hdiv_equations.cpp ../fem/specialelement.cpp ../fem/hdivfe.cpp
-
- @-rm *.o
- $(COMPILE) -c $?
-- ar -r libngfem.a *.o
-+ $(AR) -r libngfem.a *.o
- @-rm *.o
-
diff --git a/cad/netgen/files/patch-ngsolve_basiclinalg_calcinverse.cpp b/cad/netgen/files/patch-ngsolve_basiclinalg_calcinverse.cpp
deleted file mode 100644
index 0e2ac09956b8..000000000000
--- a/cad/netgen/files/patch-ngsolve_basiclinalg_calcinverse.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ngsolve/basiclinalg/calcinverse.cpp.orig Tue Nov 16 09:38:35 2004
-+++ ngsolve/basiclinalg/calcinverse.cpp Tue May 29 19:27:48 2007
-@@ -10,7 +10,7 @@
- {
- double sum = 0;
- for (int i = 0; i < N; i++)
-- sum += abs(m(i,i));
-+ sum += std::abs(m(i,i));
- return sum;
- }
-
diff --git a/cad/netgen/files/patch-ngsolve_basiclinalg_expr3.hpp b/cad/netgen/files/patch-ngsolve_basiclinalg_expr3.hpp
deleted file mode 100644
index 74d85379a040..000000000000
--- a/cad/netgen/files/patch-ngsolve_basiclinalg_expr3.hpp
+++ /dev/null
@@ -1,70 +0,0 @@
---- ngsolve/basiclinalg/expr3.hpp.orig Sat Oct 2 10:26:56 2004
-+++ ngsolve/basiclinalg/expr3.hpp Tue May 29 19:33:11 2007
-@@ -851,6 +851,16 @@
- /**
- Inner product
- */
-+inline double InnerProduct ( const double& a, const double& b )
-+{
-+ return a * b;
-+}
-+
-+inline Complex InnerProduct ( const Complex& a, const Complex b)
-+{
-+ return a * b;
-+}
-+
- template <class TA, class TB>
- inline typename TA::TSCAL
- InnerProduct (const MatExpr<TA> & a, const MatExpr<TB> & b)
-@@ -862,16 +872,6 @@
- return sum;
- }
-
--inline double InnerProduct (double a, double b)
--{
-- return a * b;
--}
--
--inline Complex InnerProduct (Complex a, Complex b)
--{
-- return a * b;
--}
--
-
- /* **************************** Trace **************************** */
-
-@@ -889,16 +889,6 @@
- /* **************************** L2Norm **************************** */
-
- /// Euklidean norm squared
--template <class TA>
--inline double L2Norm2 (const MatExpr<TA> & v)
--{
-- typedef typename TA::TSCAL TSCAL;
-- double sum = 0;
-- for (int i = 0; i < v.Height(); i++)
-- sum += L2Norm2 (v.Spec()(i)); // REval
-- return sum;
--}
--
-
- inline double L2Norm2 (double v)
- {
-@@ -908,6 +898,16 @@
- inline double L2Norm2 (Complex v)
- {
- return v.real()*v.real()+v.imag()*v.imag();
-+}
-+
-+template <class TA>
-+inline double L2Norm2 (const MatExpr<TA> & v)
-+{
-+ typedef typename TA::TSCAL TSCAL;
-+ double sum = 0;
-+ for (int i = 0; i < v.Height(); i++)
-+ sum += L2Norm2 (v.Spec()(i)); // REval
-+ return sum;
- }
-
- template <class TA>
diff --git a/cad/netgen/files/patch-ngsolve_comp_postproc.cpp b/cad/netgen/files/patch-ngsolve_comp_postproc.cpp
deleted file mode 100644
index 551ae710c376..000000000000
--- a/cad/netgen/files/patch-ngsolve_comp_postproc.cpp
+++ /dev/null
@@ -1,21 +0,0 @@
---- ngsolve/comp/postproc.cpp.orig
-+++ ngsolve/comp/postproc.cpp
-@@ -9,6 +9,7 @@
- */
-
- #include <comp.hpp>
-+#include <fem.hpp>
-
- namespace ngcomp
- {
-@@ -274,8 +275,8 @@
- if (dimflux > 1)
- {
- FlatMatrix<SCAL> elmat(dnumsflux.Size(), lh);
-- dynamic_cast<const BlockBilinearFormIntegrator&> (fluxbli)
-- . Block() . AssembleElementMatrix (felflux, eltrans, elmat, lh);
-+ BlockBilinearFormIntegrator const& fluxbli_ref = dynamic_cast<const BlockBilinearFormIntegrator&> (fluxbli);
-+ fluxbli_ref . Block() . AssembleElementMatrix (felflux, eltrans, elmat, lh);
- CholeskyFactors<SCAL> invelmat(elmat);
-
- FlatVector<SCAL> hv1(dnumsflux.Size(), lh);
diff --git a/cad/netgen/files/patch-ngsolve_linalg_order.cpp b/cad/netgen/files/patch-ngsolve_linalg_order.cpp
deleted file mode 100644
index 1ef838fbae60..000000000000
--- a/cad/netgen/files/patch-ngsolve_linalg_order.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ngsolve/linalg/order.cpp.orig
-+++ ngsolve/linalg/order.cpp
-@@ -54,7 +54,7 @@
- return ball.Alloc();
- }
-
-- void CliqueEl :: operator delete (void * p, size_t)
-+ void CliqueEl :: operator delete (void * p)
- {
- ball.Free (p);
- }
diff --git a/cad/netgen/files/patch-ngsolve_linalg_order.hpp b/cad/netgen/files/patch-ngsolve_linalg_order.hpp
deleted file mode 100644
index ba1ad8341acb..000000000000
--- a/cad/netgen/files/patch-ngsolve_linalg_order.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ngsolve/linalg/order.hpp.orig
-+++ ngsolve/linalg/order.hpp
-@@ -118,7 +118,7 @@
- ///
- void * operator new(size_t);
- ///
-- void operator delete (void *, size_t);
-+ void operator delete (void *);
- };
-
-
diff --git a/cad/netgen/files/patch-ngtcltk_ngappinit.cpp b/cad/netgen/files/patch-ngtcltk_ngappinit.cpp
deleted file mode 100644
index 0dea255951eb..000000000000
--- a/cad/netgen/files/patch-ngtcltk_ngappinit.cpp
+++ /dev/null
@@ -1,45 +0,0 @@
---- ngtcltk/ngappinit.cpp.orig 2004-11-17 17:43:35.000000000 +0800
-+++ ngtcltk/ngappinit.cpp 2008-09-01 22:40:22.000000000 +0800
-@@ -3,10 +3,12 @@
- This file is a modification of tkAppInit.c from the Tcl/Tk package
- */
-
-+using namespace std;
-+
- #include <mystdlib.h>
- #include "incvis.hpp"
- #include <meshing.hpp>
--
-+#include <math.h>
-
- namespace netgen
- {
-@@ -26,8 +28,6 @@
- * The following variable is a special hack that is needed in order for
- * Sun shared libraries to be used for Tcl.
- */
--// extern "C" int matherr();
--int *tclDummyMathPtr = (int *) matherr;
-
-
- /*
-@@ -194,8 +194,9 @@
- // For adding an application, parse the file here,
- // and call the init-procedure below
- // #define DEMOAPP
-+#define DEMOAPP
- #ifdef DEMOAPP
-- Tcl_EvalFile (myinterp, "demoapp/demoapp.tcl");
-+ Tcl_EvalFile (myinterp, "%%DATADIR%%/demoapp.tcl");
- #endif
-
- #ifdef ADDON
-@@ -316,7 +317,7 @@
- // #undef NGSOLVE
-
-
--#ifdef NGSOLVE
-+#if 0
-
- extern int NGSolve_Init (Tcl_Interp * interp);
- if (NGSolve_Init(interp) == TCL_ERROR)
diff --git a/cad/netgen/files/patch-togl::Makefile b/cad/netgen/files/patch-togl::Makefile
deleted file mode 100644
index c714582115f5..000000000000
--- a/cad/netgen/files/patch-togl::Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
---- ./togl/Makefile.orig Wed Jan 28 16:28:33 2004
-+++ ./togl/Makefile Sun Nov 21 18:37:12 2004
-@@ -57,33 +57,33 @@
- # Initial revision
- #
-
--
-+include ../libsrc/makefile.mach.$(MACHINE)
-
- # Makefile for Togl demos
- # You'll probably have to tinker with these macros:
-
-
- # The C compiler:
--CC = cc
-+CC = $(CPLUSPLUS)
-
- # Compiler options:
--COPTS = -c -O
-+COPTS = -c $(CXXFLAGS)
-
- # Shared library linker command:
--SHLINK = cc -G
-+SHLINK = $(LINK) -shared
-
- # Name for the shared lib:
- #SH_LIB = libtogl.so.1.3
- SH_LIB =
-
- # Where to find tcl.h, tk.h, OpenGL/Mesa headers, etc:
--INCLUDES = -I/usr/local/include -I/usr/include/tcl -I/usr/freeware/include
-+INCLUDES = -I$(LOCALBASE)/include $(CPLUSPLUSFLAGS3)
-
- # Where to find libtcl.a, libtk.a, OpenGL/Mesa libraries:
--LIBDIRS = -L/usr/local/lib
-+LIBDIRS = $(LINKFLAGS2)
-
- # Libraries to link with (-ldl for Linux only?):
--LIBS = -ltk -ltcl -lGLU -lGL -L/usr/X11/lib -L/usr/freeware/lib32 -lX11 -lXmu -lXext -lXt -lm -ldl
-+LIBS = $(tcltklib) -lGLU -lGL -lX11 -lXmu -lXext -lXt -lm
-
- TK_FLAGS =
-
diff --git a/cad/netgen/files/patch-togl::togl.cpp b/cad/netgen/files/patch-togl::togl.cpp
deleted file mode 100644
index c260846edd20..000000000000
--- a/cad/netgen/files/patch-togl::togl.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- togl/togl.cpp.orig Wed Sep 29 19:48:06 2004
-+++ togl/togl.cpp Fri Jan 26 00:30:29 2007
-@@ -138,14 +138,14 @@
- # include "tkInt8.4p3.h"
- #elif TK_MAJOR_VERSION==8 && TK_MINOR_VERSION==4 && TK_RELEASE_SERIAL==4
- # include "tkInt8.4p4.h"
--#elif TK_MAJOR_VERSION==8 && TK_MINOR_VERSION==4 && TK_RELEASE_SERIAL==6
-+#elif TK_MAJOR_VERSION==8 && TK_MINOR_VERSION==4 && TK_RELEASE_SERIAL>=6
- # include "tkInt8.4p6.h"
- #else
-- Sorry, you will have to edit togl.c to include the right tkInt.h file
-+ #error Sorry, you will have to edit togl.c to include the right tkInt.h file
- #endif
- #elif defined(WIN32)
- #if TK_MAJOR_VERSION<8
-- Sorry Windows version requires Tcl/Tk ver 8.0 or higher.
-+ #error Sorry Windows version requires Tcl/Tk ver 8.0 or higher.
- #endif
- #include "tkInt.h"
- #include "tkWinInt.h"
diff --git a/cad/netgen/files/pkg-message.in b/cad/netgen/files/pkg-message.in
new file mode 100644
index 000000000000..3ca16818fc38
--- /dev/null
+++ b/cad/netgen/files/pkg-message.in
@@ -0,0 +1,9 @@
+
+*************************************************************************
+
+ If you installed netgen to nondefault prefix,
+ make sure that you set the environment variable:
+
+ NETGENDIR=%%PREFIX%%/bin
+
+*************************************************************************