aboutsummaryrefslogtreecommitdiff
path: root/cad/opencascade
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-08-19 13:29:59 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-08-19 13:29:59 +0000
commitbb271f0bf7b513a23a31da4ec8819b113ebf4587 (patch)
treeac5a462edc3d85d5f0b20a594802ce4b12f0bf9f /cad/opencascade
parent29879aded766da253313579a3503ff5e15026355 (diff)
downloadports-bb271f0bf7b513a23a31da4ec8819b113ebf4587.tar.gz
ports-bb271f0bf7b513a23a31da4ec8819b113ebf4587.zip
Notes
Diffstat (limited to 'cad/opencascade')
-rw-r--r--cad/opencascade/Makefile29
1 files changed, 11 insertions, 18 deletions
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index 11566aa69213..c6e96ee50253 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -67,22 +67,18 @@ VIS_LIB_DEPENDS= libftgl.so:${PORTSDIR}/graphics/ftgl \
libgl2ps.so:${PORTSDIR}/print/gl2ps \
libfreeimageplus.so:${PORTSDIR}/graphics/freeimage
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MVIS}
-CMAKE_ARGS+= -D3RDPARTY_FREETYPE_DIR=${LOCALBASE} \
+VIS_CMAKE_ON= -D3RDPARTY_FREETYPE_DIR=${LOCALBASE} \
-D3RDPARTY_FREEIMAGE_DIR=${LOCALBASE} \
-D3RDPARTY_GL2PS_DIR=${LOCALBASE}
-.endif
-.if ${PORT_OPTIONS:MDOCS}
-USE_TEX+= latex:build
-BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash \
- doxygen:${PORTSDIR}/devel/doxygen \
- dot:${PORTSDIR}/graphics/graphviz \
- inkscape:${PORTSDIR}/graphics/inkscape
-RUN_DEPENDS+= ${LOCALBASE}/www/MathJax/MathJax.js:${PORTSDIR}/www/mathjax
-.endif
+DOCS_USE= TEX=latex:build
+DOCS_BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ doxygen:${PORTSDIR}/devel/doxygen \
+ dot:${PORTSDIR}/graphics/graphviz \
+ inkscape:${PORTSDIR}/graphics/inkscape
+DOCS_RUN_DEPENDS= ${LOCALBASE}/www/MathJax/MathJax.js:${PORTSDIR}/www/mathjax
+
+.include <bsd.port.options.mk>
.if ${ARCH} == "i386"
BITS= 32
@@ -106,10 +102,8 @@ pre-configure:
${REINPLACE_CMD} -e 's|lin|bsd|' ${WRKSRC}/${es}
.endfor
-post-build:
-.if ${PORT_OPTIONS:MDOCS}
+post-build-DOCS-on:
(cd ${WRKSRC} && ./gendoc -overview)
-.endif
post-install:
${MV} ${STAGEDIR}${OCCROOT}/bsd${BITS}/${COMPILER_TYPE}/bin/DRAWEXE \
@@ -129,11 +123,10 @@ post-install:
${RM} -rf ${STAGEDIR}${OCCROOT}/inc
${LN} -sf ${PREFIX}/include/OpenCASCADE ${STAGEDIR}${OCCROOT}/inc
(cd ${WRKSRC} && ${COPYTREE_SHARE} tests ${STAGEDIR}${OCCROOT})
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/doc/overview && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
${RMDIR} ${STAGEDIR}${DOCSDIR}/latex
-.endif
.if defined(MAINTAINER_MODE)
regression-test: install