aboutsummaryrefslogtreecommitdiff
path: root/cad/opencascade
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2009-01-26 17:57:30 +0000
committerThierry Thomas <thierry@FreeBSD.org>2009-01-26 17:57:30 +0000
commitfcd940ea6ec7687d0c42cd428f9b0c75a3b397e9 (patch)
treee6d49e2d3aa390aba5a6b53cfa124d3f19c66006 /cad/opencascade
parent0c3c90ce56c038a499229d326798004519541772 (diff)
downloadports-fcd940ea6ec7687d0c42cd428f9b0c75a3b397e9.tar.gz
ports-fcd940ea6ec7687d0c42cd428f9b0c75a3b397e9.zip
Notes
Diffstat (limited to 'cad/opencascade')
-rw-r--r--cad/opencascade/Makefile2
-rw-r--r--cad/opencascade/files/patch-ros_src_STEPConstruct_STEPConstruct_AP203Context.cxx11
2 files changed, 12 insertions, 1 deletions
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index fed93b66df46..556b88a193e9 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -7,7 +7,7 @@
PORTNAME= opencascade
PORTVERSION= 6.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= cad science
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= thierry
diff --git a/cad/opencascade/files/patch-ros_src_STEPConstruct_STEPConstruct_AP203Context.cxx b/cad/opencascade/files/patch-ros_src_STEPConstruct_STEPConstruct_AP203Context.cxx
new file mode 100644
index 000000000000..245322f6345c
--- /dev/null
+++ b/cad/opencascade/files/patch-ros_src_STEPConstruct_STEPConstruct_AP203Context.cxx
@@ -0,0 +1,11 @@
+--- ./ros/src/STEPConstruct/STEPConstruct_AP203Context.cxx.orig 2001-09-21 10:00:28.000000000 +0200
++++ ./ros/src/STEPConstruct/STEPConstruct_AP203Context.cxx 2009-01-24 11:45:15.000000000 +0100
+@@ -103,7 +103,7 @@
+
+ Handle(StepBasic_CoordinatedUniversalTimeOffset) zone =
+ new StepBasic_CoordinatedUniversalTimeOffset;
+- Standard_Integer shift = Standard_Integer(timezone);
++ Standard_Integer shift = Standard_Integer((long long) timezone);
+ Standard_Integer shifth = abs ( shift ) / 3600;
+ Standard_Integer shiftm = ( abs ( shift ) - shifth * 3600 ) / 60;
+ StepBasic_AheadOrBehind sense = ( shift >0 ? StepBasic_aobBehind :