aboutsummaryrefslogtreecommitdiff
path: root/cad/openvsp/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-04-22 12:06:12 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-04-22 12:06:12 +0000
commitb9c8e3ecb7e272becd6ff25667099f5b04939413 (patch)
tree3e35b36a05ede3c8c0b0c26fecc08d293f26b141 /cad/openvsp/Makefile
parent1ac8535d32a6d00231658c50bf6676de528faa78 (diff)
downloadports-b9c8e3ecb7e272becd6ff25667099f5b04939413.tar.gz
ports-b9c8e3ecb7e272becd6ff25667099f5b04939413.zip
Notes
Diffstat (limited to 'cad/openvsp/Makefile')
-rw-r--r--cad/openvsp/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/cad/openvsp/Makefile b/cad/openvsp/Makefile
new file mode 100644
index 000000000000..148e7d4d6931
--- /dev/null
+++ b/cad/openvsp/Makefile
@@ -0,0 +1,46 @@
+# Port makefile for: openvsp
+# Date created: Apr 10 2012
+# Whom: Fernando Apesteguia <fernando.apesteguia@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= openvsp
+PORTVERSION= 2.0
+CATEGORIES= cad
+MASTER_SITES= https://nodeload.github.com/OpenVSP/OpenVSP/tarball/
+DISTNAME= OpenVSP_${PORTVERSION}_Community
+
+MAINTAINER= fernando.apesteguia@gmail.com
+COMMENT= Create a 3D model of an aircraft defined by engineering parameters
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libopenNURBS.a:${PORTSDIR}/graphics/opennurbs
+
+LIB_DEPENDS+= fltk:${PORTSDIR}/x11-toolkits/fltk
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS+= png:${PORTSDIR}/graphics/png
+
+WRKSRC= ${WRKDIR}/OpenVSP-OpenVSP-574d7c3/src
+
+USE_CMAKE= yes
+USE_DOS2UNIX= yes
+USE_XORG= xinerama xft
+USE_GNOME= libxml2
+
+PORTEXAMPLES= *
+INSTALL_PORTEXAMPLES= @(cd ${WRKSRC}/../examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+
+PLIST_FILES= bin/vsp
+
+CFLAGS+= -I${LOCALBASE}/include/openNURBS
+
+do-fetch:
+ ${FETCH_BINARY} -o ${DISTDIR}/${DISTNAME}.tar.gz ${MASTER_SITES}${DISTNAME}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/vsp/vsp ${PREFIX}/bin
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_PORTEXAMPLES}
+.endif
+
+.include <bsd.port.mk>