aboutsummaryrefslogtreecommitdiff
path: root/cad/oregano
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-09 00:35:08 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-09 00:35:08 +0000
commitbdc6a2c0df550060d6dc21f50f360f70bddf29df (patch)
treef84659c25233c8f78be79b6c5bcc499f7e8e3871 /cad/oregano
parent3583fb4460a78adb6b38b9187e7be246b1ead193 (diff)
downloadports-bdc6a2c0df550060d6dc21f50f360f70bddf29df.tar.gz
ports-bdc6a2c0df550060d6dc21f50f360f70bddf29df.zip
Notes
Diffstat (limited to 'cad/oregano')
-rw-r--r--cad/oregano/Makefile25
-rw-r--r--cad/oregano/distinfo6
-rw-r--r--cad/oregano/files/patch-src__engines__netlist.c (renamed from cad/oregano/files/patch-src__simulate.c)9
-rw-r--r--cad/oregano/files/patch-src__sim-engine.c22
-rw-r--r--cad/oregano/pkg-plist24
5 files changed, 23 insertions, 63 deletions
diff --git a/cad/oregano/Makefile b/cad/oregano/Makefile
index 6f15462be2e5..dac9c2b8cee1 100644
--- a/cad/oregano/Makefile
+++ b/cad/oregano/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= oregano
-PORTVERSION= 0.50.0
+PORTVERSION= 0.60.0
CATEGORIES= cad gnome
-MASTER_SITES= http://gforge.lug.fi.uba.ar/frs/download.php/80/
+MASTER_SITES= http://gforge.lug.fi.uba.ar/frs/download.php/84/
MAINTAINER= ports@FreeBSD.org
COMMENT= Schematic capture and simulation of electrical circuits
@@ -17,8 +17,10 @@ BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons
USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_GETTEXT= yes
USE_GNOME= gnomehack gnomeprefix gtksourceview intlhack libglade2 \
libgnomeprintui libgnomeui
+USE_SCONS= yes
INSTALLS_OMF= yes
.include <bsd.port.pre.mk>
@@ -26,23 +28,13 @@ INSTALLS_OMF= yes
post-patch:
@${REINPLACE_CMD} -e "s|-Wall|${CFLAGS}|g ; \
s|'/share'|'/share/gnome'|g ; \
- s|'gnome/apps/Applications'|'applications'|g ; \
- /oregano\.xml/d" ${WRKSRC}/SConstruct
+ s|'share/applications'|'share/gnome/applications'|g ; \
+ s|'share/mime-info'|'share/gnome/mime-info'|g" ${WRKSRC}/SConstruct
@${FIND} ${WRKSRC} -name "SConscript" | ${XARGS} ${REINPLACE_CMD} -e \
"s|share/oregano|share/gnome/oregano|g"
-do-build:
- @cd ${BUILD_WRKSRC} && scons PREFIX=${PREFIX}
-
-do-install:
- @cd ${BUILD_WRKSRC} && scons install PREFIX=${PREFIX}
+post-install:
@${STRIP_CMD} ${PREFIX}/bin/oregano
- @${MKDIR} ${PREFIX}/share/gnome/oregano/models
- ${INSTALL_DATA} ${WRKSRC}/data/models/*.model \
- ${PREFIX}/share/gnome/oregano/models
- @${MKDIR} ${PREFIX}/share/gnome/oregano/samples
- ${INSTALL_DATA} ${WRKSRC}/src/samples/*.oregano \
- ${PREFIX}/share/gnome/oregano/samples
.for lang in C es fr
@${MKDIR} ${PREFIX}/share/gnome/help/oregano/${lang}
${INSTALL_DATA} ${WRKSRC}/help/${lang}/*.xml \
@@ -53,8 +45,5 @@ do-install:
.endfor
${INSTALL_DATA} ${WRKSRC}/gnome-oregano.svg \
${PREFIX}/share/gnome/pixmaps/gnome-oregano.svg
- ${INSTALL_DATA} ${WRKSRC}/oregano.xml.in \
- ${PREFIX}/share/mime/packages/oregano.xml
- @-update-mime-database ${PREFIX}/share/mime
.include <bsd.port.post.mk>
diff --git a/cad/oregano/distinfo b/cad/oregano/distinfo
index 59da29deed19..a03e7ad34b96 100644
--- a/cad/oregano/distinfo
+++ b/cad/oregano/distinfo
@@ -1,3 +1,3 @@
-MD5 (oregano-0.50.0.tar.bz2) = 9816761944b0163029942f2e113b7827
-SHA256 (oregano-0.50.0.tar.bz2) = a7a44daa150d589f34f134682ecec5e3a50ce3e418fef991f0ef6a127ab155d5
-SIZE (oregano-0.50.0.tar.bz2) = 521434
+MD5 (oregano-0.60.0.tar.bz2) = 576942f1b6d3348f16d2eff085eb03f4
+SHA256 (oregano-0.60.0.tar.bz2) = 1c6ee75a5b8d5926064ad8a953dc70bf858b8a47a951e9998dcde3233680a6d2
+SIZE (oregano-0.60.0.tar.bz2) = 525514
diff --git a/cad/oregano/files/patch-src__simulate.c b/cad/oregano/files/patch-src__engines__netlist.c
index e6a983bafd55..60d280468165 100644
--- a/cad/oregano/files/patch-src__simulate.c
+++ b/cad/oregano/files/patch-src__engines__netlist.c
@@ -1,14 +1,13 @@
---- src/simulate.c.orig Wed May 24 14:16:30 2006
-+++ src/simulate.c Wed May 24 21:39:29 2006
-@@ -188,10 +188,10 @@
+--- src/engines/netlist.c.orig Sat Sep 30 13:47:23 2006
++++ src/engines/netlist.c Sat Sep 30 21:26:42 2006
+@@ -628,9 +628,9 @@
GList *parts;
GList *p;
gchar *prop, *type, *ac;
- parts = node_store_get_parts (store);
GString *out;
gchar *ret;
-
+ parts = node_store_get_parts (store);
+
out = g_string_new ("");
- for(p=parts; p; p = p->next) {
diff --git a/cad/oregano/files/patch-src__sim-engine.c b/cad/oregano/files/patch-src__sim-engine.c
deleted file mode 100644
index 142c45f5b398..000000000000
--- a/cad/oregano/files/patch-src__sim-engine.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/sim-engine.c.orig Wed May 24 14:16:30 2006
-+++ src/sim-engine.c Wed May 24 21:39:29 2006
-@@ -268,9 +268,9 @@
- /* TODO Would be recomendable to use pthread? */
- engine->child_pid = fork();
- if (engine->child_pid == 0) {
-- setpgrp ();
-+ setpgrp(0, getpid());
- /* Now oregano.simtype has gnucap or ngspice */
-- gchar *simexec = oregano.simexec;
-+ { gchar *simexec = oregano.simexec;
- /* !!!!!!!!!!! "-s" "-n" */
- gchar *args[4] = { simexec, oregano.simtype, (gchar *)netlist, NULL };
-
-@@ -300,6 +300,7 @@
- * path y todo
- */
- execvp(simexec, args);
-+ }
-
- /* We should never get here. */
- g_warning ("Error executing the simulation engine.");
diff --git a/cad/oregano/pkg-plist b/cad/oregano/pkg-plist
index c5765e8875a1..1ffb65f71a79 100644
--- a/cad/oregano/pkg-plist
+++ b/cad/oregano/pkg-plist
@@ -1,5 +1,4 @@
bin/oregano
-bin/oregano_parser.pl
share/gnome/applications/oregano.desktop
share/gnome/help/oregano/C/legal.xml
share/gnome/help/oregano/C/oregano.xml
@@ -28,6 +27,13 @@ share/gnome/oregano/dialogs/splash.glade2
share/gnome/oregano/dialogs/splash.xpm
share/gnome/oregano/dialogs/textbox-properties-dialog.glade2
share/gnome/oregano/dialogs/view-netlist.glade2
+share/gnome/oregano/examples/Full-wave bridge rectifier.oregano
+share/gnome/oregano/examples/carga_capacitor.oregano
+share/gnome/oregano/examples/opamp.oregano
+share/gnome/oregano/examples/opamp_ideal.oregano
+share/gnome/oregano/examples/pasa_altos.oregano
+share/gnome/oregano/examples/simple.oregano
+share/gnome/oregano/examples/simple2.oregano
share/gnome/oregano/libraries/cmos.oreglib
share/gnome/oregano/libraries/cpu.oreglib
share/gnome/oregano/libraries/default.oreglib
@@ -41,22 +47,11 @@ share/gnome/oregano/libraries/power.oreglib
share/gnome/oregano/libraries/ttl.oreglib
share/gnome/oregano/models/12AX7A.model
share/gnome/oregano/models/1N750.model
+share/gnome/oregano/models/DiodeBridge.model
share/gnome/oregano/models/NPN.model
share/gnome/oregano/models/PNP.model
share/gnome/oregano/models/TLC555.model
share/gnome/oregano/models/UA741.model
-share/gnome/oregano/samples/12ax7a.oregano
-share/gnome/oregano/samples/555.oregano
-share/gnome/oregano/samples/741.oregano
-share/gnome/oregano/samples/OP177B.oregano
-share/gnome/oregano/samples/carga_capacitor.oregano
-share/gnome/oregano/samples/opamp.oregano
-share/gnome/oregano/samples/opamp_ideal.oregano
-share/gnome/oregano/samples/pasa_altos.oregano
-share/gnome/oregano/samples/simple.oregano
-share/gnome/oregano/samples/simple2.oregano
-share/gnome/oregano/samples/transistors.oregano
-share/gnome/oregano/samples/zener.oregano
share/gnome/pixmaps/gnome-oregano.svg
share/locale/ca/LC_MESSAGES/oregano.mo
share/locale/de/LC_MESSAGES/oregano.mo
@@ -64,15 +59,14 @@ share/locale/es/LC_MESSAGES/oregano.mo
share/locale/fr/LC_MESSAGES/oregano.mo
share/locale/it/LC_MESSAGES/oregano.mo
share/locale/ja/LC_MESSAGES/oregano.mo
-share/locale/pl/LC_MESSAGES/oregano.mo
share/locale/pt_BR/LC_MESSAGES/oregano.mo
share/locale/ro/LC_MESSAGES/oregano.mo
share/locale/ru/LC_MESSAGES/oregano.mo
share/locale/sv/LC_MESSAGES/oregano.mo
share/mime/packages/oregano.xml
-@dirrm share/gnome/oregano/samples
@dirrm share/gnome/oregano/models
@dirrm share/gnome/oregano/libraries
+@dirrm share/gnome/oregano/examples
@dirrm share/gnome/oregano/dialogs
@dirrm share/gnome/oregano
@dirrm share/gnome/omf/oregano