aboutsummaryrefslogtreecommitdiff
path: root/cad/oregano
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-06-10 12:50:45 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-06-10 12:50:45 +0000
commit0c9fd72e090a4db0ea36d49d9be83799414443d1 (patch)
treecc854f2a57251778aabd0e1f1c7fd26bb550d10c /cad/oregano
parente5e672d151ed164c729126ca3f6fb3dd35f795c5 (diff)
downloadports-0c9fd72e090a4db0ea36d49d9be83799414443d1.tar.gz
ports-0c9fd72e090a4db0ea36d49d9be83799414443d1.zip
Notes
Diffstat (limited to 'cad/oregano')
-rw-r--r--cad/oregano/Makefile49
-rw-r--r--cad/oregano/distinfo6
-rw-r--r--cad/oregano/files/patch-src::node-store.c25
-rw-r--r--cad/oregano/files/patch-src__model__node-store.c24
-rw-r--r--cad/oregano/files/patch-src__schematic-view.c (renamed from cad/oregano/files/patch-src::schematic-view.c)10
-rw-r--r--cad/oregano/files/patch-src__sheet__wire-item.c12
-rw-r--r--cad/oregano/files/patch-src__sim-engine.c (renamed from cad/oregano/files/patch-src_sim-engine.c)13
-rw-r--r--cad/oregano/files/patch-src__simulate.c (renamed from cad/oregano/files/patch-src::simulate.c)6
-rw-r--r--cad/oregano/files/patch-src_plot.c15
-rw-r--r--cad/oregano/pkg-plist40
10 files changed, 107 insertions, 93 deletions
diff --git a/cad/oregano/Makefile b/cad/oregano/Makefile
index f08f09368d82..6f15462be2e5 100644
--- a/cad/oregano/Makefile
+++ b/cad/oregano/Makefile
@@ -6,32 +6,55 @@
#
PORTNAME= oregano
-PORTVERSION= 0.40.5
+PORTVERSION= 0.50.0
CATEGORIES= cad gnome
-MASTER_SITES= http://gforge.lug.fi.uba.ar/frs/download.php/64/
+MASTER_SITES= http://gforge.lug.fi.uba.ar/frs/download.php/80/
MAINTAINER= ports@FreeBSD.org
COMMENT= Schematic capture and simulation of electrical circuits
+BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons
+
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix gtksourceview intlhack libglade2 \
libgnomeprintui libgnomeui
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOHEADER="${TRUE}" \
- AUTOMAKE="${TRUE}"
INSTALLS_OMF= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= "Does not build on 4.X"
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e 's|src/main\.c|${PORTNAME}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s|-Wall|${CFLAGS}|g ; \
+ s|'/share'|'/share/gnome'|g ; \
+ s|'gnome/apps/Applications'|'applications'|g ; \
+ /oregano\.xml/d" ${WRKSRC}/SConstruct
+ @${FIND} ${WRKSRC} -name "SConscript" | ${XARGS} ${REINPLACE_CMD} -e \
+ "s|share/oregano|share/gnome/oregano|g"
+
+do-build:
+ @cd ${BUILD_WRKSRC} && scons PREFIX=${PREFIX}
+
+do-install:
+ @cd ${BUILD_WRKSRC} && scons install PREFIX=${PREFIX}
+ @${STRIP_CMD} ${PREFIX}/bin/oregano
+ @${MKDIR} ${PREFIX}/share/gnome/oregano/models
+ ${INSTALL_DATA} ${WRKSRC}/data/models/*.model \
+ ${PREFIX}/share/gnome/oregano/models
+ @${MKDIR} ${PREFIX}/share/gnome/oregano/samples
+ ${INSTALL_DATA} ${WRKSRC}/src/samples/*.oregano \
+ ${PREFIX}/share/gnome/oregano/samples
+.for lang in C es fr
+ @${MKDIR} ${PREFIX}/share/gnome/help/oregano/${lang}
+ ${INSTALL_DATA} ${WRKSRC}/help/${lang}/*.xml \
+ ${PREFIX}/share/gnome/help/oregano/${lang}
+ @${MKDIR} ${PREFIX}/share/gnome/omf/oregano
+ ${INSTALL_DATA} ${WRKSRC}/help/${lang}/*.omf \
+ ${PREFIX}/share/gnome/omf/oregano
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/gnome-oregano.svg \
+ ${PREFIX}/share/gnome/pixmaps/gnome-oregano.svg
+ ${INSTALL_DATA} ${WRKSRC}/oregano.xml.in \
+ ${PREFIX}/share/mime/packages/oregano.xml
+ @-update-mime-database ${PREFIX}/share/mime
.include <bsd.port.post.mk>
diff --git a/cad/oregano/distinfo b/cad/oregano/distinfo
index e00985e778a3..59da29deed19 100644
--- a/cad/oregano/distinfo
+++ b/cad/oregano/distinfo
@@ -1,3 +1,3 @@
-MD5 (oregano-0.40.5.tar.bz2) = 9aa11ab2afca0453466ac236458e9ea4
-SHA256 (oregano-0.40.5.tar.bz2) = e1406d0cb68d92f165df4d6cf0cd85bbe1a3491f6d2dec320693721deffac357
-SIZE (oregano-0.40.5.tar.bz2) = 874251
+MD5 (oregano-0.50.0.tar.bz2) = 9816761944b0163029942f2e113b7827
+SHA256 (oregano-0.50.0.tar.bz2) = a7a44daa150d589f34f134682ecec5e3a50ce3e418fef991f0ef6a127ab155d5
+SIZE (oregano-0.50.0.tar.bz2) = 521434
diff --git a/cad/oregano/files/patch-src::node-store.c b/cad/oregano/files/patch-src::node-store.c
deleted file mode 100644
index 66de4602016f..000000000000
--- a/cad/oregano/files/patch-src::node-store.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/node-store.c.orig Tue Oct 12 04:04:27 2004
-+++ src/node-store.c Fri Nov 26 18:05:48 2004
-@@ -431,9 +431,10 @@
-
- if (IS_EQ (x1, x2) && ((ipoint->pos.y == y1) || (ipoint->pos.y == y2))) {
- SheetPos w_pos, w_length;
-- wire_get_pos_and_length (ipoint->wire, &w_pos, &w_length);
- gdouble _x1, _x2, _y1, _y2;
-
-+ wire_get_pos_and_length (ipoint->wire, &w_pos, &w_length);
-+
- _x1 = w_pos.x;
- _y1 = w_pos.y;
- _x2 = x1 + w_length.x;
-@@ -457,8 +458,9 @@
- }
- } else if (IS_EQ (y1, y2) && ((ipoint->pos.x == x1) || (ipoint->pos.x == x2))) {
- SheetPos w_pos, w_length;
-- wire_get_pos_and_length (ipoint->wire, &w_pos, &w_length);
- gdouble _x1, _x2, _y1, _y2;
-+
-+ wire_get_pos_and_length (ipoint->wire, &w_pos, &w_length);
-
- _x1 = w_pos.x;
- _y1 = w_pos.y;
diff --git a/cad/oregano/files/patch-src__model__node-store.c b/cad/oregano/files/patch-src__model__node-store.c
new file mode 100644
index 000000000000..d4a39e52440a
--- /dev/null
+++ b/cad/oregano/files/patch-src__model__node-store.c
@@ -0,0 +1,24 @@
+--- src/model/node-store.c.orig Wed May 24 14:16:30 2006
++++ src/model/node-store.c Wed May 24 19:07:00 2006
+@@ -432,9 +432,9 @@
+ SheetPos w_pos, w_length;
+ gboolean can_join;
+ GSList *nodes;
++ gdouble _x1, _x2, _y1, _y2;
+
+ wire_get_pos_and_length (ipoint->wire, &w_pos, &w_length);
+- gdouble _x1, _x2, _y1, _y2;
+
+ _x1 = w_pos.x;
+ _y1 = w_pos.y;
+@@ -481,9 +481,9 @@
+ SheetPos w_pos, w_length;
+ gboolean can_join;
+ GSList *nodes;
++ gdouble _x1, _x2, _y1, _y2;
+
+ wire_get_pos_and_length (ipoint->wire, &w_pos, &w_length);
+- gdouble _x1, _x2, _y1, _y2;
+
+ _x1 = w_pos.x;
+ _y1 = w_pos.y;
diff --git a/cad/oregano/files/patch-src::schematic-view.c b/cad/oregano/files/patch-src__schematic-view.c
index 7cc677b8291f..c7fd3c690120 100644
--- a/cad/oregano/files/patch-src::schematic-view.c
+++ b/cad/oregano/files/patch-src__schematic-view.c
@@ -1,6 +1,6 @@
---- src/schematic-view.c.orig Fri Nov 12 10:09:14 2004
-+++ src/schematic-view.c Fri Nov 26 18:08:32 2004
-@@ -1840,6 +1840,7 @@
+--- src/schematic-view.c.orig Wed May 24 14:16:30 2006
++++ src/schematic-view.c Wed May 24 21:39:29 2006
+@@ -1849,6 +1849,7 @@
int i=0;
while (files[i]) {
Schematic *new_sm = NULL;
@@ -8,12 +8,12 @@
int l = strlen(files[i]);
/* Algo queda mal al final luego del split, agrego un \0 */
files[i][l-1] = '\0';
-@@ -1849,8 +1850,6 @@
+@@ -1858,8 +1859,6 @@
i++;
continue;
}
-
- gchar *fname = files[i];
- new_sm = schematic_read (fname);
+ new_sm = schematic_read (fname, &error);
if (new_sm) {
diff --git a/cad/oregano/files/patch-src__sheet__wire-item.c b/cad/oregano/files/patch-src__sheet__wire-item.c
new file mode 100644
index 000000000000..e6c85906d885
--- /dev/null
+++ b/cad/oregano/files/patch-src__sheet__wire-item.c
@@ -0,0 +1,12 @@
+--- src/sheet/wire-item.c.orig Wed May 24 14:16:30 2006
++++ src/sheet/wire-item.c Wed May 24 21:13:43 2006
+@@ -363,8 +363,8 @@
+ case GDK_BUTTON_PRESS:
+ switch (event->button.button) {
+ case 1: {
+- g_signal_stop_emission_by_name (G_OBJECT (sheet), "event");
+ double x, y;
++ g_signal_stop_emission_by_name (G_OBJECT (sheet), "event");
+ x = event->button.x - start_pos.x;
+ y = event->button.y - start_pos.y;
+ if ((x > -RESIZER_SIZE) && (x < RESIZER_SIZE) &&
diff --git a/cad/oregano/files/patch-src_sim-engine.c b/cad/oregano/files/patch-src__sim-engine.c
index c4f7d06b8e0a..142c45f5b398 100644
--- a/cad/oregano/files/patch-src_sim-engine.c
+++ b/cad/oregano/files/patch-src__sim-engine.c
@@ -1,9 +1,6 @@
-
-$FreeBSD$
-
---- src/sim-engine.c.orig
-+++ src/sim-engine.c
-@@ -265,9 +265,9 @@
+--- src/sim-engine.c.orig Wed May 24 14:16:30 2006
++++ src/sim-engine.c Wed May 24 21:39:29 2006
+@@ -268,9 +268,9 @@
/* TODO Would be recomendable to use pthread? */
engine->child_pid = fork();
if (engine->child_pid == 0) {
@@ -14,8 +11,8 @@ $FreeBSD$
+ { gchar *simexec = oregano.simexec;
/* !!!!!!!!!!! "-s" "-n" */
gchar *args[4] = { simexec, oregano.simtype, (gchar *)netlist, NULL };
-
-@@ -298,6 +298,7 @@
+
+@@ -300,6 +300,7 @@
* path y todo
*/
execvp(simexec, args);
diff --git a/cad/oregano/files/patch-src::simulate.c b/cad/oregano/files/patch-src__simulate.c
index 4391181847da..e6a983bafd55 100644
--- a/cad/oregano/files/patch-src::simulate.c
+++ b/cad/oregano/files/patch-src__simulate.c
@@ -1,6 +1,6 @@
---- src/simulate.c.orig Tue Nov 23 04:20:05 2004
-+++ src/simulate.c Fri Nov 26 18:10:37 2004
-@@ -200,10 +200,10 @@
+--- src/simulate.c.orig Wed May 24 14:16:30 2006
++++ src/simulate.c Wed May 24 21:39:29 2006
+@@ -188,10 +188,10 @@
GList *parts;
GList *p;
gchar *prop, *type, *ac;
diff --git a/cad/oregano/files/patch-src_plot.c b/cad/oregano/files/patch-src_plot.c
deleted file mode 100644
index 8d92d65d7a26..000000000000
--- a/cad/oregano/files/patch-src_plot.c
+++ /dev/null
@@ -1,15 +0,0 @@
-
-$FreeBSD$
-
---- src/plot.c.orig
-+++ src/plot.c
-@@ -277,8 +277,8 @@
- {
- GtkTreeIter iter;
- GtkTreeModel *model;
-- plot->selected = 0;
- gboolean activo;
-+ plot->selected = 0;
-
- /* Check if selected row is leaf or root */
- if (gtk_tree_path_get_depth (arg1) == 1) {
diff --git a/cad/oregano/pkg-plist b/cad/oregano/pkg-plist
index 03e2fb05be9c..c5765e8875a1 100644
--- a/cad/oregano/pkg-plist
+++ b/cad/oregano/pkg-plist
@@ -1,7 +1,6 @@
bin/oregano
bin/oregano_parser.pl
-bin/pspice2oregano
-share/gnome/apps/Applications/oregano.desktop
+share/gnome/applications/oregano.desktop
share/gnome/help/oregano/C/legal.xml
share/gnome/help/oregano/C/oregano.xml
share/gnome/help/oregano/es/legal.xml
@@ -13,22 +12,22 @@ share/gnome/mime-info/oregano.mime
share/gnome/omf/oregano/oregano-C.omf
share/gnome/omf/oregano/oregano-es.omf
share/gnome/omf/oregano/oregano-fr.omf
-share/gnome/oregano/glade/clamp-properties-dialog.glade2
-share/gnome/oregano/glade/log-window.glade2
-share/gnome/oregano/glade/page-properties.glade2
-share/gnome/oregano/glade/part-browser.glade2
-share/gnome/oregano/glade/part-properties-dialog.glade2
-share/gnome/oregano/glade/plot-add-function.glade2
-share/gnome/oregano/glade/plot-export.glade2
-share/gnome/oregano/glade/plot-window.glade2
-share/gnome/oregano/glade/properties.glade2
-share/gnome/oregano/glade/settings.glade2
-share/gnome/oregano/glade/sim-settings.glade2
-share/gnome/oregano/glade/simulation.glade2
-share/gnome/oregano/glade/splash.glade2
-share/gnome/oregano/glade/splash.xpm
-share/gnome/oregano/glade/textbox-properties-dialog.glade2
-share/gnome/oregano/glade/view-netlist.glade2
+share/gnome/oregano/dialogs/clamp-properties-dialog.glade2
+share/gnome/oregano/dialogs/log-window.glade2
+share/gnome/oregano/dialogs/page-properties.glade2
+share/gnome/oregano/dialogs/part-browser.glade2
+share/gnome/oregano/dialogs/part-properties-dialog.glade2
+share/gnome/oregano/dialogs/plot-add-function.glade2
+share/gnome/oregano/dialogs/plot-export.glade2
+share/gnome/oregano/dialogs/plot-window.glade2
+share/gnome/oregano/dialogs/properties.glade2
+share/gnome/oregano/dialogs/settings.glade2
+share/gnome/oregano/dialogs/sim-settings.glade2
+share/gnome/oregano/dialogs/simulation.glade2
+share/gnome/oregano/dialogs/splash.glade2
+share/gnome/oregano/dialogs/splash.xpm
+share/gnome/oregano/dialogs/textbox-properties-dialog.glade2
+share/gnome/oregano/dialogs/view-netlist.glade2
share/gnome/oregano/libraries/cmos.oreglib
share/gnome/oregano/libraries/cpu.oreglib
share/gnome/oregano/libraries/default.oreglib
@@ -65,17 +64,16 @@ share/locale/es/LC_MESSAGES/oregano.mo
share/locale/fr/LC_MESSAGES/oregano.mo
share/locale/it/LC_MESSAGES/oregano.mo
share/locale/ja/LC_MESSAGES/oregano.mo
+share/locale/pl/LC_MESSAGES/oregano.mo
share/locale/pt_BR/LC_MESSAGES/oregano.mo
share/locale/ro/LC_MESSAGES/oregano.mo
share/locale/ru/LC_MESSAGES/oregano.mo
share/locale/sv/LC_MESSAGES/oregano.mo
share/mime/packages/oregano.xml
-share/mime/text/netlist.xml
-share/mime/text/oregano.xml
@dirrm share/gnome/oregano/samples
@dirrm share/gnome/oregano/models
@dirrm share/gnome/oregano/libraries
-@dirrm share/gnome/oregano/glade
+@dirrm share/gnome/oregano/dialogs
@dirrm share/gnome/oregano
@dirrm share/gnome/omf/oregano
@dirrm share/gnome/help/oregano/fr