aboutsummaryrefslogtreecommitdiff
path: root/cad/p5-GDS2
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-08 21:29:55 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-08 21:29:55 +0000
commit85ad94b8c1151e916fa0f54bf6d173af157322f6 (patch)
treeede43b8e7280dfdcbbde49083053fd5496fe6c6d /cad/p5-GDS2
parentef1bf9597207eb1f0d40688c361e5cbece87c445 (diff)
downloadports-85ad94b8c1151e916fa0f54bf6d173af157322f6.tar.gz
ports-85ad94b8c1151e916fa0f54bf6d173af157322f6.zip
Notes
Diffstat (limited to 'cad/p5-GDS2')
-rw-r--r--cad/p5-GDS2/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/cad/p5-GDS2/Makefile b/cad/p5-GDS2/Makefile
index 81a1c0262756..c647c930128e 100644
--- a/cad/p5-GDS2/Makefile
+++ b/cad/p5-GDS2/Makefile
@@ -11,20 +11,19 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S,.a$,a,}
MAINTAINER= hrs@FreeBSD.org
COMMENT= GDS2 - GDS2 stream module
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= modbuild
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S,.a$,,}
+SHEBANG_FILES= Examples/*
PLIST_FILES= ${SITE_PERL_REL}/GDS2.pm \
- ${PROGRAMS:S,^,bin/,}
-
-MAN3= GDS2.3
+ ${PROGRAMS:S,^,bin/,} %%PERL5_MAN3%%/GDS2.3.gz
PROGRAMS= gdsdump2gds modgds2 gdslayers testgds2 \
gdspath4topath0 testgdt
# XXX: gdsdump disabled for the moment
-NO_STAGE= yes
post-install:
- ${INSTALL_SCRIPT} ${PROGRAMS:S,^,${WRKSRC}/Examples/,} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${PROGRAMS:S,^,${WRKSRC}/Examples/,} \
+ ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>