aboutsummaryrefslogtreecommitdiff
path: root/cad/qcad/Makefile
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2021-03-28 20:08:24 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2021-03-28 20:08:24 +0000
commitd4728e1f832b3a193f677dc3d015c9a475013af0 (patch)
tree774d47307089f668c9aa5b43f743ce6688d041c7 /cad/qcad/Makefile
parent8df6776d31e1751347e25d21591959fe30619d52 (diff)
downloadports-d4728e1f832b3a193f677dc3d015c9a475013af0.tar.gz
ports-d4728e1f832b3a193f677dc3d015c9a475013af0.zip
Notes
Diffstat (limited to 'cad/qcad/Makefile')
-rw-r--r--cad/qcad/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/cad/qcad/Makefile b/cad/qcad/Makefile
index 6885509442d9..5149efddbbd0 100644
--- a/cad/qcad/Makefile
+++ b/cad/qcad/Makefile
@@ -20,8 +20,6 @@ LICENSE= GPLv3
BUILD_DEPENDS= bash:shells/bash \
${LOCALBASE}/lib/libopenNURBS.a:graphics/opennurbs
-MAKE_JOBS_UNSAFE=yes
-
USES= compiler:c++11-lang gl gmake qmake qt:5
USE_GITHUB= yes
USE_LDCONFIG= yes
@@ -56,6 +54,18 @@ CFLAGS_i386= -fPIC
CXXFLAGS_i386= -fPIC
LDFLAGS_i386= -Wl,-z,notext
+.include <bsd.port.options.mk>
+
+.if defined(WITH_DEBUG)
+ALL_TARGET= debug
+PLIST_SUB+= DEBUG_LIB_SUFFIX="_debug"
+RESDIR= ${WRKSRC}/debug
+.else
+ALL_TARGET= release
+PLIST_SUB+= DEBUG_LIB_SUFFIX=""
+RESDIR= ${WRKSRC}/release
+.endif
+
pre-configure:
${MKDIR} ${WRKSRC}/src/3rdparty/qt-labs-qtscriptgenerator-${_QT_VERSION}
${CP} ${WRKSRC}/src/3rdparty/qt-labs-qtscriptgenerator-5.13.2/qt-labs-qtscriptgenerator-5.13.2.pro \