aboutsummaryrefslogtreecommitdiff
path: root/cad/qcad
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2004-03-28 16:42:17 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2004-03-28 16:42:17 +0000
commit3e5994f1a0acf3b411a845cdde918926b05dc00e (patch)
treeb4afacbd3623096376791e4a27816428470a8dbd /cad/qcad
parentfb3ad256afcc32d08107c8d231dac482e42903b8 (diff)
downloadports-3e5994f1a0acf3b411a845cdde918926b05dc00e.tar.gz
ports-3e5994f1a0acf3b411a845cdde918926b05dc00e.zip
Notes
Diffstat (limited to 'cad/qcad')
-rw-r--r--cad/qcad/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/cad/qcad/Makefile b/cad/qcad/Makefile
index 29c7d429ea9d..38efe551ebb4 100644
--- a/cad/qcad/Makefile
+++ b/cad/qcad/Makefile
@@ -45,7 +45,6 @@ do-build:
pre-install:
@${ECHO_CMD} bin/qcad > ${PLIST}
- @${ECHO_CMD} '@exec mkdir -p %D/share/qcad/libraries' >> ${PLIST}
@${FIND} ${WRKSRC}/qcad/doc/ -type f | \
${SED} -e "s:^${WRKSRC}/:%%PORTDOCS%%share/:g" >> ${PLIST}
@${FIND} ${WRKSRC}/qcad/examples/ -type f | \
@@ -58,18 +57,19 @@ pre-install:
${SED} -e "s:^${WRKSRC}/:share/:g" >> ${PLIST}
@${FIND} ${WRKSRC}/qcad/scripts/ -type f | \
${SED} -e "s:^${WRKSRC}/:share/:g" >> ${PLIST}
- @${ECHO_CMD} '%%PORTDOCS%%@dirrm share/qcad/doc' >> ${PLIST}
+ @${FIND} -d ${WRKSRC}/qcad/doc -type d | \
+ ${SED} -e "s:^${WRKSRC}/:%%PORTDOCS%%@dirrm share/:g" >> ${PLIST}
@${ECHO_CMD} '%%PORTDOCS%%@dirrm share/qcad/examples' >> ${PLIST}
- @${ECHO_CMD} '@dirrm share/qcad/libraries' >> ${PLIST}
@${ECHO_CMD} '@dirrm share/qcad/fonts' >> ${PLIST}
@${ECHO_CMD} '@dirrm share/qcad/patterns' >> ${PLIST}
+ @${ECHO_CMD} '@dirrm share/qcad/qm' >> ${PLIST}
@${ECHO_CMD} '@dirrm share/qcad/scripts/python' >> ${PLIST}
@${ECHO_CMD} '@dirrm share/qcad/scripts' >> ${PLIST}
@${ECHO_CMD} '@dirrm share/qcad' >> ${PLIST}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/qcad/qcad ${PREFIX}/bin/qcad
- @${MKDIR} ${DATADIR}/libraries
+ @${MKDIR} ${DATADIR}
.for dir in fonts patterns qm scripts
${TAR} -C ${WRKSRC}/qcad --exclude CVS -cf - ${dir} | \
${TAR} -C ${DATADIR} --unlink -xf -