aboutsummaryrefslogtreecommitdiff
path: root/cad/salome/Makefile.ext
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2010-05-25 22:02:10 +0000
committerThierry Thomas <thierry@FreeBSD.org>2010-05-25 22:02:10 +0000
commit6cf8700f3378a5fc98ae3b92fd35fffcce37a28c (patch)
tree3180ee6dd807ccb13f8dff2a36b1eb9de544d852 /cad/salome/Makefile.ext
parent8baeafe842a6bb57b11cce97f561e9e792c84672 (diff)
downloadports-6cf8700f3378a5fc98ae3b92fd35fffcce37a28c.tar.gz
ports-6cf8700f3378a5fc98ae3b92fd35fffcce37a28c.zip
Notes
Diffstat (limited to 'cad/salome/Makefile.ext')
-rw-r--r--cad/salome/Makefile.ext13
1 files changed, 9 insertions, 4 deletions
diff --git a/cad/salome/Makefile.ext b/cad/salome/Makefile.ext
index 8d62fb11fa8c..ae93fa37b7d9 100644
--- a/cad/salome/Makefile.ext
+++ b/cad/salome/Makefile.ext
@@ -201,10 +201,15 @@ BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/PyQt4/QtXml.so:${PORTSDIR}/textproc/py-qt4
#Dependency from metis & scotsch
.if ${SAL_MODULE} == "med"
-BUILD_DEPENDS+= kmetis:${PORTSDIR}/math/metis \
- gmap:${PORTSDIR}/cad/scotch
-RUN_DEPENDS+= kmetis:${PORTSDIR}/math/metis \
- gmap:${PORTSDIR}/cad/scotch
+. if exists(${LOCALBASE}/bin/graphchk)
+BUILD_DEPENDS+= kmetis:${PORTSDIR}/math/metis
+RUN_DEPENDS+= kmetis:${PORTSDIR}/math/metis
+. else
+BUILD_DEPENDS+= kmetis:${PORTSDIR}/math/metis-edf
+RUN_DEPENDS+= kmetis:${PORTSDIR}/math/metis-edf
+.endif
+BUILD_DEPENDS+= gmap:${PORTSDIR}/cad/scotch
+RUN_DEPENDS+= gmap:${PORTSDIR}/cad/scotch
CONFIGURE_ENV+= METISDIR=${LOCALBASE} SCOTCHDIR=${LOCALBASE}
CPPFLAGS+= -I${LOCALBASE}/include/metis
.endif