aboutsummaryrefslogtreecommitdiff
path: root/cad/salome
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-21 17:39:03 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-21 17:39:03 +0000
commit7ef963090c1ba3fae0e4ab7630e60ff49fe6a9f0 (patch)
treecf7e2bb2fe4cf190cc3da2f5ec6472007f6e4fda /cad/salome
parent16e40219b9f2996a944be12c348301ce78a1526a (diff)
downloadports-7ef963090c1ba3fae0e4ab7630e60ff49fe6a9f0.tar.gz
ports-7ef963090c1ba3fae0e4ab7630e60ff49fe6a9f0.zip
Notes
Diffstat (limited to 'cad/salome')
-rw-r--r--cad/salome/Makefile49
-rw-r--r--cad/salome/Makefile.ext4
2 files changed, 27 insertions, 26 deletions
diff --git a/cad/salome/Makefile b/cad/salome/Makefile
index 9068fccc9f19..19a72a3473d5 100644
--- a/cad/salome/Makefile
+++ b/cad/salome/Makefile
@@ -14,19 +14,20 @@ EXTRACT_ONLY= #none
MAINTAINER= devel@stasyan.com
-OPTIONS= \
- GEOM "GEOM module" on \
- MED "MED module" on \
- SMESH "SMESH module (require MED & GEOM)" on \
- NETGENPLUGIN "Netgen-meser plugin" on \
- VISU "VISU module (require MED)" on \
- LIGHT "LIGHT module" on \
- YACS "Yacs module" on \
- MULTIPR "Multipr module" on \
- RANDOMIZER "Randomizer module" on \
- SIERPINSKY "Sierpinsky module" on \
- JOBMAN "Job manager module" on \
- MPI "build with support parrallel calculation" on
+OPTIONS_DEFINE= GEOM MED SMESH NETGENPLUGIN VISU LIGHT YACS MULTIPR RANDOMIZER SIERPINSKY
+OPTIONS_DEFAULT= GEOM MED SMESH NETGENPLUGIN VISU LIGHT YACS MULTIPR RANDOMIZER SIERPINSKY
+GEOM_DESC= GEOM module
+MED_DESC= MED module
+SMESH_DESC= SMESH module (require MED & GEOM)
+NETGENPLUGIN_DESC= Netgen-meser plugin
+VISU_DESC= VISU module (require MED)
+LIGHT_DESC= LIGHT module
+YACS_DESC= Yacs module
+MULTIPR_DESC= Multipr module
+RANDOMIZER_DESC= Randomizer module
+SIERPINSKY_DESC= Sierpinsky module
+JOBMAN_DESC= Job manager module
+MPI_DESC= build with support parrallel calculation
RESOURCEDIR= ${PREFIX}/share/salome/resources
@@ -47,37 +48,37 @@ NO_BUILD= yes
RUN_DEPENDS+= ${RESOURCEDIR}/kernel:${PORTSDIR}/cad/salome-kernel \
${RESOURCEDIR}/gui:${PORTSDIR}/cad/salome-gui
-.if defined(WITH_GEOM)
+.if ${PORT_OPTIONS:MGEOM}
RUN_DEPENDS+= ${RESOURCEDIR}/geom:${PORTSDIR}/cad/salome-geom
.endif
-.if defined(WITH_LIGHT)
+.if ${PORT_OPTIONS:MLIGHT}
RUN_DEPENDS+= ${RESOURCEDIR}/light:${PORTSDIR}/cad/salome-light
.endif
-.if defined(WITH_YACS)
+.if ${PORT_OPTIONS:MYACS}
RUN_DEPENDS+= ${RESOURCEDIR}/yacs:${PORTSDIR}/cad/salome-yacs
.endif
-.if defined(WITH_RANDOMIZER)
+.if ${PORT_OPTIONS:MRANDOMIZER}
RUN_DEPENDS+= ${RESOURCEDIR}/randomizer:${PORTSDIR}/cad/salome-randomizer
.endif
-.if defined(WITH_VISU)
+.if ${PORT_OPTIONS:MVISU}
RUN_DEPENDS+= ${RESOURCEDIR}/visu:${PORTSDIR}/cad/salome-visu
.endif
-.if defined(WITH_MED)
+.if ${PORT_OPTIONS:MMED}
RUN_DEPENDS+= ${RESOURCEDIR}/med:${PORTSDIR}/cad/salome-med
.endif
-.if defined(WITH_SIERPINSKY)
+.if ${PORT_OPTIONS:MSIERPINSKY}
RUN_DEPENDS+= ${RESOURCEDIR}/sierpinsky:${PORTSDIR}/cad/salome-sierpinsky
.endif
-.if defined(WITH_SMESH)
+.if ${PORT_OPTIONS:MSMESH}
RUN_DEPENDS+= ${RESOURCEDIR}/smesh:${PORTSDIR}/cad/salome-smesh
.endif
-.if defined(WITH_NETGENPLUGIN)
+.if ${PORT_OPTIONS:MNETGENPLUGIN}
RUN_DEPENDS+= ${RESOURCEDIR}/netgenplugin:${PORTSDIR}/cad/salome-netgenplugin
.endif
-.if defined(WITH_MULTIPR)
+.if ${PORT_OPTIONS:MMULTIPR}
RUN_DEPENDS+= ${RESOURCEDIR}/multipr:${PORTSDIR}/cad/salome-multipr
.endif
-.if defined(WITH_JOBMAN)
+.if ${PORT_OPTIONS:MJOBMAN}
RUN_DEPENDS+= ${RESOURCEDIR}/jobmanager:${PORTSDIR}/cad/salome-jobmanager
.endif
diff --git a/cad/salome/Makefile.ext b/cad/salome/Makefile.ext
index e1537bf03ce7..8243cd13770e 100644
--- a/cad/salome/Makefile.ext
+++ b/cad/salome/Makefile.ext
@@ -269,7 +269,7 @@ STRIP=
#turn off cppunit support
.if ${SAL_MODULE} == "kernel" || ${SAL_MODULE} == "gui" || ${SAL_MODULE} == "yacs" || ${SAL_MODULE} == "med"
-#.if defined(WITH_CPPUNIT)
+#.if ${PORT_OPTIONS:MCPPUNIT}
#CONFIGURE_ARGS+= --with-cppunit=${LOCALBASE} --with-cppunit_inc=${LOCALBASE}/include/cppunit
#BUILD_DEPENDS+= cppunit-config:${PORTSDIR}/devel/cppunit
#PLIST_SUB+= CPPUNIT=""
@@ -281,7 +281,7 @@ PLIST_SUB+= CPPUNIT="@comment "
#optionally dependency from mpich2
.if ${SAL_MODULE} == "kernel" || ${SAL_MODULE} == "med"
-.if defined(WITH_MPI)
+.if ${PORT_OPTIONS:MMPI}
LIB_DEPENDS+= mpich.2:${PORTSDIR}/net/mpich2
CONFIGURE_ARGS+= --with-mpich=${LOCALBASE}/mpich2 --with-mpi=${LOCALBASE}/mpich2
PLIST_SUB+= MPI=""