aboutsummaryrefslogtreecommitdiff
path: root/cad/scv
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-23 06:03:56 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-23 06:03:56 +0000
commit349b712654284d9763d78e7eb371fd62889becb1 (patch)
tree146ddcdbd3ba7e6e6f37a79f8c43153f49dcc567 /cad/scv
parentb93c8d444f1c9e41aaaaf4ccd447bf8ccb97c860 (diff)
downloadports-349b712654284d9763d78e7eb371fd62889becb1.tar.gz
ports-349b712654284d9763d78e7eb371fd62889becb1.zip
Notes
Diffstat (limited to 'cad/scv')
-rw-r--r--cad/scv/pkg-plist229
1 files changed, 229 insertions, 0 deletions
diff --git a/cad/scv/pkg-plist b/cad/scv/pkg-plist
new file mode 100644
index 000000000000..27697a535fde
--- /dev/null
+++ b/cad/scv/pkg-plist
@@ -0,0 +1,229 @@
+systemc/AUTHORS.scv
+systemc/COPYING.scv
+systemc/INSTALL.scv
+systemc/LICENSE.scv
+systemc/NEWS.scv
+systemc/README.scv
+systemc/RELEASENOTES.scv
+systemc/docs/scv/ChangeLog
+systemc/docs/scv/LICENSE
+systemc/docs/scv/README
+systemc/docs/scv/date03a2.pdf
+systemc/docs/scv/intro_slides.pdf
+systemc/docs/scv/scv_random_white_paper4.pdf
+systemc/docs/scv/scvref/vwg_1_0e.pdf
+systemc/examples/scv/Makefile.rules
+systemc/examples/scv/README
+systemc/examples/scv/data_structures/scv_bag/Makefile
+systemc/examples/scv/data_structures/scv_bag/README
+systemc/examples/scv/data_structures/scv_bag/checktest.sh
+systemc/examples/scv/data_structures/scv_bag/packet.h
+systemc/examples/scv/data_structures/scv_bag/scv_bag.vcproj
+systemc/examples/scv/data_structures/scv_bag/test.cc
+systemc/examples/scv/data_structures/scv_bag/test_reg.cc
+systemc/examples/scv/data_structures/scv_sparse_array/Makefile
+systemc/examples/scv/data_structures/scv_sparse_array/README
+systemc/examples/scv/data_structures/scv_sparse_array/checktest.sh
+systemc/examples/scv/data_structures/scv_sparse_array/packet.h
+systemc/examples/scv/data_structures/scv_sparse_array/scv_sparse_array.vcproj
+systemc/examples/scv/data_structures/scv_sparse_array/test.cc
+systemc/examples/scv/data_structures/scv_sparse_array/test_reg.cc
+systemc/examples/scv/extensions/ex_01_userdata/Makefile
+systemc/examples/scv/extensions/ex_01_userdata/README
+systemc/examples/scv/extensions/ex_01_userdata/checktest.sh
+systemc/examples/scv/extensions/ex_01_userdata/data.h
+systemc/examples/scv/extensions/ex_01_userdata/data_ext.h
+systemc/examples/scv/extensions/ex_01_userdata/ex_01_userdata.vcproj
+systemc/examples/scv/extensions/ex_01_userdata/test.cc
+systemc/examples/scv/extensions/ex_01_userdata/test_reg.cc
+systemc/examples/scv/extensions/ex_02_enumdata/Makefile
+systemc/examples/scv/extensions/ex_02_enumdata/README
+systemc/examples/scv/extensions/ex_02_enumdata/checktest.sh
+systemc/examples/scv/extensions/ex_02_enumdata/ex_02_enumdata.vcproj
+systemc/examples/scv/extensions/ex_02_enumdata/state.h
+systemc/examples/scv/extensions/ex_02_enumdata/state_ext.h
+systemc/examples/scv/extensions/ex_02_enumdata/test.cc
+systemc/examples/scv/extensions/ex_02_enumdata/test_reg.cc
+systemc/examples/scv/extensions/ex_03_nestdata/Makefile
+systemc/examples/scv/extensions/ex_03_nestdata/README
+systemc/examples/scv/extensions/ex_03_nestdata/checktest.sh
+systemc/examples/scv/extensions/ex_03_nestdata/ex_03_nestdata.vcproj
+systemc/examples/scv/extensions/ex_03_nestdata/state.h
+systemc/examples/scv/extensions/ex_03_nestdata/state_ext.h
+systemc/examples/scv/extensions/ex_03_nestdata/test.cc
+systemc/examples/scv/extensions/ex_03_nestdata/test_reg.cc
+systemc/examples/scv/extensions/introspection1/Makefile
+systemc/examples/scv/extensions/introspection1/README
+systemc/examples/scv/extensions/introspection1/introspection1.vcproj
+systemc/examples/scv/extensions/introspection1/test.cpp
+systemc/examples/scv/extensions/private/Makefile
+systemc/examples/scv/extensions/private/README
+systemc/examples/scv/extensions/private/checktest.sh
+systemc/examples/scv/extensions/private/packet.h
+systemc/examples/scv/extensions/private/private.vcproj
+systemc/examples/scv/extensions/private/test.cc
+systemc/examples/scv/extensions/private/test_reg.cc
+systemc/examples/scv/general/hello/Makefile
+systemc/examples/scv/general/hello/README
+systemc/examples/scv/general/hello/hello.vcproj
+systemc/examples/scv/general/hello/main.cpp
+systemc/examples/scv/randomization/constraints/Makefile
+systemc/examples/scv/randomization/constraints/README
+systemc/examples/scv/randomization/constraints/constraints.h
+systemc/examples/scv/randomization/constraints/constraints.vcproj
+systemc/examples/scv/randomization/constraints/packet.cpp
+systemc/examples/scv/randomization/constraints/packet.h
+systemc/examples/scv/randomization/constraints/packet_constraints.h
+systemc/examples/scv/randomization/constraints/packet_ext.h
+systemc/examples/scv/randomization/constraints/test.cpp
+systemc/examples/scv/randomization/debug/Makefile
+systemc/examples/scv/randomization/debug/README
+systemc/examples/scv/randomization/debug/debug.vcproj
+systemc/examples/scv/randomization/debug/test.cpp
+systemc/examples/scv/randomization/ex_04_simplerand/Makefile
+systemc/examples/scv/randomization/ex_04_simplerand/README
+systemc/examples/scv/randomization/ex_04_simplerand/checktest.sh
+systemc/examples/scv/randomization/ex_04_simplerand/data.h
+systemc/examples/scv/randomization/ex_04_simplerand/data_ext.h
+systemc/examples/scv/randomization/ex_04_simplerand/ex_04_simplerand.vcproj
+systemc/examples/scv/randomization/ex_04_simplerand/test.cc
+systemc/examples/scv/randomization/ex_04_simplerand/test_reg.cc
+systemc/examples/scv/randomization/ex_05_disablerand/Makefile
+systemc/examples/scv/randomization/ex_05_disablerand/README
+systemc/examples/scv/randomization/ex_05_disablerand/checktest.sh
+systemc/examples/scv/randomization/ex_05_disablerand/data.h
+systemc/examples/scv/randomization/ex_05_disablerand/data_ext.h
+systemc/examples/scv/randomization/ex_05_disablerand/ex_05_disablerand.vcproj
+systemc/examples/scv/randomization/ex_05_disablerand/test.cc
+systemc/examples/scv/randomization/ex_05_disablerand/test_reg.cc
+systemc/examples/scv/randomization/ex_07_seedfile/Makefile
+systemc/examples/scv/randomization/ex_07_seedfile/README
+systemc/examples/scv/randomization/ex_07_seedfile/checktest.sh
+systemc/examples/scv/randomization/ex_07_seedfile/data.h
+systemc/examples/scv/randomization/ex_07_seedfile/data_ext.h
+systemc/examples/scv/randomization/ex_07_seedfile/ex_07_seedfile.vcproj
+systemc/examples/scv/randomization/ex_07_seedfile/test.cc
+systemc/examples/scv/randomization/ex_07_seedfile/test_reg.cc
+systemc/examples/scv/randomization/ex_08_dist/Makefile
+systemc/examples/scv/randomization/ex_08_dist/README
+systemc/examples/scv/randomization/ex_08_dist/checktest.sh
+systemc/examples/scv/randomization/ex_08_dist/data.h
+systemc/examples/scv/randomization/ex_08_dist/data_ext.h
+systemc/examples/scv/randomization/ex_08_dist/ex_08_dist.vcproj
+systemc/examples/scv/randomization/ex_08_dist/test.cc
+systemc/examples/scv/randomization/ex_08_dist/test_reg.cc
+systemc/examples/scv/randomization/ex_09_distrange/Makefile
+systemc/examples/scv/randomization/ex_09_distrange/README
+systemc/examples/scv/randomization/ex_09_distrange/checktest.sh
+systemc/examples/scv/randomization/ex_09_distrange/data.h
+systemc/examples/scv/randomization/ex_09_distrange/data_ext.h
+systemc/examples/scv/randomization/ex_09_distrange/ex_09_distrange.vcproj
+systemc/examples/scv/randomization/ex_09_distrange/test.cc
+systemc/examples/scv/randomization/ex_09_distrange/test_reg.cc
+systemc/examples/scv/randomization/ex_10_basicconstraint/Makefile
+systemc/examples/scv/randomization/ex_10_basicconstraint/README
+systemc/examples/scv/randomization/ex_10_basicconstraint/checktest.sh
+systemc/examples/scv/randomization/ex_10_basicconstraint/ex_10_basicconstraint.vcproj
+systemc/examples/scv/randomization/ex_10_basicconstraint/test.cc
+systemc/examples/scv/randomization/ex_10_basicconstraint/test_reg.cc
+systemc/examples/scv/randomization/ex_11_softconstraint/Makefile
+systemc/examples/scv/randomization/ex_11_softconstraint/README
+systemc/examples/scv/randomization/ex_11_softconstraint/checktest.sh
+systemc/examples/scv/randomization/ex_11_softconstraint/ex_11_softconstraint.vcproj
+systemc/examples/scv/randomization/ex_11_softconstraint/test.cc
+systemc/examples/scv/randomization/ex_11_softconstraint/test_reg.cc
+systemc/examples/scv/randomization/ex_12_hier_constraint/Makefile
+systemc/examples/scv/randomization/ex_12_hier_constraint/README
+systemc/examples/scv/randomization/ex_12_hier_constraint/checktest.sh
+systemc/examples/scv/randomization/ex_12_hier_constraint/ex_12_hier_constraint.vcproj
+systemc/examples/scv/randomization/ex_12_hier_constraint/packet.h
+systemc/examples/scv/randomization/ex_12_hier_constraint/packet_constraint.h
+systemc/examples/scv/randomization/ex_12_hier_constraint/packet_ext.h
+systemc/examples/scv/randomization/ex_12_hier_constraint/test.cc
+systemc/examples/scv/randomization/ex_12_hier_constraint/test_reg.cc
+systemc/examples/scv/randomization/ex_13_custom_next/Makefile
+systemc/examples/scv/randomization/ex_13_custom_next/README
+systemc/examples/scv/randomization/ex_13_custom_next/checktest.sh
+systemc/examples/scv/randomization/ex_13_custom_next/constraint.h
+systemc/examples/scv/randomization/ex_13_custom_next/ex_13_custom_next.vcproj
+systemc/examples/scv/randomization/ex_13_custom_next/test.cc
+systemc/examples/scv/randomization/ex_13_custom_next/test.h
+systemc/examples/scv/randomization/ex_13_custom_next/test_reg.cc
+systemc/examples/scv/randomization/pythagoras/Makefile
+systemc/examples/scv/randomization/pythagoras/README
+systemc/examples/scv/randomization/pythagoras/pythagoras.vcproj
+systemc/examples/scv/randomization/pythagoras/test.cpp
+systemc/examples/scv/transactions/overview/Makefile
+systemc/examples/scv/transactions/overview/README
+systemc/examples/scv/transactions/overview/main.cpp
+systemc/examples/scv/transactions/overview/overview.vcproj
+systemc/include/scv/_scv_associative_array.h
+systemc/include/scv/_scv_data_structure.h
+systemc/include/scv/_scv_ext_callbacks.h
+systemc/include/scv/_scv_ext_comp.h
+systemc/include/scv/_scv_ext_rand.h
+systemc/include/scv/_scv_ext_rw.h
+systemc/include/scv/_scv_ext_type.h
+systemc/include/scv/_scv_ext_util.h
+systemc/include/scv/_scv_introspection.h
+systemc/include/scv/_scv_list_iter.h
+systemc/include/scv/_scv_randomization.h
+systemc/include/scv/_scv_smart_ptr.h
+systemc/include/scv/scv_bag.h
+systemc/include/scv/scv_config.h
+systemc/include/scv/scv_constraint.h
+systemc/include/scv/scv_constraint_range.h
+systemc/include/scv/scv_debug.h
+systemc/include/scv/scv_expression.h
+systemc/include/scv/scv_introspection.h
+systemc/include/scv/scv_kit_date.h
+systemc/include/scv/scv_messages.h
+systemc/include/scv/scv_object_if.h
+systemc/include/scv/scv_random.h
+systemc/include/scv/scv_report.h
+systemc/include/scv/scv_shared_ptr.h
+systemc/include/scv/scv_sparse_array.h
+systemc/include/scv/scv_tr.h
+systemc/include/scv/scv_util.h
+systemc/include/scv.h
+systemc/lib-freebsd/libcudd.a
+systemc/lib-freebsd/libdddmp.a
+systemc/lib-freebsd/libmtr.a
+systemc/lib-freebsd/libobj.a
+systemc/lib-freebsd/libscv.so
+systemc/lib-freebsd/libst.a
+systemc/lib-freebsd/libutil.a
+@dirrm systemc/docs/scv/scvref
+@dirrm systemc/docs/scv
+@dirrmtry systemc/docs
+@dirrm systemc/examples/scv/data_structures/scv_bag
+@dirrm systemc/examples/scv/data_structures/scv_sparse_array
+@dirrm systemc/examples/scv/data_structures
+@dirrm systemc/examples/scv/extensions/ex_01_userdata
+@dirrm systemc/examples/scv/extensions/ex_02_enumdata
+@dirrm systemc/examples/scv/extensions/ex_03_nestdata
+@dirrm systemc/examples/scv/extensions/introspection1
+@dirrm systemc/examples/scv/extensions/private
+@dirrm systemc/examples/scv/extensions
+@dirrm systemc/examples/scv/general/hello
+@dirrm systemc/examples/scv/general
+@dirrm systemc/examples/scv/randomization/constraints
+@dirrm systemc/examples/scv/randomization/debug
+@dirrm systemc/examples/scv/randomization/ex_04_simplerand
+@dirrm systemc/examples/scv/randomization/ex_05_disablerand
+@dirrm systemc/examples/scv/randomization/ex_07_seedfile
+@dirrm systemc/examples/scv/randomization/ex_08_dist
+@dirrm systemc/examples/scv/randomization/ex_09_distrange
+@dirrm systemc/examples/scv/randomization/ex_10_basicconstraint
+@dirrm systemc/examples/scv/randomization/ex_11_softconstraint
+@dirrm systemc/examples/scv/randomization/ex_12_hier_constraint
+@dirrm systemc/examples/scv/randomization/ex_13_custom_next
+@dirrm systemc/examples/scv/randomization/pythagoras
+@dirrm systemc/examples/scv/randomization
+@dirrm systemc/examples/scv/transactions/overview
+@dirrm systemc/examples/scv/transactions
+@dirrm systemc/examples/scv
+@dirrm systemc/include/scv
+@dirrmtry systemc/include
+@dirrmtry systemc/lib-freebsd
+@dirrmtry systemc