aboutsummaryrefslogtreecommitdiff
path: root/cad/sp2sp
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2016-11-05 18:52:36 +0000
committerHiroki Sato <hrs@FreeBSD.org>2016-11-05 18:52:36 +0000
commitbccbbe71bca9b6f8c49ef56c8938262174383e8e (patch)
treee9fc765773f45445649cb9e743971165bece4c8a /cad/sp2sp
parent29a009367b27d4e842598fda3efcd5b7b060cc25 (diff)
downloadports-bccbbe71bca9b6f8c49ef56c8938262174383e8e.tar.gz
ports-bccbbe71bca9b6f8c49ef56c8938262174383e8e.zip
Add cad/sp2sp, a command-line waveform data processor for SPICE-type
simulators.
Notes
Notes: svn path=/head/; revision=425428
Diffstat (limited to 'cad/sp2sp')
-rw-r--r--cad/sp2sp/Makefile22
-rw-r--r--cad/sp2sp/distinfo3
-rw-r--r--cad/sp2sp/files/patch-Makefile.am11
-rw-r--r--cad/sp2sp/files/patch-configure.ac87
-rw-r--r--cad/sp2sp/pkg-descr10
5 files changed, 133 insertions, 0 deletions
diff --git a/cad/sp2sp/Makefile b/cad/sp2sp/Makefile
new file mode 100644
index 000000000000..2bd4b58a7133
--- /dev/null
+++ b/cad/sp2sp/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= sp2sp
+PORTVERSION= 20090213
+CATEGORIES= cad
+MASTER_SITES= SF/gwave/gwave2/${PORTVERSION}
+DISTNAME= gwave2-${PORTVERSION}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Processor of waveform data generated by SPICE-type simulators
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
+USES= autoreconf gettext-runtime
+USE_GNOME= gtk20 pango atk cairo gdkpixbuf2 glib20
+GNU_CONFIGURE= yes
+PLIST_FILES= bin/sp2sp
+
+.include <bsd.port.mk>
diff --git a/cad/sp2sp/distinfo b/cad/sp2sp/distinfo
new file mode 100644
index 000000000000..bc637860b198
--- /dev/null
+++ b/cad/sp2sp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1478370612
+SHA256 (gwave2-20090213.tar.gz) = 464c7bc6f2bb84413959584b4ed08b3391361fd7524fc93f7fd1c1cde370ea7f
+SIZE (gwave2-20090213.tar.gz) = 403957
diff --git a/cad/sp2sp/files/patch-Makefile.am b/cad/sp2sp/files/patch-Makefile.am
new file mode 100644
index 000000000000..5b997b008ad7
--- /dev/null
+++ b/cad/sp2sp/files/patch-Makefile.am
@@ -0,0 +1,11 @@
+--- Makefile.am.orig 2016-11-06 03:33:18.529485000 +0900
++++ Makefile.am 2016-11-06 03:33:34.527390000 +0900
+@@ -2,7 +2,7 @@
+ ## Process this file with automake to produce Makefile.in
+
+ #SUBDIRS=spicefile utilities src scheme doc remote
+-SUBDIRS=spicefile utilities src scheme remote
++SUBDIRS=spicefile
+
+ EXTRA_DIST=autogen.sh gwave.spec TODO FAQ plotutils-2.4.1.patch
+
diff --git a/cad/sp2sp/files/patch-configure.ac b/cad/sp2sp/files/patch-configure.ac
new file mode 100644
index 000000000000..4039a84ddf78
--- /dev/null
+++ b/cad/sp2sp/files/patch-configure.ac
@@ -0,0 +1,87 @@
+--- configure.ac.orig 2009-02-13 14:00:57.000000000 +0900
++++ configure.ac 2016-11-06 03:36:13.237251000 +0900
+@@ -16,20 +16,6 @@
+ AC_PATH_PROGS(PERL, perl perl5, no)
+ AC_SUBST(PERL)
+
+-# this tries to find GNU graph only, not traditional berkeley/sysv graph,
+-# so we do the right thing on solaris, where an unusable one is in /usr/bin
+-# and the graph we want is usually in /usr/local/bin or some such.
+-AC_ARG_WITH(graph, [full pathname to GNU graph for postscript plotting])
+-dnl AC_MSG_RESULT(with_graph is $with_graph)
+-if test "$with_graph" != no; then
+- if test "$with_graph" != yes && test ! -z "$with_graph" ; then
+- AC_DEFINE_UNQUOTED(PROG_GRAPH, "$with_graph", [If present, the pathname of graph, from GNU plotutils.])
+- else
+- AC_PROG_GREPSTDOUT(GRAPH, graph --version, GNU, $ac_dir/$ac_word)
+- AC_DEFINE_UNQUOTED(PROG_GRAPH, "$GRAPH", [If present, the pathname of graph, from GNU plotutils.])
+- fi
+-fi
+-
+ dnl do we need libtool?
+ dnl even though we aren't building shared libraries, it seemed to help on HP-UX
+ dnl AM_PROG_LIBTOOL
+@@ -51,62 +37,8 @@
+ dnl check for gtk/glib features
+ AC_CHECK_LIB(c, g_slice_set_config, AC_DEFINE(HAVE_G_SLICE_SET_CONFIG,1,[Define this if your version of glib2 has the slice allocator and g_slice_set_config]),,[$GTK_LIBS])
+
+-
+-dnl check for readline library
+-AC_CHECK_LIB(termcap, tgoto, [
+- AC_CHECK_LIB(readline, readline, [
+- READLINE_LIB="-lreadline -ltermcap"
+- AC_DEFINE(HAVE_READLINE,1,[Define this if you have the readline library])
+- AC_CHECK_LIB(readline, add_history, AC_DEFINE(HAVE_HISTORY,1,[Define this if your readline also has add_history]),,"-ltermcap"
+-)
+- ], READLINE_LIB="", "-ltermcap")
+-], AC_CHECK_LIB(ncurses, tgoto, [
+- AC_CHECK_LIB(readline, readline, [
+- READLINE_LIB="-lreadline -lncurses"
+- AC_DEFINE(HAVE_READLINE,1,[Define this if you have the readline library])
+- AC_CHECK_LIB(readline, add_history, AC_DEFINE(HAVE_HISTORY,1,[Define this if your readline also has add_history]),,"-l
+-ncurses")
+- ], READLINE_LIB="", "-lncurses")
+-], READLINE_LIB=""))
+-
+-AC_SUBST(READLINE_LIB)
+-
+-
+-dnl check for guile
+-GUILE_FLAGS
+-
+-dnl checks for guile version-specific features, if any
+-
+-
+-dnl check for guile-gnome-platform
+-
+-GUILE_MODULE_REQUIRED(gnome-2)
+-dnl GUILE_MODULE_REQUIRED(gnome gtk)
+-
+-PKG_CHECK_MODULES(GUILE_GNOME, guile-gnome-gtk-2, ,AC_MSG_ERROR(Can not find Guile-gnome-platform))
+-
+-dnl remind myself how to check for somthing I know exists
+-dnl GUILE_MODULE_EXPORTS(foo_widget_show, (gnome-0)(gnome gtk),gtk-widget-show)
+-dnl if test "$foo_widget_show" = yes; then
+-dnl AC_DEFINE(FOO_WIDGET_SHOW,1,"Defined if guile-gnome module (gnome gtk) already contains gtk-widget-show")
+-dnl fi
+-
+-GUILE_MODULE_EXPORTS(have_guile_gtk_menu_popup,(gnome-2)(gnome gtk),gtk-menu-popup)
+-if test "$have_guile_gtk_menu_popup" = yes; then
+- AC_DEFINE(HAVE_GUILE_GTK_MENU_POPUP,1,"Defined if guile-gnome module (gnome gtk) already contains gtk-menu-popup")
+-fi
+-
+-
+ dnl doesn't work if prefix isn't specified.
+ dnl AC_DEFINE_UNQUOTED(DATADIR,"${datadir}",Installation prefix for finding necessary guile code)
+
+ AC_OUTPUT(Makefile \
+-src/Makefile spicefile/Makefile scheme/Makefile \
+-src/app/Makefile \
+-remote/Makefile \
+-utilities/Makefile \
+-utilities/gwave-doc-snarf \
+-utilities/doc-split \
+-utilities/sweepsplit \
+-gwave.spec \
+-scheme/gwave-config.scm)
++src/Makefile spicefile/Makefile)
diff --git a/cad/sp2sp/pkg-descr b/cad/sp2sp/pkg-descr
new file mode 100644
index 000000000000..c47e8de269f3
--- /dev/null
+++ b/cad/sp2sp/pkg-descr
@@ -0,0 +1,10 @@
+sp2sp ("spice to spice") is a processor of waveform data generated by
+SPICE-type simulators. It uses libspicefile library in Gwave which
+provides SpiceStream and WaveFile avstraction levels. sp2sp uses
+SpiceStream to convert any file format supported by the SpiceStream
+layer into one of several ASCII printable formats, and it is useful
+for converting files any of the binary formats into a printable form,
+where they can easily be processed by awk, perl, or some other scripting
+language.
+
+WWW: http://gwave.sourceforge.net/