aboutsummaryrefslogtreecommitdiff
path: root/cad/spice/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1996-05-23 08:17:41 +0000
committerThomas Gellekum <tg@FreeBSD.org>1996-05-23 08:17:41 +0000
commit79e8f75f8d4205bf45b37bece893f7553c8e7622 (patch)
tree56f91f9b24b964707cc1cffb8ba9bb4e7e0142d2 /cad/spice/Makefile
parent805d9aef3d0933a3cd70c81b85cf9fe8d71f812b (diff)
downloadports-79e8f75f8d4205bf45b37bece893f7553c8e7622.tar.gz
ports-79e8f75f8d4205bf45b37bece893f7553c8e7622.zip
Notes
Diffstat (limited to 'cad/spice/Makefile')
-rw-r--r--cad/spice/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/cad/spice/Makefile b/cad/spice/Makefile
new file mode 100644
index 000000000000..8c4bced071d1
--- /dev/null
+++ b/cad/spice/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: spice
+# Version required: 3f4 (3f5?)
+# Date created: 26 Mar 96
+# Whom: Julian Jenkins <kaveman@magna.com.au>
+#
+#
+
+DISTNAME= spice3f4
+PKGNAME= spice-3f4
+CATEGORIES+= cad
+MASTER_SITES= ftp://sunsite.unc.edu/pub/Linux/apps/circuits/
+
+#PATCH_SITES= ftp://ic.eecs.berkeley.edu/pub/Spice3/3f4patches
+#PATCHFILES= grid.patch newcoms.patch spsmp.patch
+# documentation in ftp://ic.eecs.berkeley.edu/pub/Spice3/um.3f3.ps
+
+MAINTAINER= kaveman@magna.com.au
+
+# export restrictions
+NO_CDROM= yes
+
+post-install:
+ chmod a+rx ${PREFIX}/bin/spice3 ${PREFIX}/bin/nutmeg \
+ ${PREFIX}/bin/sconvert ${PREFIX}/bin/help ${PREFIX}/bin/proc2mod \
+ ${PREFIX}/bin/multidec
+ strip ${PREFIX}/bin/spice3 ${PREFIX}/bin/nutmeg \
+ ${PREFIX}/bin/sconvert ${PREFIX}/bin/help ${PREFIX}/bin/proc2mod \
+ ${PREFIX}/bin/multidec
+ chmod -R a+rX ${PREFIX}/share/spice
+ chmod a+rx ${PREFIX}/man/man5/mfbcap.5.gz \
+ ${PREFIX}/man/man1/sconvert.1.gz ${PREFIX}/man/man1/nutmeg.1.gz \
+ ${PREFIX}/man/man1/spice.1.gz ${PREFIX}/man/man3/mfb.3.gz
+
+.include <bsd.port.mk>