aboutsummaryrefslogtreecommitdiff
path: root/cad/spice
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-04-05 20:51:27 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-04-05 20:51:27 +0000
commit714ea1c6623c73ff6b6b85dc96cd85c8d66afc19 (patch)
treea96f4e0b0003c74b27eba98ee6588a16a5806b7d /cad/spice
parent77cd648cbfa2f44ec9d45a1d44e479737973bb64 (diff)
downloadports-714ea1c6623c73ff6b6b85dc96cd85c8d66afc19.tar.gz
ports-714ea1c6623c73ff6b6b85dc96cd85c8d66afc19.zip
Notes
Diffstat (limited to 'cad/spice')
-rw-r--r--cad/spice/Makefile13
-rw-r--r--cad/spice/distinfo6
-rw-r--r--cad/spice/files/patch-sp3f5141
-rw-r--r--cad/spice/files/patch-src_include_cpstd_h12
-rw-r--r--cad/spice/files/patch-src_include_misc_h55
-rw-r--r--cad/spice/files/patch-src_include_os_bsd_h9
-rw-r--r--cad/spice/files/patch-src_lib_fte_resource_c25
-rw-r--r--cad/spice/files/patch-util_skeleton_make_def_bd11
-rw-r--r--cad/spice/pkg-descr2
-rw-r--r--cad/spice/pkg-plist18
10 files changed, 83 insertions, 209 deletions
diff --git a/cad/spice/Makefile b/cad/spice/Makefile
index 2ed20c5a8313..0f099d9b7110 100644
--- a/cad/spice/Makefile
+++ b/cad/spice/Makefile
@@ -7,20 +7,19 @@
PORTNAME= spice
PORTVERSION= 3f5.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= cad
-MASTER_SITES= ftp://ic.eecs.berkeley.edu/pub/Spice3/:sources \
+MASTER_SITES= http://embedded.eecs.berkeley.edu/pubs/downloads/spice/:sources \
ftp://ic.eecs.berkeley.edu/pub/Spice3/um.3f3.ps/:docs
-DISTFILES= sp3f4.kit${EXTRACT_SUFX}:sources \
+DISTFILES= spice3f5${EXTRACT_SUFX}:sources \
cp.ps:docs toc.ps:docs doc.ps:docs
DIST_SUBDIR= spice
-EXTRACT_ONLY= sp3f4.kit${EXTRACT_SUFX}
+EXTRACT_ONLY= spice3f5${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= A general-purpose circuit simulation program
-USE_REINPLACE= yes
-NO_WRKSUBDIR= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}3f5
MAN1= sconvert.1 nutmeg.1 spice.1
MAN3= mfb.3
MAN5= mfbcap.5
@@ -29,8 +28,8 @@ MAKEFILE= ${FILESDIR}/Makefile
MAKE_ENV+= STRIP_CMD=${STRIP_CMD}
.ifdef WITHOUT_X11
-COMMENT= A general-purpose circuit simulation program (non-X11 version)
PKGNAMESUFFIX= -without-x11
+COMMENT= A general-purpose circuit simulation program (non-X11 version)
MAKE_ARGS+= -DWITHOUT_X11
.else
USE_XLIB= yes
diff --git a/cad/spice/distinfo b/cad/spice/distinfo
index 8a0bd11dd19f..e109852b3a46 100644
--- a/cad/spice/distinfo
+++ b/cad/spice/distinfo
@@ -1,6 +1,6 @@
-MD5 (spice/sp3f4.kit.tar.gz) = 744e61c241adedb0553a74f8df6779c1
-SHA256 (spice/sp3f4.kit.tar.gz) = 6f93854b8e51040f90966cf04b4de68aec258d21abffc2515c0448c166d41e53
-SIZE (spice/sp3f4.kit.tar.gz) = 1224435
+MD5 (spice/spice3f5.tar.gz) = 14d901bda437d4edda91c929b87eff51
+SHA256 (spice/spice3f5.tar.gz) = 233fe76233dc4071f43c902819a24050d3011fe6ece4c2fe2ac41f32b0e33bfb
+SIZE (spice/spice3f5.tar.gz) = 1226208
MD5 (spice/cp.ps) = ee9065de6e11e82fa3fe34318c2373fc
SHA256 (spice/cp.ps) = 3bab6c3487def4ce2e817bf7ef3c1a7d199ea8e790da3a786f936872b35d0920
SIZE (spice/cp.ps) = 10297
diff --git a/cad/spice/files/patch-sp3f5 b/cad/spice/files/patch-sp3f5
deleted file mode 100644
index f9606a6b4cc1..000000000000
--- a/cad/spice/files/patch-sp3f5
+++ /dev/null
@@ -1,141 +0,0 @@
-These are official Berkeley fixes for sp3f4
-*** src/lib/fte/grid.c.orig Sun Apr 25 14:53:11 1993
---- src/lib/fte/grid.c Sat Jan 29 10:47:59 1994
-***************
-*** 17,22 ****
---- 17,23 ----
- #include "suffix.h"
-
- #define RAD_TO_DEG (180.0 / M_PI)
-+ #define LABEL_CHARS 20
-
- static double *lingrid(), *loggrid();
- static void polargrid(), smithgrid();
-***************
-*** 225,231 ****
- int max;
- static double dd[2];
- int mult = 1;
-! char buf[16], *s;
- int slim, digits;
-
- if (axis == y_axis && graph->grid.ysized) {
---- 226,232 ----
- int max;
- static double dd[2];
- int mult = 1;
-! char buf[LABEL_CHARS], *s;
- int slim, digits;
-
- if (axis == y_axis && graph->grid.ysized) {
-***************
-*** 477,483 ****
- drawlingrid(graph, units, spacing, nsp, dst, lmt, hmt, onedec, mult, mag,
- digits, axis)
- GRAPH *graph;
-! char units[16];
- bool onedec;
- int nsp, spacing, mult;
- double hmt, lmt, dst;
---- 478,484 ----
- drawlingrid(graph, units, spacing, nsp, dst, lmt, hmt, onedec, mult, mag,
- digits, axis)
- GRAPH *graph;
-! char *units;
- bool onedec;
- int nsp, spacing, mult;
- double hmt, lmt, dst;
-***************
-*** 488,494 ****
-
- int i, j;
- double m, step;
-! char buf[16];
-
- /* i counts how many pixels we have drawn, and j counts which unit
- * we are at.
---- 489,495 ----
-
- int i, j;
- double m, step;
-! char buf[LABEL_CHARS];
-
- /* i counts how many pixels we have drawn, and j counts which unit
- * we are at.
-***************
-*** 567,573 ****
- double k;
- double decs;
- double mag, gain;
-! char buf[32], *s;
-
- if (axis == x_axis && graph->grid.xsized) {
- lmt = graph->grid.xaxis.log.lmt;
---- 568,574 ----
- double k;
- double decs;
- double mag, gain;
-! char buf[LABEL_CHARS], *s;
-
- if (axis == x_axis && graph->grid.xsized) {
- lmt = graph->grid.xaxis.log.lmt;
-***************
-*** 671,677 ****
- {
- int i, j, k, l, m;
- double t;
-! char buf[16];
-
- /* Now plot every pp'th decade line, with subs lines between them. */
- if (subs > 1)
---- 672,678 ----
- {
- int i, j, k, l, m;
- double t;
-! char buf[LABEL_CHARS];
-
- /* Now plot every pp'th decade line, with subs lines between them. */
- if (subs > 1)
-*** src/lib/fte/newcoms.c.orig Sun Mar 7 16:30:58 1993
---- src/lib/fte/newcoms.c Wed Feb 23 22:39:55 1994
-***************
-*** 151,156 ****
---- 151,160 ----
- /* Copy from the first */
- vname = cp_unquote(wl->wl_word);
- dv = vec_get(vname);
-+ if (!dv) {
-+ printf("'%s' reference vector not found\n", vname);
-+ return;
-+ }
- numdims = dv->v_numdims;
- dims = dv->v_dims;
- wl = wl->wl_next;
-*** src/lib/sparse/spsmp.c.orig Wed Feb 3 14:20:50 1993
---- src/lib/sparse/spsmp.c Sun Jan 30 11:53:10 1994
-***************
-*** 483,492 ****
- int CreateIfMissing;
- {
- MatrixPtr Matrix = (MatrixPtr)eMatrix;
-! ElementPtr Element = Matrix->FirstInCol[Col];
-
- /* Begin `SMPfindElt'. */
- ASSERT( IS_SPARSE( Matrix ) );
- Element = spcFindElementInCol(Matrix, &Element, Row, Col, CreateIfMissing);
- return (SMPelement *)Element;
- }
---- 485,497 ----
- int CreateIfMissing;
- {
- MatrixPtr Matrix = (MatrixPtr)eMatrix;
-! ElementPtr Element;
-
- /* Begin `SMPfindElt'. */
- ASSERT( IS_SPARSE( Matrix ) );
-+ Row = Matrix->ExtToIntRowMap[Row];
-+ Col = Matrix->ExtToIntColMap[Col];
-+ Element = Matrix->FirstInCol[Col];
- Element = spcFindElementInCol(Matrix, &Element, Row, Col, CreateIfMissing);
- return (SMPelement *)Element;
- }
diff --git a/cad/spice/files/patch-src_include_cpstd_h b/cad/spice/files/patch-src_include_cpstd_h
new file mode 100644
index 000000000000..834ec79cdcfb
--- /dev/null
+++ b/cad/spice/files/patch-src_include_cpstd_h
@@ -0,0 +1,12 @@
+--- src/include/cpstd.h.orig 2005-12-17 13:10:09.000000000 +0000
++++ src/include/cpstd.h
+@@ -50,7 +50,9 @@ extern char *tildexpand();
+ extern char *printnum();
+ extern int cp_numdgt;
+ extern void fatal();
++#ifndef _STDLIB_H_
+ extern void setenv();
++#endif
+ extern void cp_printword();
+
+ /* Externs from wlist.c */
diff --git a/cad/spice/files/patch-src_include_misc_h b/cad/spice/files/patch-src_include_misc_h
index a772f63793e2..5f97d18a30a6 100644
--- a/cad/spice/files/patch-src_include_misc_h
+++ b/cad/spice/files/patch-src_include_misc_h
@@ -1,31 +1,24 @@
-*** src/include/misc.h.orig Thu Dec 1 09:17:02 1994
---- src/include/misc.h Sun Mar 31 12:32:58 1996
-***************
-*** 86,92 ****
---- 86,94 ----
- extern char *realloc();
- extern char *getenv();
- extern int errno;
-+ #ifndef __FreeBSD__
- extern char *sys_errlist[];
-+ #endif
- extern char *getenv();
- extern char *getwd();
- extern int rand();
-***************
-*** 111,122 ****
---- 111,124 ----
- # endif /* clearerr */
- # endif /* HAS_CLEARERR */
-
-+ #ifndef __FreeBSD__
- # ifndef bzero
- extern int bzero();
- # endif
- # ifndef bcopy
- extern void bcopy();
- # endif
-+ #endif /* __FreeBSD__ */
-
- # ifndef index
- # ifdef HAS_INDEX
+--- src/include/misc.h.orig Sun Apr 25 16:37:48 1993
++++ src/include/misc.h Mon Apr 3 23:04:51 2006
+@@ -86,8 +86,10 @@
+ extern char *realloc();
+ extern char *getenv();
+ extern int errno;
++#ifndef __FreeBSD__
+ extern char *sys_errlist[];
+ extern char *getenv();
++#endif
+ extern char *getwd();
+ extern int rand();
+ extern int srand();
+@@ -154,7 +156,9 @@
+
+ #ifndef HAS_MEMAVL
+ # ifdef HAS_RLIMIT_
+-extern char *sbrk();
++#include <sys/types.h>
++#include <sys/time.h>
++#include <sys/resource.h>
+ # endif
+ #endif
+
diff --git a/cad/spice/files/patch-src_include_os_bsd_h b/cad/spice/files/patch-src_include_os_bsd_h
index bcd219cedfa0..0d783698ceef 100644
--- a/cad/spice/files/patch-src_include_os_bsd_h
+++ b/cad/spice/files/patch-src_include_os_bsd_h
@@ -1,18 +1,20 @@
--- src/include/os_bsd.h.orig Sat Apr 24 18:09:46 1993
-+++ src/include/os_bsd.h Thu Jul 17 01:26:36 2003
-@@ -8,18 +8,31 @@
++++ src/include/os_bsd.h Mon Apr 3 21:27:21 2006
+@@ -8,18 +8,32 @@
#include "os_unix.h"
+#ifdef __FreeBSD__
++#define HAS_STDLIB /* #include <stdlib.h> for libc defs */
+#define HAS_SYSVDIRS /* <sys/dirent.h> */
+#define HAS_INTWAITSTATUS /* wait(3) takes an int *, not a union */
++#define HAS_STRINGS /* use <strings.h> instead of <string.h> */
++#define HAS_STRCHR /* strchr( ) instead of index( ) */
+#else
#define HAS_NO_ATRIGH_DECL /* if asinh( ) is not in math.h */
-#define HAS_ATRIGH /* acosh( ), asinh( ), atanh( ) */
#define HAS_FTIME /* ftime( ), <times.h> */
+#define HAS_INDEX /* index( ) instead of strchr( ) */
-+#define HAS_STRINGS /* use <strings.h> instead of <string.h> */
+#define HAS_BSDDIRS /* <sys/dir.h> */
+#endif
+
@@ -34,5 +36,4 @@
+#define HAS_BSDSOCKETS /* <net/inet.h>, socket( ), etc. */
+#define HAS_BSDTIME /* gettimeofday( ) return time */
+#define HAS_FLOAT_H /* float.h */
-+#define HAS_STRCHR /* strchr( ) instead of index( ) */
+#endif
diff --git a/cad/spice/files/patch-src_lib_fte_resource_c b/cad/spice/files/patch-src_lib_fte_resource_c
index b6ab6b0239c0..c63cd7452e2c 100644
--- a/cad/spice/files/patch-src_lib_fte_resource_c
+++ b/cad/spice/files/patch-src_lib_fte_resource_c
@@ -1,6 +1,27 @@
--- src/lib/fte/resource.c.orig Wed Apr 28 17:39:03 1993
-+++ src/lib/fte/resource.c Thu Jul 17 00:47:50 2003
-@@ -369,7 +369,9 @@
++++ src/lib/fte/resource.c Mon Apr 3 22:47:57 2006
+@@ -12,6 +12,7 @@
+ #include "ftedefs.h"
+
+ #include <sys/types.h>
++#include <unistd.h>
+
+ #ifdef HAS_BSDRLIMIT
+ # include <sys/time.h>
+@@ -144,7 +145,7 @@
+
+ # endif
+
+- usage = sbrk(0) - enddata;
++ usage = (char *)sbrk(0) - enddata;
+
+ # endif
+
+@@ -365,11 +366,12 @@
+ baseaddr( )
+ {
+ char *low, *high, *at;
+- char *sbrk( );
long x;
SIGNAL_TYPE (*orig_signal)( );
diff --git a/cad/spice/files/patch-util_skeleton_make_def_bd b/cad/spice/files/patch-util_skeleton_make_def_bd
deleted file mode 100644
index aa0f36710f81..000000000000
--- a/cad/spice/files/patch-util_skeleton_make_def_bd
+++ /dev/null
@@ -1,11 +0,0 @@
---- util/skeleton/make_def.bd.orig Thu Jul 29 16:35:18 1993
-+++ util/skeleton/make_def.bd Thu Jul 17 00:47:51 2003
-@@ -8,7 +8,7 @@
- PATH_SEP = /
- PS = /
- REVISION =
--VERSION = 3f4
-+VERSION = 3f5
- VERSION_REVISION= $(VERSION)$(REVISION)
- NOTICE =
- TOP = /projects/spice3/spice$(VERSION)
diff --git a/cad/spice/pkg-descr b/cad/spice/pkg-descr
index 22a13535dd95..932b49edb9a4 100644
--- a/cad/spice/pkg-descr
+++ b/cad/spice/pkg-descr
@@ -11,4 +11,4 @@ and the level 2 JFET model are courtesy from the Macquarie University.
Online documentation at:
-WWW: http://infopad.eecs.berkeley.edu/~icdesign/SPICE/
+WWW: http://bwrc.eecs.berkeley.edu/Classes/IcBook/SPICE/
diff --git a/cad/spice/pkg-plist b/cad/spice/pkg-plist
index 694db05f0aab..197b8ddbd8b0 100644
--- a/cad/spice/pkg-plist
+++ b/cad/spice/pkg-plist
@@ -4,15 +4,15 @@ bin/sconvert
bin/help
bin/proc2mod
bin/multidec
-share/spice/helpdir/spice.txt
-share/spice/helpdir/spice.idx
-share/spice/scripts/setplot
-share/spice/scripts/spinit
-share/spice/mfbcap
-share/spice/news
-@dirrm share/spice/helpdir
-@dirrm share/spice/scripts
-@dirrm share/spice
+%%DATADIR%%/helpdir/spice.txt
+%%DATADIR%%/helpdir/spice.idx
+%%DATADIR%%/scripts/setplot
+%%DATADIR%%/scripts/spinit
+%%DATADIR%%/mfbcap
+%%DATADIR%%/news
+@dirrm %%DATADIR%%/helpdir
+@dirrm %%DATADIR%%/scripts
+@dirrm %%DATADIR%%
%%PORTDOCS%%%%DOCSDIR%%/spice3f3.ps.gz
%%PORTDOCS%%%%EXAMPLESDIR%%/bjtnoise.cir
%%PORTDOCS%%%%EXAMPLESDIR%%/bsim1tst.cir