aboutsummaryrefslogtreecommitdiff
path: root/cad/tkgate/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2020-03-15 14:49:10 +0000
committerSteve Wills <swills@FreeBSD.org>2020-03-15 14:49:10 +0000
commitc021e20ce5c36c9b35bd15704b335b9d9017f1aa (patch)
tree5ccd6899166165e461786451d3660ff27155cb75 /cad/tkgate/Makefile
parent0f47a4b77b79a1c2ed87865db9e25ea4c64c7fae (diff)
downloadports-c021e20ce5c36c9b35bd15704b335b9d9017f1aa.tar.gz
ports-c021e20ce5c36c9b35bd15704b335b9d9017f1aa.zip
Notes
Diffstat (limited to 'cad/tkgate/Makefile')
-rw-r--r--cad/tkgate/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/cad/tkgate/Makefile b/cad/tkgate/Makefile
index 3b781bde2beb..34b16b5c1c36 100644
--- a/cad/tkgate/Makefile
+++ b/cad/tkgate/Makefile
@@ -11,21 +11,21 @@ COMMENT= Event driven digital circuit simulator
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-GNU_CONFIGURE= yes
-USES+= autoreconf gnome iconv:translit libtool pkgconfig tk:build,run
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
+USES= autoreconf gnome iconv:translit libtool pkgconfig tk
+
+USE_XORG= x11 xft
USE_GNOME= pango
OPTIONS_DEFINE= DOCS
+GNU_CONFIGURE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/bin/wish|${WISH}|g' ${WRKSRC}/scripts/tree.tcl
@${REINPLACE_CMD} -e \
's|%%TCL_VER%%|${TCL_VER}|g; \
s|%%TCL_INCLUDEDIR%%|${TCL_INCLUDEDIR}|g; \
s|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/configure.ac
-# Remove backup files somehow installed to the stagedir
-post-install:
- ${FIND} ${STAGEDIR}/${DATADIR} -name '*~' -delete -or -name '*~?' -delete
-
.include <bsd.port.mk>