aboutsummaryrefslogtreecommitdiff
path: root/cad/tochnog
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2003-07-13 05:29:48 +0000
committerMaho Nakata <maho@FreeBSD.org>2003-07-13 05:29:48 +0000
commitb92ae7663739e230ac19d009dc2d4d3dcfbb4894 (patch)
treef2fc4e92ab0da22c85065739d28a68671d2f76ce /cad/tochnog
parent7ea36c0d51916398cdfaf33201b50daa4247ccbb (diff)
downloadports-b92ae7663739e230ac19d009dc2d4d3dcfbb4894.tar.gz
ports-b92ae7663739e230ac19d009dc2d4d3dcfbb4894.zip
Notes
Diffstat (limited to 'cad/tochnog')
-rw-r--r--cad/tochnog/Makefile78
-rw-r--r--cad/tochnog/Makefile~78
-rw-r--r--cad/tochnog/distinfo1
-rw-r--r--cad/tochnog/files/patch--test10
-rw-r--r--cad/tochnog/files/patch--tools+aba2tn.c12
-rw-r--r--cad/tochnog/files/patch-makefile99
-rw-r--r--cad/tochnog/files/patch-tnhypo.h5
-rw-r--r--cad/tochnog/files/patch-tnsuplu.h15
-rw-r--r--cad/tochnog/files/patch-tochnog.h31
-rw-r--r--cad/tochnog/pkg-descr15
-rw-r--r--cad/tochnog/pkg-plist210
11 files changed, 554 insertions, 0 deletions
diff --git a/cad/tochnog/Makefile b/cad/tochnog/Makefile
new file mode 100644
index 000000000000..b1ca841911d9
--- /dev/null
+++ b/cad/tochnog/Makefile
@@ -0,0 +1,78 @@
+# New ports collection makefile for: tochnog
+# Date created: 19 Apr 2003
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tochnog
+PORTVERSION= 20010211
+CATEGORIES= cad
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= tochnog
+DISTNAME= ${PORTNAME}_feb11_2001
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A free explicit/implicit Finite Element Program
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libf2c.a:${PORTSDIR}/lang/f2c \
+ ${LOCALBASE}/lib/libf77blas.a:${PORTSDIR}/math/atlas
+.ifdef USE_THREADS
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libsuperlu_mt.a:${PORTSDIR}/math/superlu_mt
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libsuperlu.a:${PORTSDIR}/math/superlu
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+USE_GCC= 2.95
+.endif
+
+USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+MAKEFILE= makefile
+
+.ifdef USE_THREADS
+BLAS_LIBS= -L${LOCALBASE}/lib -lptf77blas -latlas_r
+SUPERLU= superlu_mt
+ALL_TARGET= freebsd_parallel
+.else
+BLAS_LIBS= -L${LOCALBASE}/lib -lf77blas -latlas
+SUPERLU= superlu
+ALL_TARGET= freebsd_old
+.endif
+
+.ifndef USE_THREADS
+pre-everything::
+ @${ECHO_MSG} "make USE_THREADS=yes for threaded version"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g ; \
+ s,%%PTHREAD_CFLAGS%%,${PTHREAD_CFLAGS},g ; s,%%PTHREAD_LIBS%%,${PTHREAD_LIBS},g ; \
+ s,%%SUPERLU%%,${SUPERLU},g ; \
+ s,%%BLAS_LIBS%%,${BLAS_LIBS},g' \
+ ${WRKSRC}/makefile
+.ifdef USE_THREADS
+ @${REINPLACE_CMD} -e 's,SUPERLU_MT_USE 0,SUPERLU_MT_USE 1,' \
+ ${WRKSRC}/tnsuplu.h
+.else
+ @${REINPLACE_CMD} -e 's,SUPERLU_USE 0,SUPERLU_USE 1,' \
+ ${WRKSRC}/tnsuplu.h
+.endif
+
+post-build:
+ @(cd ${WRKDIR}/tochnog/tools; ${CXX} ${CFLAGS} -o aba2tn aba2tn.cc)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tochnog ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKDIR}/tochnog/tools/aba2tn ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/tochnog/tools/*.awk ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/test
+ @${RM} -f ${WRKDIR}/tochnog/test/*.orig
+ ${INSTALL_DATA} ${WRKDIR}/tochnog/test/* ${DOCSDIR}/test
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/cad/tochnog/Makefile~ b/cad/tochnog/Makefile~
new file mode 100644
index 000000000000..a687de694c58
--- /dev/null
+++ b/cad/tochnog/Makefile~
@@ -0,0 +1,78 @@
+# New ports collection makefile for: tochnog
+# Date created: 19 Apr 2003
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $FreeBSD $
+#
+
+PORTNAME= tochnog
+PORTVERSION= 20010211
+CATEGORIES= cad
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= tochnog
+DISTNAME= ${PORTNAME}_feb11_2001
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A free explicit/implicit Finite Element Program
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libf2c.a:${PORTSDIR}/lang/f2c \
+ ${LOCALBASE}/lib/libf77blas.a:${PORTSDIR}/math/atlas
+.ifdef USE_THREADS
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libsuperlu_mt.a:${PORTSDIR}/math/superlu_mt
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libsuperlu.a:${PORTSDIR}/math/superlu
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+USE_GCC= 2.95
+.endif
+
+USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+MAKEFILE= makefile
+
+.ifdef USE_THREADS
+BLAS_LIBS= -L${LOCALBASE}/lib -lptf77blas -latlas_r
+SUPERLU= superlu_mt
+ALL_TARGET= freebsd_parallel
+.else
+BLAS_LIBS= -L${LOCALBASE}/lib -lf77blas -latlas
+SUPERLU= superlu
+ALL_TARGET= freebsd_old
+.endif
+
+.ifndef USE_THREADS
+pre-everything::
+ @${ECHO_MSG} "make USE_THREADS=yes for threaded version"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g ; \
+ s,%%PTHREAD_CFLAGS%%,${PTHREAD_CFLAGS},g ; s,%%PTHREAD_LIBS%%,${PTHREAD_LIBS},g ; \
+ s,%%SUPERLU%%,${SUPERLU},g ; \
+ s,%%BLAS_LIBS%%,${BLAS_LIBS},g' \
+ ${WRKSRC}/makefile
+.ifdef USE_THREADS
+ @${REINPLACE_CMD} -e 's,SUPERLU_MT_USE 0,SUPERLU_MT_USE 1,' \
+ ${WRKSRC}/tnsuplu.h
+.else
+ @${REINPLACE_CMD} -e 's,SUPERLU_USE 0,SUPERLU_USE 1,' \
+ ${WRKSRC}/tnsuplu.h
+.endif
+
+post-build:
+ @(cd ${WRKDIR}/tochnog/tools; ${CXX} ${CFLAGS} -o aba2tn aba2tn.cc)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tochnog ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKDIR}/tochnog/tools/aba2tn ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/tochnog/tools/*.awk ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/test
+ @${RM} -f ${WRKDIR}/tochnog/test/*.orig
+ ${INSTALL_DATA} ${WRKDIR}/tochnog/test/* ${DOCSDIR}/test
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/cad/tochnog/distinfo b/cad/tochnog/distinfo
new file mode 100644
index 000000000000..f522802e9b88
--- /dev/null
+++ b/cad/tochnog/distinfo
@@ -0,0 +1 @@
+MD5 (tochnog_feb11_2001.tar.gz) = f513e749541d72d0277cf262d2bd5f3b
diff --git a/cad/tochnog/files/patch--test b/cad/tochnog/files/patch--test
new file mode 100644
index 000000000000..3e8c06e50a32
--- /dev/null
+++ b/cad/tochnog/files/patch--test
@@ -0,0 +1,10 @@
+--- ../test/makefile.orig Sat May 10 21:32:30 2003
++++ ../test/makefile Sat May 10 21:32:44 2003
+@@ -1,6 +1,6 @@
+ default: small
+
+-TN="../src/tochnog"
++TN="tochnog"
+
+ all: small large very_large
+
diff --git a/cad/tochnog/files/patch--tools+aba2tn.c b/cad/tochnog/files/patch--tools+aba2tn.c
new file mode 100644
index 000000000000..a5f060d6ef77
--- /dev/null
+++ b/cad/tochnog/files/patch--tools+aba2tn.c
@@ -0,0 +1,12 @@
+--- ../tools/aba2tn.cc.orig Sat Jul 12 16:05:32 2003
++++ ../tools/aba2tn.cc Sat Jul 12 16:08:10 2003
+@@ -1,5 +1,7 @@
+-#include <fstream.h>
+-#include <iostream.h>
++#include <fstream>
++#include <iostream>
++using std::cout;
++using std::cin;
+ #include <string.h>
+ #include <stdio.h>
+ #include <stdlib.h>
diff --git a/cad/tochnog/files/patch-makefile b/cad/tochnog/files/patch-makefile
new file mode 100644
index 000000000000..fd9d6fcf31fc
--- /dev/null
+++ b/cad/tochnog/files/patch-makefile
@@ -0,0 +1,99 @@
+--- makefile.orig Sun Aug 19 12:31:52 2001
++++ makefile Wed Jun 18 12:57:01 2003
+@@ -1,6 +1,7 @@
+ # *********** fortran 2 c *******************
+ # Set F2C (for unix -lf2c and for MS windows to f2c.lib)
+-F2C=
++F2C= -lf2c -L%%LOCALBASE%%/lib
++F2C_INCLUDE= -I%%LOCALBASE%%/include
+
+ # *********** hypoplasticity ****************
+ # For hypoplasticity:
+@@ -8,8 +9,8 @@
+ # set HYPO_USE to 1 in tnhypo.h
+ # set HYPO_SRC to hypo.c below
+ # set HYPO_OBJ to hypo.o below
+-HYPO_SRC=hypo_dum.c
+-HYPO_OBJ=hypo_dum.o
++HYPO_SRC=hypo.c
++HYPO_OBJ=hypo.o
+
+ # *********** profiler ***********************
+ # for the gnu profiler, use as follows:
+@@ -26,11 +27,11 @@
+ SYS_FILE=sysother
+ BCPP=-P
+ VCPP=
+-COMPILER_C=bcc32
+-COMPILER_CPP=bcc32
+-COMPILER_FLAGS= -c -O2 -w-
++COMPILER_C=$(CC)
++COMPILER_CPP=$(CXX)
++COMPILER_FLAGS=$(CFLAGS) -c
+ OBJ=obj
+-LINK_FLAGS_BEFORE= -l$(F2C)
++LINK_FLAGS_BEFORE= -l$(F2C) -L%%LOCALBASE%%/lib
+ LINK_FLAGS_AFTER=
+
+ # *********** SUPERLU library *******************
+@@ -39,9 +40,9 @@
+ # Set SUPERLU_MT_USE to 1 in tnsuplu.h for the multi threaded version
+ # Set SUPERLU_DIST_USE to 1 in tnsuplu.h for the distributed MPI version
+ # 2. Activate and adjust the next three lines
+-# SUPERLU=/home/programs/src/SuperLU
+-# SUPERLU_LIB=$(SUPERLU)/superlu.a $(SUPERLU)/blas.a
+-# SUPERLU_INCLUDE=-I$(SUPERLU)/SRC
++SUPERLU=%%LOCALBASE%%
++SUPERLU_LIB=$(SUPERLU)/lib/lib%%SUPERLU%%.a %%BLAS_LIBS%%
++SUPERLU_INCLUDE=-I$(SUPERLU)/include/%%SUPERLU%%
+ # 3. For SuperLU_MT be sure to compile a multi threaded version
+ # of Tochnog (sparc_parallel, alpha_parallel, linux, etc.)
+
+@@ -65,7 +66,7 @@
+ ALL_LIB= $(PETSC_LIB) $(SUPERLU_LIB) $(F2C)
+
+ # *********** default platform *******************
+-default: linux_old
++default: freebsd_old
+
+ # single and multi-processor windows; borland c++ compiler
+ # set SYS_FILE above to syswin32 for multi-processor
+@@ -101,18 +102,23 @@
+ "LINK_FLAGS_AFTER= /link $(F2C) $(PROFILE) /OUT:tochnog.exe"
+
+ # single processor linux; gnu gcc compiler
+-linux_old:
++freebsd_old:
+ make tochnog \
+ "SYS_FILE=sysother" \
+ "OBJ=o" \
+- "BCPP=" \
+- "VCPP=" \
+- "COMPILER_C=gcc" \
+- "COMPILER_CPP=g++" \
+- "COMPILER_FLAGS= -ansi -c -O2 -Wall $(PROFILE) $(ALL_INCLUDE)" \
++ "COMPILER_FLAGS= -c ${CFLAGS} $(ALL_INCLUDE)" \
+ "LINK_FLAGS_BEFORE=" \
+ "LINK_FLAGS_AFTER= $(PROFILE) $(ALL_LIB) -static -lm -o tochnog"
+
++# Multithreaded FreeBSD
++freebsd_parallel:
++ make tochnog \
++ "SYS_FILE=sysposix" \
++ "OBJ=o" \
++ "COMPILER_FLAGS= -c ${CFLAGS} %%PTHREAD_CFLAGS%% -D_REENTRANT $(ALL_INCLUDE)" \
++ "LINK_FLAGS_BEFORE=" \
++ "LINK_FLAGS_AFTER= $(ALL_LIB) %%PTHREAD_LIBS%% -static -lm -o tochnog"
++
+ # multi processor linux; gnu gcc compiler
+ linux:
+ make tochnog \
+@@ -375,7 +381,7 @@
+ $(COMPILER_CPP) $(COMPILER_FLAGS) $(BCPP) $(VCPP)hyperela.$(SRC_CPP)
+
+ $(HYPO_OBJ): $(HYPO_SRC)
+- $(COMPILER_C) $(COMPILER_FLAGS) $(HYPO_SRC)
++ $(COMPILER_C) $(COMPILER_FLAGS) $(HYPO_SRC) $(F2C_INCLUDE)
+
+ hypoplas.$(OBJ): hypoplas.$(SRC_CPP) tochnog.h
+ $(COMPILER_CPP) $(COMPILER_FLAGS) $(BCPP) $(VCPP)hypoplas.$(SRC_CPP)
diff --git a/cad/tochnog/files/patch-tnhypo.h b/cad/tochnog/files/patch-tnhypo.h
new file mode 100644
index 000000000000..717290d4bfac
--- /dev/null
+++ b/cad/tochnog/files/patch-tnhypo.h
@@ -0,0 +1,5 @@
+--- tnhypo.h.orig Fri May 9 11:00:50 2003
++++ tnhypo.h Fri May 9 11:01:12 2003
+@@ -1 +1 @@
+-#define HYPO_USE 0
++#define HYPO_USE 1
diff --git a/cad/tochnog/files/patch-tnsuplu.h b/cad/tochnog/files/patch-tnsuplu.h
new file mode 100644
index 000000000000..b8f6ceec4f44
--- /dev/null
+++ b/cad/tochnog/files/patch-tnsuplu.h
@@ -0,0 +1,15 @@
+--- tnsuplu.h.orig Wed Jun 18 12:39:20 2003
++++ tnsuplu.h Wed Jun 18 12:45:46 2003
+@@ -2,6 +2,12 @@
+ #define SUPERLU_USE 0
+ #define SUPERLU_MT_USE 0
+ #define SUPERLU_DIST_USE 0
++#if SUPERLU_USE /* enums were changed for SuperLU v2 */
++#define _D SLU_D
++#define DN SLU_DN
++#define GE SLU_GE
++#define NC SLU_NC
++#endif
+ /* don't change the next lines */
+ #if SUPERLU_USE+SUPERLU_MT_USE+SUPERLU_DIST_USE > 1
+ ERROR___ just pick one
diff --git a/cad/tochnog/files/patch-tochnog.h b/cad/tochnog/files/patch-tochnog.h
new file mode 100644
index 000000000000..530d4d49c9df
--- /dev/null
+++ b/cad/tochnog/files/patch-tochnog.h
@@ -0,0 +1,31 @@
+--- tochnog.h.orig Sat Jul 12 13:05:15 2003
++++ tochnog.h Sat Jul 12 15:29:05 2003
+@@ -17,12 +17,25 @@
+ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
+-#include <iostream.h>
++#include <iostream>
++// C++ iostream compatibility stuff
++using std::ios;
++using std::cout;
++using std::cin;
++using std::flush;
++//end iostream compatibility stuff
++
+ #include <assert.h>
+ #include <ctype.h>
+ #include <float.h>
+-#include <fstream.h>
+-#include <iomanip.h>
++#include <fstream>
++// C++ fstream compatibility stuff
++using std::ifstream;
++using std::ofstream;
++using std::fstream;
++//end fstream compatibility stuff
++
++#include <iomanip>
+ #include <math.h>
+ #include <limits.h>
+ #include <stdio.h>
diff --git a/cad/tochnog/pkg-descr b/cad/tochnog/pkg-descr
new file mode 100644
index 000000000000..e3fc41dcadca
--- /dev/null
+++ b/cad/tochnog/pkg-descr
@@ -0,0 +1,15 @@
+TOCHNOG is a free finite element program with many features. TOCHNOG
+accepts free format input. Boundary conditions can be imposed at
+geometrical entities, as well as nodes and elements.
+
+Among the FE models supported are: differential equations (materials),
+convection-diffusion equations, Stokes and Navier-Stokes (fluids),
+elasticity (isotropy and transverse isotropy), plasticity (Von-Mises,
+Mohr-Coulomb, etc.; plastic surfaces can be arbitrarily
+combined). Residues in equations and error estimates for all data can
+be printed or plotted using gnuplot/plotmtv, CalculiX or gmsh.
+
+TOCHNOG supports a choice of description frames including Lagrangian,
+Eulerian and arbitrary Eulerian-Lagrangian (AEL).
+
+WWW: http://tochnog.sourceforge.net/
diff --git a/cad/tochnog/pkg-plist b/cad/tochnog/pkg-plist
new file mode 100644
index 000000000000..0dc34bc554be
--- /dev/null
+++ b/cad/tochnog/pkg-plist
@@ -0,0 +1,210 @@
+bin/aba2tn
+bin/tochnog
+bin/gmsh2tn.awk
+bin/mkansys.awk
+bin/mkgmsh.awk
+%%PORTDOCS%%%%DOCSDIR%%/test/absorp1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/axisym1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/axisym2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/axisym3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/axisym4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/axisym5.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/beam2d.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/beam2d_1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/beam2d_2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/beam3d.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/bimet1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/blatz1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/calcul1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/calcul2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/condif1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/condif10.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/condif2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/condif3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/condif5.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/condif6.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/condif7.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/condif8.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/condif9.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/conspr1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/conspr2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/conspr3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/conspr4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/contac1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/contac2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/contac3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/contac4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/convec1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/convec2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/crack1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/crack2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/crack3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/ctvmis1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/ctvmis2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/damage1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/dataput1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/delete1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/dens1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/depend1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/diprisc1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/disk1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/disk2a.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/distri1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/druckpr1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/eigen1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/eigen3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/elasti1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/elasti2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/elasti3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/elasti4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp10.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp11.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp12.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp13.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp14.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp15.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp16.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp17.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp18.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp19.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp20.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp22.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp23.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp24.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp5.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp6.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp7.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp8.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/examp9.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/expans1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/expans2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/force1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/force2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/force3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/force4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/force5.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/genera1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/genera2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/ground1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/ground2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/ground3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/ho_heat1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/ho_heat2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/ho_mech1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/ho_mech2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/ho_mech3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/ho_mech4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/ho_othr1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/ho_othr2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/ho_othr3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/ho_othr4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/hypo1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/hypo2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/hypo3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/hypo4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/incnav1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/incnav2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/incnav3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/incnav4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/incnav5.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/interac1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/inver1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/inver2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/inver3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/makefile
+%%PORTDOCS%%%%DOCSDIR%%/test/matrix1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/matrix2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/matrix3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/matrix4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/matrix5.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/matrix6.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/matrix7.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/matrix8.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/matrix9.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/membran1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/membran2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/merge1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/mohrcou1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/mohrcou2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/mohrcou3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/mohrcou4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/nodfor1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/petsc1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/post1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/post2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/post3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/post4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/post5.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/post6.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/pridbs.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/radiate1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/radiate2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/refine1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/refine2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/refine3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/refine4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/refine5.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/remesh1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/repeat1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/repeat2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/silo1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/skip1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/slide1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/slope.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/soften1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/spring1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/spring2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/spring3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/spring4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/spring5.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/strconv1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/taylor3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/temp1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/temp2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/temp3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/temp4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/temp5.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/tendon1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/tendon10.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/tendon2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/tendon3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/tendon4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/tendon6.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/tendon7.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/tendon8.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/tension1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/tet10.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/total1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/total2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/total3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/transv1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/tria6.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/trubea1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/trubea2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/trubea3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/trubea4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/truss1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/truss2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/truss3.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/truss4.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/truss5.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/truss6.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/truss7.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/trussbea.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/tube1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/update1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/visc_pl1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/visc_pl2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/viscel1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/viscos1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/volume1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/volume2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/vonmis1.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/vonmis2.dat
+%%PORTDOCS%%%%DOCSDIR%%/test/wave1.dat
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/test
+%%PORTDOCS%%@dirrm %%DOCSDIR%%