aboutsummaryrefslogtreecommitdiff
path: root/cad/tochnog
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-03-29 23:43:21 +0000
committerRene Ladan <rene@FreeBSD.org>2014-03-29 23:43:21 +0000
commit123a7489e10fea338a740d5975df199351b6d4a5 (patch)
tree694cb15f8d5b77e17c7d956bf0cb28c61338c046 /cad/tochnog
parent577085b061eecef361800d921d120bcdc995f471 (diff)
downloadports-123a7489e10fea338a740d5975df199351b6d4a5.tar.gz
ports-123a7489e10fea338a740d5975df199351b6d4a5.zip
Notes
Diffstat (limited to 'cad/tochnog')
-rw-r--r--cad/tochnog/Makefile55
-rw-r--r--cad/tochnog/distinfo10
-rw-r--r--cad/tochnog/files/patch-makefile89
-rw-r--r--cad/tochnog/files/patch-so_petsc.c20
-rw-r--r--cad/tochnog/files/patch-so_suplu.c54
-rw-r--r--cad/tochnog/files/patch-tn.cc23
-rw-r--r--cad/tochnog/files/patch-tnhypo.h5
-rw-r--r--cad/tochnog/files/patch-tochnog.h28
-rw-r--r--cad/tochnog/pkg-plist22
9 files changed, 117 insertions, 189 deletions
diff --git a/cad/tochnog/Makefile b/cad/tochnog/Makefile
index a880d1c9604b..40a906a04ba3 100644
--- a/cad/tochnog/Makefile
+++ b/cad/tochnog/Makefile
@@ -2,26 +2,28 @@
# $FreeBSD$
PORTNAME= tochnog
-PORTVERSION= 20010211
-PORTREVISION= 9
+PORTVERSION= 20140100
CATEGORIES= cad
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/feb11_2001
-DISTNAME= ${PORTNAME}_feb11_2001
+MASTER_SITES= SF/${PORTNAME}/Tochnog%20Latest%20January%202014
+DISTFILES= Sources${EXTRACT_SUFX} gid${EXTRACT_SUFX} \
+ tools${EXTRACT_SUFX} test${EXTRACT_SUFX}
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Free explicit/implicit Finite Element Program
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2014-03-07
+LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/lib/libf2c.a:${PORTSDIR}/lang/f2c
OPTIONS_DEFINE= ATLAS EXAMPLES THREADS
ATLAS_DESC= Use ATLAS instead of BLAS/LAPACK
-WRKSRC= ${WRKDIR}/${PORTNAME}/src
+WRKSRC= ${WRKDIR}/Sources/Tochnog-Latest-jan-2014
MAKEFILE= makefile
-USES= fortran
+MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS} PTHREAD_CFLAGS=${PTHREAD_CFLAGS}
+USES= fortran zip dos2unix
+DOS2UNIX_FILES= time.cc time.h tnlapack.h tnsuplu.h
# You can set GIDDIR to share/gid to install the scripts to be used
# with the cad/linux-gid port, otherwise they can be linked to the data
@@ -41,8 +43,9 @@ BLAS_LIBS= -lptf77blas
BLAS_LIBS= -lf77blas
.endif
.else
-LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
-BLAS_LIBS= -lblas
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas \
+ liblapack.so:${PORTSDIR}/math/lapack
+BLAS_LIBS= -llapack -lblas
.endif
.if ${PORT_OPTIONS:MTHREADS}
@@ -55,37 +58,45 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libsuperlu.a:${PORTSDIR}/math/superlu
SUPERLU= superlu
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g ; \
+post-extract:
+.for sup in gid tools test
+ ${MV} ${WRKDIR}/${sup} ${WRKDIR}/Sources/
+.endfor
+
+pre-configure:
+.for hd in pthread.h
+ ${MV} ${WRKSRC}/${hd} ${WRKSRC}/${hd}.orig
+.endfor
+ ${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g ; \
s,%%SUPERLU%%,${SUPERLU},g ; \
s,%%BLAS_LIBS%%,-L${LOCALBASE}/lib ${BLAS_LIBS},g' \
${WRKSRC}/makefile
.if ${PORT_OPTIONS:MTHREADS}
- @${REINPLACE_CMD} -e 's,SUPERLU_MT_USE 0,SUPERLU_MT_USE 1,' \
+ ${REINPLACE_CMD} -e 's,SUPERLU_MT_USE 0,SUPERLU_MT_USE 1,' \
${WRKSRC}/tnsuplu.h
.else # Serial
- @${REINPLACE_CMD} -e 's,SUPERLU_USE 0,SUPERLU_USE 1,' \
+ ${REINPLACE_CMD} -e 's,SUPERLU_USE 0,SUPERLU_USE 1,' \
${WRKSRC}/tnsuplu.h
.endif
post-build:
- (cd ${WRKDIR}/tochnog/tools && ${CXX} ${CXXFLAGS} -o aba2tn aba2tn.cc)
+ (cd ${WRKDIR}/Sources/tools && ${CXX} ${CXXFLAGS} -o aba2tn aba2tn.cc)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tochnog ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKDIR}/tochnog/tools/aba2tn ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKDIR}/tochnog/tools/*.awk ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKDIR}/Sources/tools/aba2tn ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/Sources/tools/*.awk ${STAGEDIR}${PREFIX}/bin
${MKDIR} ${STAGEDIR}${GID_PTYPES}/tochnog.gid
- ${INSTALL_DATA} ${WRKDIR}/tochnog/gid/tochnog.gid/tochnog.cnd \
+ ${INSTALL_DATA} ${WRKDIR}/Sources/gid/tochnog.gid/tochnog.cnd \
${STAGEDIR}${GID_PTYPES}/tochnog.gid
- ${INSTALL_DATA} ${WRKDIR}/tochnog/gid/tochnog.gid/tochnog.mat \
+ ${INSTALL_DATA} ${WRKDIR}/Sources/gid/tochnog.gid/tochnog.mat \
${STAGEDIR}${GID_PTYPES}/tochnog.gid
- ${INSTALL_SCRIPT} ${WRKDIR}/tochnog/gid/tochnog.gid/tochnog.ba* \
+ ${INSTALL_SCRIPT} ${WRKDIR}/Sources/gid/tochnog.gid/tochnog.ba* \
${STAGEDIR}${GID_PTYPES}/tochnog.gid
.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${RM} -f ${WRKDIR}/tochnog/test/*.orig
- ${INSTALL_DATA} ${WRKDIR}/tochnog/test/* ${STAGEDIR}${EXAMPLESDIR}
+ ${RM} -f ${WRKDIR}/Sources/test/*.orig
+ ${INSTALL_DATA} ${WRKDIR}/Sources/test/* ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/cad/tochnog/distinfo b/cad/tochnog/distinfo
index 83511a66b92f..dcad0ef98b84 100644
--- a/cad/tochnog/distinfo
+++ b/cad/tochnog/distinfo
@@ -1,2 +1,8 @@
-SHA256 (tochnog_feb11_2001.tar.gz) = 0eb52942b9ba4ceae74e901defa74be7cba3594c7853f3ff9ce68adad725d0fa
-SIZE (tochnog_feb11_2001.tar.gz) = 394486
+SHA256 (tochnog-20140100/Sources.zip) = 8f1cc04cd07526bbd942e4b246dc0e2f2af5d7920fc6e5d4b48a0bec4f175288
+SIZE (tochnog-20140100/Sources.zip) = 461522
+SHA256 (tochnog-20140100/gid.zip) = fd2bc5fe386b62a41bb95c10e7c78be57c6d3ae8c8c118d09b02f6b05a384d73
+SIZE (tochnog-20140100/gid.zip) = 6040
+SHA256 (tochnog-20140100/tools.zip) = 84d32721eae1b9602641901c51dee74343d92357758bfdf170f2440c8273dddf
+SIZE (tochnog-20140100/tools.zip) = 3943
+SHA256 (tochnog-20140100/test.zip) = 94bd12cfb742be29e22f57a31f123a387232f25fa6a2f5d1859ad295745e5a87
+SIZE (tochnog-20140100/test.zip) = 205793
diff --git a/cad/tochnog/files/patch-makefile b/cad/tochnog/files/patch-makefile
index 08ab161e2e98..f2633df04ae2 100644
--- a/cad/tochnog/files/patch-makefile
+++ b/cad/tochnog/files/patch-makefile
@@ -1,26 +1,16 @@
---- makefile.orig Sun Aug 19 19:31:52 2001
-+++ makefile Sun Aug 6 18:58:12 2006
-@@ -1,6 +1,7 @@
- # *********** fortran 2 c *******************
- # Set F2C (for unix -lf2c and for MS windows to f2c.lib)
--F2C=
+--- makefile.orig 2014-01-05 15:35:37.000000000 +0100
++++ makefile 2014-03-09 22:07:32.000000000 +0100
+@@ -5,7 +5,8 @@
+ #*********** fortran 2 c *******************
+ # Set F2C (for unix -lf2c and for MS windows if using Visual C++ to f2c.lib)
+
+-F2C= -lf2c
+F2C= -lf2c -L%%LOCALBASE%%/lib
+F2C_INCLUDE= -I%%LOCALBASE%%/include
-
# *********** hypoplasticity ****************
# For hypoplasticity:
-@@ -8,8 +9,8 @@
- # set HYPO_USE to 1 in tnhypo.h
- # set HYPO_SRC to hypo.c below
- # set HYPO_OBJ to hypo.o below
--HYPO_SRC=hypo_dum.c
--HYPO_OBJ=hypo_dum.o
-+HYPO_SRC=hypo.c
-+HYPO_OBJ=hypo.o
-
- # *********** profiler ***********************
- # for the gnu profiler, use as follows:
-@@ -26,11 +27,11 @@
+ # install f2c on your computer (also see F2C above)
+@@ -30,11 +31,11 @@
SYS_FILE=sysother
BCPP=-P
VCPP=
@@ -36,59 +26,66 @@
LINK_FLAGS_AFTER=
# *********** SUPERLU library *******************
-@@ -39,9 +40,9 @@
- # Set SUPERLU_MT_USE to 1 in tnsuplu.h for the multi threaded version
- # Set SUPERLU_DIST_USE to 1 in tnsuplu.h for the distributed MPI version
- # 2. Activate and adjust the next three lines
--# SUPERLU=/home/programs/src/SuperLU
--# SUPERLU_LIB=$(SUPERLU)/superlu.a $(SUPERLU)/blas.a
--# SUPERLU_INCLUDE=-I$(SUPERLU)/SRC
+@@ -49,6 +50,9 @@
+ # SUPERLU_INCLUDE=-I/Users/fdolorenzo/Downloads/petsc-3.4.2/arch-darwin-c-debug/include
+ # 3. For SuperLU_MT be sure to compile a multi threaded version
+ # of Tochnog (sparc_parallel, alpha_parallel, linux, etc.
+SUPERLU=%%LOCALBASE%%
+SUPERLU_LIB=$(SUPERLU)/lib/lib%%SUPERLU%%.a %%BLAS_LIBS%%
+SUPERLU_INCLUDE=-I$(SUPERLU)/include/%%SUPERLU%%
- # 3. For SuperLU_MT be sure to compile a multi threaded version
- # of Tochnog (sparc_parallel, alpha_parallel, linux, etc.)
-@@ -65,7 +66,7 @@
- ALL_LIB= $(PETSC_LIB) $(SUPERLU_LIB) $(F2C)
+ # *********** PetSc library *******************
+ # Do NOT link together with the SUPERLU library
+@@ -80,7 +84,7 @@
+ ALL_LIB= $(LAPACK_LIB) $(BLAS_LIB) $(F2C) -lm $(PETSC_LIB) $(SUPERLU_LIB)
# *********** default platform *******************
--default: linux_old
+-default: darwin-intel
+default: freebsd_old
# single and multi-processor windows; borland c++ compiler
# set SYS_FILE above to syswin32 for multi-processor
-@@ -101,17 +102,22 @@
- "LINK_FLAGS_AFTER= /link $(F2C) $(PROFILE) /OUT:tochnog.exe"
+@@ -130,17 +134,22 @@
+ "LINK_FLAGS_AFTER=-g -v -dynamic -undefined dynamic_lookup $(ALL_LIB) $(PROFILE) -dynamic -lpthread -o tochnog"
# single processor linux; gnu gcc compiler
-linux_old:
-+freebsd_old:
- make tochnog \
+- make tochnog \
++freebsd_old:
++ ${MAKE} tochnog \
"SYS_FILE=sysother" \
"OBJ=o" \
- "BCPP=" \
- "VCPP=" \
- "COMPILER_C=gcc" \
-- "COMPILER_CPP=g++" \
+- "COMPILER_CPP=g++-4.2" \
- "COMPILER_FLAGS= -ansi -c -O2 -Wall $(PROFILE) $(ALL_INCLUDE)" \
+ "COMPILER_FLAGS= -c ${CFLAGS} ${CPPFLAGS} $(ALL_INCLUDE)" \
"LINK_FLAGS_BEFORE=" \
- "LINK_FLAGS_AFTER= $(PROFILE) $(ALL_LIB) -static -lm -o tochnog"
-+ "LINK_FLAGS_AFTER= $(PROFILE) $(ALL_LIB) ${LDFLAGS} -lm -o tochnog"
++ "LINK_FLAGS_AFTER= $(PROFILE) $(ALL_LIB) ${LDFLAGS} -pthread -lm -o tochnog"
+
+# Multithreaded FreeBSD
+freebsd_parallel:
-+ make tochnog \
++ ${MAKE} tochnog \
+ "SYS_FILE=sysposix" \
+ "OBJ=o" \
-+ "COMPILER_FLAGS= -c ${CFLAGS} ${CPPFLAGS} -D_REENTRANT $(ALL_INCLUDE)" \
++ "COMPILER_FLAGS= -c ${CFLAGS} ${CPPFLAGS} -D_REENTRANT $(PTHREAD_CFLAGS) $(ALL_INCLUDE)" \
+ "LINK_FLAGS_BEFORE=" \
-+ "LINK_FLAGS_AFTER= $(PROFILE) $(ALL_LIB) ${LDFLAGS} -pthread -lm -o tochnog"
++ "LINK_FLAGS_AFTER= $(PROFILE) $(ALL_LIB) ${LDFLAGS} $(PTHREAD_LIBS) -lm -o tochnog"
# multi processor linux; gnu gcc compiler
linux:
-@@ -375,7 +381,7 @@
+@@ -289,7 +298,7 @@
+ renumber.$(OBJ) repeat.$(OBJ) restart.$(OBJ) \
+ slide.$(OBJ) \
+ so.$(OBJ) so_bicg.$(OBJ) \
+- split.$(OBJ) \
++ so_suplu.$(OBJ) split.$(OBJ) \
+ spring.$(OBJ) stress.$(OBJ) \
+ $(SYS_FILE).$(OBJ) tendon.$(OBJ) time.$(OBJ) tn.$(OBJ) \
+ top.$(OBJ) truss.$(OBJ) \
+@@ -401,7 +410,7 @@
$(COMPILER_CPP) $(COMPILER_FLAGS) $(BCPP) $(VCPP)hyperela.$(SRC_CPP)
$(HYPO_OBJ): $(HYPO_SRC)
@@ -97,3 +94,13 @@
hypoplas.$(OBJ): hypoplas.$(SRC_CPP) tochnog.h
$(COMPILER_CPP) $(COMPILER_FLAGS) $(BCPP) $(VCPP)hypoplas.$(SRC_CPP)
+@@ -565,6 +574,9 @@
+ #so_petsc.$(OBJ): so_petsc.$(SRC_C) tochnog.h
+ # $(COMPILER_C) $(COMPILER_FLAGS) so_petsc.$(SRC_C)
+
++so_suplu.$(OBJ): so_suplu.$(SRC_C) tochnog.h
++ $(COMPILER_C) $(COMPILER_FLAGS) so_suplu.$(SRC_C)
++
+ split.$(OBJ): split.$(SRC_CPP) tochnog.h
+ $(COMPILER_CPP) $(COMPILER_FLAGS) $(BCPP) $(VCPP)split.$(SRC_CPP)
+
diff --git a/cad/tochnog/files/patch-so_petsc.c b/cad/tochnog/files/patch-so_petsc.c
deleted file mode 100644
index 68c33a12ddb3..000000000000
--- a/cad/tochnog/files/patch-so_petsc.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- so_petsc.c.orig Wed Jun 21 00:31:58 2006
-+++ so_petsc.c Wed Jun 21 00:33:30 2006
-@@ -21,14 +21,14 @@
-
- #if PETSC_USE
-
--/* before version 2.2.29 of petsc use these two lines */
-+/* before version 2.2.29 of petsc use these two lines
- #include "sles.h"
- #include "mg.h"
-+*/
-
--/* version 2.2.29 and further of petsc use these two lines
-+/* version 2.2.29 and further of petsc use these two lines */
- #include "petscsles.h"
- #include "petscmg.h"
--*/
-
- extern double *solve_solution;
-
diff --git a/cad/tochnog/files/patch-so_suplu.c b/cad/tochnog/files/patch-so_suplu.c
deleted file mode 100644
index 9bd2185c8dd4..000000000000
--- a/cad/tochnog/files/patch-so_suplu.c
+++ /dev/null
@@ -1,54 +0,0 @@
---- so_suplu.c.orig Thu Nov 9 15:59:39 2000
-+++ so_suplu.c Sat Feb 4 20:21:59 2006
-@@ -22,14 +22,16 @@
- #if ( SUPERLU_USE || SUPERLU_MT_USE || SUPERLU_DIST_USE )
-
- #if SUPERLU_USE
--#include "dsp_defs.h"
-+#include "slu_ddefs.h"
- #elif SUPERLU_MT_USE
-+#include "slu_mt_util.h"
- #include "pdsp_defs.h"
- #elif SUPERLU_DIST_USE
- #include <math.h>
-+#include "superlu_util.h"
- #include "superlu_ddefs.h"
- #endif
--#include "util.h"
-+
-
- long int solve_superlu( double *superlu_A, int *superlu_asub,
- int *superlu_xa, int superlu_nnz, double solve_b[], long int solve_nlocal,
-@@ -53,6 +55,10 @@
- int *perm_r, *perm_c;
- int perm_spec;
- int nrhs;
-+#if SUPERLU_USE
-+ SuperLUStat_t stat;
-+ superlu_options_t options;
-+#endif
- #endif
-
- /* Create Matrix A in the format expected by SuperLU */
-@@ -94,8 +100,8 @@
- nrhs = 1;
- #if ( SUPERLU_USE || SUPERLU_MT_USE )
- dCreate_Dense_Matrix( &B, n, nrhs, solve_b, n, DN, _D, GE );
-- if ( !(perm_r = intMalloc(1000+n)) ) ABORT("Not enough memory for SuperLU.");
-- if ( !(perm_c = intMalloc(1000+n)) ) ABORT("Not enough memory for SuperLU.");
-+ if ( !(perm_r = intMalloc(1000+n)) ) USER_ABORT("Not enough memory for SuperLU.");
-+ if ( !(perm_c = intMalloc(1000+n)) ) USER_ABORT("Not enough memory for SuperLU.");
- /* Get column permutation vector perm_c[] */
- perm_spec = 1;
- get_perm_c( perm_spec, &A, perm_c );
-@@ -103,7 +109,9 @@
-
- /* Solve */
- #if SUPERLU_USE
-- dgssv( &A, perm_c, perm_r, &L, &U, &B, &info );
-+ /* Initialize the statistics variables. */
-+ StatInit(&stat);
-+ dgssv(&options, &A, perm_c, perm_r, &L, &U, &B, &stat, &info );
- #elif SUPERLU_MT_USE
- pdgssv( nthread, &A, perm_c, perm_r, &L, &U, &B, &info );
- #elif SUPERLU_DIST_USE
diff --git a/cad/tochnog/files/patch-tn.cc b/cad/tochnog/files/patch-tn.cc
index fdfee0d4afab..197f3bb9acfa 100644
--- a/cad/tochnog/files/patch-tn.cc
+++ b/cad/tochnog/files/patch-tn.cc
@@ -1,6 +1,6 @@
---- tn.cc 2002/06/01 13:47:34 1.1
-+++ tn.cc 2002/07/25 14:32:17 1.2
-@@ -33,40 +33,145 @@
+--- tn.cc.orig 2013-08-16 01:47:35.000000000 +0200
++++ tn.cc 2014-03-09 17:57:23.000000000 +0100
+@@ -33,6 +33,40 @@
int PetscFinalize(void);
#endif
@@ -37,14 +37,18 @@
+ return 1;
+}
+
++
int main( int argc, char* argv[] )
{
+@@ -40,37 +74,107 @@
+ Time CPU;
+ CPU.firsttime=CPU.taketime();
+
- long int i=0, l=0, any_point=0;
-+
+ extern char *optarg;
+ extern int optind, opterr, optopt;
-+
++
+ int opt_index, option, error_count = 0;
+ bool print_usage = false, print_version = false;
+
@@ -64,13 +68,13 @@
+ case 'h': // print a short help message and exit
+ print_usage = true;
+ break;
-+ case 'v': // print the version string and exit
++ case 'v': // print the version string and exit
+ print_version = true;
+ break;
-+ case 'G': // use the *flavia* for interaction with gid
++ case 'G': // use the *flavia* for interaction with gid
+ enable_gid = true;
+ break;
-+ case 't': // use the *flavia* for interaction with gid
++ case 't': // use the *flavia* for interaction with gid
+ enable_test = true;
+ break;
+ // Options with 1 argument
@@ -83,7 +87,7 @@
+ if (error_count > 0)
+ {
+ cerr << "Try tochnog --help for more information";
-+ exit(TN_EXIT_STATUS);
++ exit(TN_EXIT_STATUS);
+ }
+
+ if (print_usage)
@@ -166,7 +170,6 @@
- ofstream outdvd( "tn.dvd" );
- outdvd.close();
+#endif
-+
// read input file
input();
diff --git a/cad/tochnog/files/patch-tnhypo.h b/cad/tochnog/files/patch-tnhypo.h
deleted file mode 100644
index 717290d4bfac..000000000000
--- a/cad/tochnog/files/patch-tnhypo.h
+++ /dev/null
@@ -1,5 +0,0 @@
---- tnhypo.h.orig Fri May 9 11:00:50 2003
-+++ tnhypo.h Fri May 9 11:01:12 2003
-@@ -1 +1 @@
--#define HYPO_USE 0
-+#define HYPO_USE 1
diff --git a/cad/tochnog/files/patch-tochnog.h b/cad/tochnog/files/patch-tochnog.h
index 634267c69636..aafa9a787cfe 100644
--- a/cad/tochnog/files/patch-tochnog.h
+++ b/cad/tochnog/files/patch-tochnog.h
@@ -1,30 +1,10 @@
---- tochnog.h 2002/06/01 13:50:03 1.1.1.1
-+++ tochnog.h 2002/08/01 08:44:35 1.3
-@@ -17,12 +17,16 @@
- Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
- */
-
--#include <iostream.h>
-+// C++ headers
-+#include <iostream>
-+#include <fstream>
-+#include <iomanip>
-+using namespace std;
-+
-+// C headers
- #include <assert.h>
- #include <ctype.h>
- #include <float.h>
--#include <fstream.h>
--#include <iomanip.h>
- #include <math.h>
- #include <limits.h>
- #include <stdio.h>
-@@ -49,6 +53,8 @@
+--- tochnog.h.orig 2013-10-12 05:33:16.000000000 +0200
++++ tochnog.h 2014-03-09 18:16:04.000000000 +0100
+@@ -58,6 +58,8 @@
MVERSION // maximum number of versions, this must be the last item
};
-+#define TOCHNOG_VERSION "July_25_2002"
++#define TOCHNOG_VERSION "Latest-jan-2014"
+
// constants
#define MCHAR 100 // maximum length of names
diff --git a/cad/tochnog/pkg-plist b/cad/tochnog/pkg-plist
index bdeb705bb42f..dc2e3709925b 100644
--- a/cad/tochnog/pkg-plist
+++ b/cad/tochnog/pkg-plist
@@ -1,18 +1,16 @@
bin/aba2tn
bin/tochnog
bin/gmsh2tn.awk
-bin/mkansys.awk
-bin/mkgmsh.awk
%%GIDDIR%%/problemtypes/tochnog.gid/tochnog.bas
%%GIDDIR%%/problemtypes/tochnog.gid/tochnog.bat
%%GIDDIR%%/problemtypes/tochnog.gid/tochnog.cnd
%%GIDDIR%%/problemtypes/tochnog.gid/tochnog.mat
-@dirrm %%GIDDIR%%/problemtypes/tochnog.gid
-@dirrm %%GIDDIR%%/problemtypes
-@dirrm %%GIDDIR%%
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/absorp1.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/axisym1.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/axisym2.dat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/axisym2.dbs
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/axisym2.flavia.msh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/axisym2.flavia.res
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/axisym3.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/axisym4.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/axisym5.dat
@@ -43,9 +41,6 @@ bin/mkgmsh.awk
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contac4.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/convec1.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/convec2.dat
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/crack1.dat
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/crack2.dat
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/crack3.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ctvmis1.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ctvmis2.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/damage1.dat
@@ -55,7 +50,6 @@ bin/mkgmsh.awk
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/depend1.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/diprisc1.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/disk1.dat
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/disk2a.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/distri1.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/druckpr1.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eigen1.dat
@@ -68,7 +62,6 @@ bin/mkgmsh.awk
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examp10.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examp11.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examp12.dat
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examp13.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examp14.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examp15.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examp16.dat
@@ -84,6 +77,9 @@ bin/mkgmsh.awk
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examp4.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examp5.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examp6.dat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examp6.dbs
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examp6.flavia.msh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examp6.flavia.res
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examp7.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examp8.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examp9.dat
@@ -148,6 +144,7 @@ bin/mkgmsh.awk
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/post5.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/post6.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pridbs.dat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pruebavel.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/radiate1.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/radiate2.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/refine1.dat
@@ -161,7 +158,6 @@ bin/mkgmsh.awk
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/silo1.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/skip1.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/slide1.dat
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/slope.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/soften1.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/spring1.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/spring2.dat
@@ -185,6 +181,7 @@ bin/mkgmsh.awk
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tendon8.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tension1.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tet10.dat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tn.dvd
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/total1.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/total2.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/total3.dat
@@ -214,3 +211,6 @@ bin/mkgmsh.awk
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vonmis2.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wave1.dat
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%GIDDIR%%/problemtypes/tochnog.gid
+@dirrm %%GIDDIR%%/problemtypes
+@dirrm %%GIDDIR%%