aboutsummaryrefslogtreecommitdiff
path: root/cad/tochnog
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-02-07 14:57:49 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-02-07 14:57:49 +0000
commit5316d6995c9eab3e2b92e7994330d27312295f13 (patch)
treee9433273f8212799f1369d579fb61a5ee351bcda /cad/tochnog
parent9e9d988f842033e039bc66c3548d6f02510ffd5c (diff)
downloadports-5316d6995c9eab3e2b92e7994330d27312295f13.tar.gz
ports-5316d6995c9eab3e2b92e7994330d27312295f13.zip
Notes
Diffstat (limited to 'cad/tochnog')
-rw-r--r--cad/tochnog/Makefile1
-rw-r--r--cad/tochnog/files/patch-makefile4
2 files changed, 2 insertions, 3 deletions
diff --git a/cad/tochnog/Makefile b/cad/tochnog/Makefile
index 7929dd0be1d3..c7e0aff14963 100644
--- a/cad/tochnog/Makefile
+++ b/cad/tochnog/Makefile
@@ -63,7 +63,6 @@ GCCLIBDIR= -L`${CAT} ${WRKSRC}/LIBDIR` -L`${CAT} ${WRKSRC}/LIBDIR`/../../..
pre-build:
@${DIRNAME} `${FC} -print-libgcc-file-name` > ${WRKSRC}/LIBDIR
@${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g ; \
- s,%%PTHREAD_CFLAGS%%,${PTHREAD_CFLAGS},g ; s,%%PTHREAD_LIBS%%,${PTHREAD_LIBS},g ; \
s,%%SUPERLU%%,${SUPERLU},g ; \
s,%%FORTRANLIBS%%,${FORTRANLIBS},g ; \
s,%%GCCLIBDIR%%,${GCCLIBDIR},g ; \
diff --git a/cad/tochnog/files/patch-makefile b/cad/tochnog/files/patch-makefile
index ae35e6b46f44..09657bba744c 100644
--- a/cad/tochnog/files/patch-makefile
+++ b/cad/tochnog/files/patch-makefile
@@ -82,9 +82,9 @@
+ make tochnog \
+ "SYS_FILE=sysposix" \
+ "OBJ=o" \
-+ "COMPILER_FLAGS= -c ${CFLAGS} %%PTHREAD_CFLAGS%% -D_REENTRANT $(ALL_INCLUDE)" \
++ "COMPILER_FLAGS= -c ${CFLAGS} -D_REENTRANT $(ALL_INCLUDE)" \
+ "LINK_FLAGS_BEFORE=" \
-+ "LINK_FLAGS_AFTER= $(ALL_LIB) %%PTHREAD_LIBS%% -lm -o tochnog"
++ "LINK_FLAGS_AFTER= $(ALL_LIB) -pthread -lm -o tochnog"
# multi processor linux; gnu gcc compiler
linux: