aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-08-25 04:00:13 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-08-25 04:00:13 +0000
commit14b8b6f1e855897cb78c45367bf7ecca668c9ca3 (patch)
tree48f6787c3905211c04001c5f110afe4877947580 /cad
parent108257931ff00abae2979ddb6aa7e4ee28823ced (diff)
downloadports-14b8b6f1e855897cb78c45367bf7ecca668c9ca3.tar.gz
ports-14b8b6f1e855897cb78c45367bf7ecca668c9ca3.zip
cad/leocad: Remove the embedded build date and fix build with Clang 6
common/lc_application.cpp:209:23: error: no matching literal operator for call to 'operator""__DATE__' with arguments of types 'const char *' and 'unsigned int', and no matching literal operator template printf("Compiled "__DATE__"\n"); ^ http://beefy11.nyi.freebsd.org/data/head-i386-default/p477696_s338122/logs/errors/leocad-0.80.3_4.log
Notes
Notes: svn path=/head/; revision=477998
Diffstat (limited to 'cad')
-rw-r--r--cad/leocad/Makefile2
-rw-r--r--cad/leocad/files/patch-common_lc__application.cpp16
2 files changed, 17 insertions, 1 deletions
diff --git a/cad/leocad/Makefile b/cad/leocad/Makefile
index 2cc7a695ba0b..028411166025 100644
--- a/cad/leocad/Makefile
+++ b/cad/leocad/Makefile
@@ -3,7 +3,7 @@
PORTNAME= leocad
PORTVERSION= 0.80.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= cad
MASTER_SITES= SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/
DISTFILES= LeoCAD-Source-${PORTVERSION}.tgz
diff --git a/cad/leocad/files/patch-common_lc__application.cpp b/cad/leocad/files/patch-common_lc__application.cpp
new file mode 100644
index 000000000000..ee54e3c0e076
--- /dev/null
+++ b/cad/leocad/files/patch-common_lc__application.cpp
@@ -0,0 +1,16 @@
+Remove the embedded build date and fix build with Clang 6
+
+common/lc_application.cpp:209:23: error: no matching literal operator for call to 'operator""__DATE__' with arguments of types 'const char *' and 'unsigned int', and no matching literal operator template
+ printf("Compiled "__DATE__"\n");
+ ^
+
+--- common/lc_application.cpp.orig 2018-08-25 03:56:08 UTC
++++ common/lc_application.cpp
+@@ -206,7 +206,6 @@ bool lcApplication::Initialize(int argc, char* argv[],
+ else if ((strcmp(Param, "-v") == 0) || (strcmp(Param, "--version") == 0))
+ {
+ printf("LeoCAD Version " LC_VERSION_TEXT "\n");
+- printf("Compiled "__DATE__"\n");
+
+ return false;
+ }