aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-06-26 22:09:30 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-06-26 22:09:30 +0000
commit2e4cba834775867c975b3ce1c57f09dc2a31d88d (patch)
tree0ef9fd83bce71e6b2ae60437bbd191349fbf6839 /cad
parent25c348a04b07f9a6d0bc20ad28e309b9e8c6b661 (diff)
downloadports-2e4cba834775867c975b3ce1c57f09dc2a31d88d.tar.gz
ports-2e4cba834775867c975b3ce1c57f09dc2a31d88d.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/Makefile1
-rw-r--r--cad/geda-gattrib/Makefile27
-rw-r--r--cad/geda-gattrib/distinfo3
-rw-r--r--cad/geda-gattrib/files/patch-src_Makefile.in11
-rw-r--r--cad/geda-gattrib/pkg-descr3
-rw-r--r--cad/geda-gattrib/pkg-plist3
6 files changed, 48 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index 7b212826caa4..4d0e0415ac0e 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -20,6 +20,7 @@
SUBDIR += fandango
SUBDIR += feappv
SUBDIR += geda
+ SUBDIR += geda-gattrib
SUBDIR += geda-symbols
SUBDIR += geda-symcheck
SUBDIR += geda-utils
diff --git a/cad/geda-gattrib/Makefile b/cad/geda-gattrib/Makefile
new file mode 100644
index 000000000000..a94123b72014
--- /dev/null
+++ b/cad/geda-gattrib/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: geda-gattrib
+# Date created: 26 June 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gattrib
+PORTVERSION= 20060123
+CATEGORIES= cad
+MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/devel/${PORTVERSION}/ \
+ http://geda.seul.org/devel/${PORTVERSION}/ \
+ http://www.tinkerbox.org/projects/files/gEDA/
+DISTNAME= geda-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= GEDA's attribute editor
+
+RUN_DEPENDS= ${LOCALBASE}/share/gEDA/sym:${PORTSDIR}/cad/geda-symbols
+LIB_DEPENDS= geda.25:${PORTSDIR}/cad/libgeda
+
+GNU_CONFIGURE= yes
+USE_GNOME= gtk20
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/cad/geda-gattrib/distinfo b/cad/geda-gattrib/distinfo
new file mode 100644
index 000000000000..246dde86c76c
--- /dev/null
+++ b/cad/geda-gattrib/distinfo
@@ -0,0 +1,3 @@
+MD5 (geda-gattrib-20060123.tar.gz) = 9b80848a7e746e127d9d2fc2a080b8cc
+SHA256 (geda-gattrib-20060123.tar.gz) = 495b9fbfa4013bed80032cb2fe25dad2308ea8fd83b361ac94cbdf245553355c
+SIZE (geda-gattrib-20060123.tar.gz) = 317978
diff --git a/cad/geda-gattrib/files/patch-src_Makefile.in b/cad/geda-gattrib/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..1a632d81f37c
--- /dev/null
+++ b/cad/geda-gattrib/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Mon Jun 26 03:31:52 2006
++++ src/Makefile.in Mon Jun 26 03:31:58 2006
+@@ -264,7 +264,7 @@
+ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+ $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+-LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
++LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@ -lgeda
+ DIST_SOURCES = $(am__gattrib_SOURCES_DIST)
+ DIST_COMMON = $(srcdir)/Makefile.in Makefile.am
+ SOURCES = $(gattrib_SOURCES)
diff --git a/cad/geda-gattrib/pkg-descr b/cad/geda-gattrib/pkg-descr
new file mode 100644
index 000000000000..6e183204d3dc
--- /dev/null
+++ b/cad/geda-gattrib/pkg-descr
@@ -0,0 +1,3 @@
+Gattrib is gEDA's attribute editor.
+
+WWW: http://www.geda.seul.org
diff --git a/cad/geda-gattrib/pkg-plist b/cad/geda-gattrib/pkg-plist
new file mode 100644
index 000000000000..66a96e35532e
--- /dev/null
+++ b/cad/geda-gattrib/pkg-plist
@@ -0,0 +1,3 @@
+bin/gattrib
+share/gEDA/system-gattribrc
+@dirrmtry share/gEDA