aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2014-08-22 11:08:48 +0000
committerHiroki Sato <hrs@FreeBSD.org>2014-08-22 11:08:48 +0000
commita2dc82fcc1b9a9adab9fb8f0d9be608f96aaec08 (patch)
tree4c0861cc63f21ff9135fd635d4c362d30b007d6a /cad
parent6e0c41ef7548b706b1e2ccded776f37ff081be25 (diff)
downloadports-a2dc82fcc1b9a9adab9fb8f0d9be608f96aaec08.tar.gz
ports-a2dc82fcc1b9a9adab9fb8f0d9be608f96aaec08.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/spice/Makefile16
-rw-r--r--cad/spice/distinfo4
-rw-r--r--cad/spice/files/Makefile10
3 files changed, 24 insertions, 6 deletions
diff --git a/cad/spice/Makefile b/cad/spice/Makefile
index 0d1d3322939d..79bc1d0de6a2 100644
--- a/cad/spice/Makefile
+++ b/cad/spice/Makefile
@@ -7,9 +7,11 @@ PORTREVISION= 11
CATEGORIES= cad
MASTER_SITES= http://embedded.eecs.berkeley.edu/pubs/downloads/spice/:srcs \
http://www-device.eecs.berkeley.edu/~bsim/Files/BSIM3/ftpv330/src/:bsim3 \
+ http://www-device.eecs.berkeley.edu/~bsim/Files/BSIM4/BSIM480/:bsim4 \
LOCAL/hrs/${PORTNAME}:docs
DISTFILES= spice3f5${EXTRACT_SUFX}:srcs \
BSIM3v330.tar.Z:bsim3 \
+ BSIM480_Code.zip:bsim4 \
cp.ps:docs toc.ps:docs doc.ps:docs
DIST_SUBDIR= spice
EXTRACT_ONLY= spice3f5${EXTRACT_SUFX}
@@ -20,6 +22,8 @@ COMMENT= General-purpose circuit simulation program
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+EXTRACT_DEPENDS= ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip
+
WRKSRC= ${WRKDIR}/${PORTNAME}3f5
MAKEFILE= ${FILESDIR}/Makefile
CONFIGURE_ENV= CONFIGFILE="${WRKSRC}/conf/FreeBSD" \
@@ -32,22 +36,30 @@ PORTEXAMPLES= bjtnoise.cir bsim1tst.cir bsim2tst.cir diffpair.cir \
process.pro pz2.cir pzt.cir rc.cir rca3040.cir resnoise.cir \
rtlinv.cir schmitt.cir simplepz.cir
-OPTIONS_DEFINE= DOCS EXAMPLES X11 DEV_BSIM3
+OPTIONS_DEFINE= DOCS EXAMPLES X11 DEV_BSIM3 DEV_BSIM4
OPTIONS_DEFAULT=DOCS EXAMPLES X11
X11_USE= XORG=x11,xaw,xext,xmu,xt
X11_CONFIGURE_ENV= WITH_X11=yes
DEV_BSIM3_DESC= BSIM3v3 MOS Transistor Model Support
DEV_BSIM3_CONFIGURE_ENV=DEV_BSIM3=yes
+DEV_BSIM4_DESC= BSIM4v4 MOS Transistor Model Support
+DEV_BSIM4_CONFIGURE_ENV=DEV_BSIM4=yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDEV_BSIM3}
post-extract:
+ @${DO_NADA}
+.if ${PORT_OPTIONS:MDEV_BSIM3}
@${MKDIR} ${WRKSRC}/src/lib/dev/bsim3
${TAR} -xf ${DISTDIR}/${DIST_SUBDIR}/BSIM3v330.tar.Z \
-C ${WRKSRC}/src/lib/dev/bsim3
.endif
+.if ${PORT_OPTIONS:MDEV_BSIM4}
+ @${MKDIR} ${WRKSRC}/src/lib/dev/bsim4
+ ${UNZIP_CMD} -qo ${DISTDIR}/${DIST_SUBDIR}/BSIM480_Code.zip \
+ -d ${WRKSRC}/src/lib/dev/bsim4
+.endif
do-configure:
@${SETENV} ${CONFIGURE_ENV} ${MAKE} -f ${MAKEFILE} configure
diff --git a/cad/spice/distinfo b/cad/spice/distinfo
index 4db27a17c094..56184288710d 100644
--- a/cad/spice/distinfo
+++ b/cad/spice/distinfo
@@ -2,6 +2,10 @@ SHA256 (spice/spice3f5.tar.gz) = cac11fe2a761241e6b6c9eaa31b938c7ffa76aeaecac098
SIZE (spice/spice3f5.tar.gz) = 1226185
SHA256 (spice/BSIM3v330.tar.Z) = 3d8d1739c5fb7f1e56af70e5dc05a6f9014d0954a4f3c1bcf778a494ae0087b2
SIZE (spice/BSIM3v330.tar.Z) = 113719
+SHA256 (spice/BSIM480_Code.zip) = 76850257fefc9d76369538ba5aa1cac7b09fb98311c39564e9e6d044b49db9c8
+SIZE (spice/BSIM480_Code.zip) = 158442
+SHA256 (spice/BSIM6.1.0_Release_March20_2014.zip) = 664e6c2138b35f45f8883a74557abff3b18f59e9da7d89adc30d0c854919c423
+SIZE (spice/BSIM6.1.0_Release_March20_2014.zip) = 1060937
SHA256 (spice/cp.ps) = 3bab6c3487def4ce2e817bf7ef3c1a7d199ea8e790da3a786f936872b35d0920
SIZE (spice/cp.ps) = 10297
SHA256 (spice/toc.ps) = 22228246f98f38e39a22911251fa52782ca6a2a7fb273fd78cf3da833d1f52e8
diff --git a/cad/spice/files/Makefile b/cad/spice/files/Makefile
index 7f978b24f3b0..efffbda428f1 100644
--- a/cad/spice/files/Makefile
+++ b/cad/spice/files/Makefile
@@ -16,9 +16,11 @@ INTERFACE_OPTS+=-DWANT_X11
VARLIST+= INCX LIBX
.endif
X_DIR= ${LOCALBASE}
-.if defined(DEV_BSIM3) && !empty(DEV_BSIM3)
-DEVLIST+= bsim3
-.endif
+.for D in BSIM3 BSIM4
+. if defined(DEV_$D) && !empty(DEV_$D)
+DEVLIST+= ${D:tl}
+. endif
+.endfor
configure:
rm -f ${CONFIGFILE}
@@ -26,7 +28,7 @@ configure:
echo "$V=${${V}}" >> ${CONFIGFILE}
.endfor
.for V in ${DEVLIST}
- echo "$V+=${${V}}" >> ${CONFIGFILE}
+ echo "DEVICES+=${V}" >> ${CONFIGFILE}
.endfor
PREFIX?= /usr/local