aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2018-08-30 02:26:19 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2018-08-30 02:26:19 +0000
commitbf54e29e8e0ac80ee0f62da49230a4a87129e908 (patch)
treefb2b62d12496da80b246cf25c2a7bd36738da258 /cad
parent9b93fbb32b19258018b826caf02f7c62c74d9040 (diff)
downloadports-bf54e29e8e0ac80ee0f62da49230a4a87129e908.tar.gz
ports-bf54e29e8e0ac80ee0f62da49230a4a87129e908.zip
GNU LibreDWG is a C library to handle DWG files which aims to be a free
replacement for the OpenDWG libraries. There are command line tools and libraries to read and write DWG files, with converters for various formats: DXF, DXFB, SVG, PS, JSON, XML, etc. WWW: https://www.gnu.org/software/libredwg/
Notes
Notes: svn path=/head/; revision=478428
Diffstat (limited to 'cad')
-rw-r--r--cad/Makefile1
-rw-r--r--cad/libredwg/Makefile27
-rw-r--r--cad/libredwg/distinfo3
-rw-r--r--cad/libredwg/pkg-descr15
-rw-r--r--cad/libredwg/pkg-plist24
5 files changed, 70 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index 432a3bba531a..d9ef14cb4d73 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -57,6 +57,7 @@
SUBDIR += leocad
SUBDIR += libopencad
SUBDIR += librecad
+ SUBDIR += libredwg
SUBDIR += linux-eagle5
SUBDIR += linuxcnc-devel
SUBDIR += logisim
diff --git a/cad/libredwg/Makefile b/cad/libredwg/Makefile
new file mode 100644
index 000000000000..9332525e5c1b
--- /dev/null
+++ b/cad/libredwg/Makefile
@@ -0,0 +1,27 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libredwg
+PORTVERSION= 0.6
+CATEGORIES= cad devel
+MASTER_SITES= GNU
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Library and command line tools to handle DWG files
+
+LICENSE= GPLv3+
+
+USES= libtool tar:xz
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+INFO= LibreDWG
+PORTDOCS= AUTHORS ChangeLog NEWS README TODO
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/cad/libredwg/distinfo b/cad/libredwg/distinfo
new file mode 100644
index 000000000000..12025b73ebcc
--- /dev/null
+++ b/cad/libredwg/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1534153306
+SHA256 (libredwg-0.6.tar.xz) = 6d525ca849496852f62ad6a11b7b801d0aafd1fa1366c45bdb0f11a90bd6f878
+SIZE (libredwg-0.6.tar.xz) = 3608836
diff --git a/cad/libredwg/pkg-descr b/cad/libredwg/pkg-descr
new file mode 100644
index 000000000000..ceb6b4f2ffa6
--- /dev/null
+++ b/cad/libredwg/pkg-descr
@@ -0,0 +1,15 @@
+GNU LibreDWG is a C library to handle DWG files. It aims to be a free
+replacement for the OpenDWG libraries. DWG is the native file format
+of AutoCAD.
+
+LibreDWG was based on LibDWG (http://libdwg.sourceforge.net), which is
+written with variable names, documentation, and comments in Esperanto.
+
+There are also command line tools and libraries to read and write DWG
+files, with converters for various formats (DXF, DXFB, SVG, PS, JSON,
+XML, etc.) and a SaveAs functionality, to convert between the various
+DWG versions. It can read r13-r2018 DWG, write r13-r2000 DWG, write
+r11-r2018 DXF ASCII and binary. Much more object types than any other
+free DWG library.
+
+WWW: https://www.gnu.org/software/libredwg/
diff --git a/cad/libredwg/pkg-plist b/cad/libredwg/pkg-plist
new file mode 100644
index 000000000000..e59f5cca722b
--- /dev/null
+++ b/cad/libredwg/pkg-plist
@@ -0,0 +1,24 @@
+bin/dwg2SVG
+bin/dwg2dxf
+bin/dwgbmp
+bin/dwggrep
+bin/dwglayers
+bin/dwgread
+bin/dwgrewrite
+include/dwg.h
+include/dwg_api.h
+lib/libredwg.a
+lib/libredwg.so
+lib/libredwg.so.0
+lib/libredwg.so.0.0.0
+libdata/pkgconfig/libredwg.pc
+man/man1/dwg2SVG.1.gz
+man/man1/dwg2dxf.1.gz
+man/man1/dwg2ps.1.gz
+man/man1/dwgbmp.1.gz
+man/man1/dwggrep.1.gz
+man/man1/dwglayers.1.gz
+man/man1/dwgread.1.gz
+man/man1/dwgrewrite.1.gz
+man/man1/dwgwrite.1.gz
+man/man1/dxf2dwg.1.gz