aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-01-17 20:36:45 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-01-17 20:36:45 +0000
commit041582de0933e621982a39e6e9d57350d7463548 (patch)
tree6df66e606d336798da318220ccf647274ea070f9 /cad
parent51c4ea40be6bf651f95341c77a64bbe76d88d3a3 (diff)
downloadports-041582de0933e621982a39e6e9d57350d7463548.tar.gz
ports-041582de0933e621982a39e6e9d57350d7463548.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/gmsh/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index 5b1e282b684d..d547b5ca519a 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gmsh
PORTVERSION= 1.62.0
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= http://www.geuz.org/gmsh/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -21,14 +22,21 @@ LIB_DEPENDS= gsl.7:${PORTSDIR}/math/gsl \
.if defined(PACKAGE_BUILDING)
WITHOUT_TRIANGLE= yes
+WITHOUT_TETGEN= yes
.endif
.if !defined(WITHOUT_TRIANGLE)
EXTRACT_DEPENDS+= ${NONEXISTENT}:${TRIANGLE_PORTDIR}:patch
+TRIANGLE_PORTDIR= ${PORTSDIR}/math/triangle
+.endif
+
+.if !defined(WITHOUT_TETGEN)
+EXTRACT_DEPENDS+= ${NONEXISTENT}:${TETGEN_PORTDIR}:patch
+TETGEN_PORTDIR= ${PORTSDIR}/math/tetgen
+TETGEN_SRC= predicates.cxx tetgen.cxx tetgen.h
.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-TRIANGLE_PORTDIR= ${PORTSDIR}/math/triangle
USE_REINPLACE= yes
GNU_CONFIGURE= yes
@@ -45,6 +53,10 @@ MAN1= gmsh.1
NO_CDROM= "Triangle must not be sold for profit"
.endif
+.if !defined(WITHOUT_TETGEN)
+NO_CDROM+= "Tetgen must not be sold for profit"
+.endif
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
@@ -57,6 +69,10 @@ post-extract:
${CP} `cd ${TRIANGLE_PORTDIR}; ${MAKE} -V WRKSRC`/triangle.* \
${WRKSRC}/contrib/Triangle
.endif
+.if !defined(WITHOUT_TETGEN)
+ ${CP} ${TETGEN_SRC:S|^|`cd ${TETGEN_PORTDIR}; ${MAKE} -V WRKSRC`/|} \
+ ${WRKSRC}/contrib/Tetgen
+.endif
pre-configure:
.for demo in lowmem-anim.geo