aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-03-08 16:03:52 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-03-08 16:03:52 +0000
commit0583db668d4baa1db49a21586834fa621ece154b (patch)
tree79c00eb94ed65ff32adfbb6129b3a5e2b60851ee /cad
parent8f3fa5b03dc486b691c4555bd80ae7cb29659df6 (diff)
downloadports-0583db668d4baa1db49a21586834fa621ece154b.tar.gz
ports-0583db668d4baa1db49a21586834fa621ece154b.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/jspice3/Makefile29
-rw-r--r--cad/jspice3/distinfo4
-rw-r--r--cad/jspice3/files/patch-build22
-rw-r--r--cad/jspice3/files/patch-conf+unixconf+mkheader.019
-rw-r--r--cad/jspice3/files/patch-conf_util_configure2
-rw-r--r--cad/jspice3/files/patch-src+bin+help.c27
-rw-r--r--cad/jspice3/files/patch-src+lib+dev+ltra+ltramisc.c31
-rw-r--r--cad/jspice3/files/patch-src_bin_help.c30
-rw-r--r--cad/jspice3/files/patch-src_bin_spiced.c11
-rw-r--r--cad/jspice3/files/patch-src_lib_ckt_cktdelt.c11
-rw-r--r--cad/jspice3/files/patch-src_lib_fte_misccoms.c (renamed from cad/jspice3/files/patch-src+lib+fte+misccoms.c)6
-rw-r--r--cad/jspice3/files/patch-src_lib_fte_options.c45
-rw-r--r--cad/jspice3/files/patch-src_lib_fte_resource.c6
-rw-r--r--cad/jspice3/files/patch-src_lib_inp_ifeval.c11
-rw-r--r--cad/jspice3/files/patch-src_lib_mfb_mfbgnc.c29
-rw-r--r--cad/jspice3/files/patch-src_lib_plot_postsc.c26
-rw-r--r--cad/jspice3/files/patch-src_lib_plot_x11.c (renamed from cad/jspice3/files/patch-src+lib+plot+x11.c)8
-rw-r--r--cad/jspice3/files/patch-src_lib_sced_labeltxt.c20
-rw-r--r--cad/jspice3/files/patch-src_lib_sced_scedintr.c11
-rw-r--r--cad/jspice3/pkg-plist2
20 files changed, 65 insertions, 285 deletions
diff --git a/cad/jspice3/Makefile b/cad/jspice3/Makefile
index 824efb108aaa..94c152f680e2 100644
--- a/cad/jspice3/Makefile
+++ b/cad/jspice3/Makefile
@@ -2,36 +2,39 @@
# $FreeBSD$
PORTNAME= jspice3
-PORTVERSION= 2.5.011109
-PORTREVISION= 1
+DISTVERSION= 2.5-110615
CATEGORIES= cad
MASTER_SITES= http://www.wrcad.com/ftp/pub/
-DISTNAME= ${PORTNAME}-2.5-011109
MAINTAINER= ports@FreeBSD.org
COMMENT= Adaptation of the Berkeley Spice3f4 with superconductivity
-BROKEN= unfetchable
-
CONFLICTS= spice-[0-9]*
OPTIONS_DEFINE= X11 EXAMPLES
OPTIONS_DEFAULT= X11
-WRKSRC= ${WRKDIR}/${PORTNAME}-2.5
+OPTIONS_SUB= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
X11_USE= XORG=x11,xaw,xt
-pre-configure:
- @${REINPLACE_CMD} -e 's+/usr/local+${PREFIX}+g;s+-O -g+${CFLAGS}+g;' \
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/^prefix/s|=.*|= ${PREFIX}| ; \
+ /^SPICE_HOST/s|=.*|= localhost| ; \
+ /^CC_OPT/s|=.*|= ${CFLAGS}|' \
${WRKSRC}/conf/unixconf/mkheader.0
-pre-configure-X11-on:
- @${REINPLACE_CMD} -e 's+#%%WITH_X%%++g' \
+post-patch-X11-off:
+ @${REINPLACE_CMD} -e \
+ '/$$makeprog depend/s|^|#|' \
+ ${WRKSRC}/build
+ @${REINPLACE_CMD} -e \
+ 's|^LIBX|#LIBX| ; \
+ s|-DWANT_X11||' \
${WRKSRC}/conf/unixconf/mkheader.0
-pre-configure-X11-off:
- @${ECHO} "#undef HAVE_X11" >> ${WRKSRC}/src/include/spice.h
-
do-build:
(cd ${WRKSRC};${SETENV} ${MAKE_ENV} ${SH} build)
diff --git a/cad/jspice3/distinfo b/cad/jspice3/distinfo
index 363d2bd98a1a..98a72eaed694 100644
--- a/cad/jspice3/distinfo
+++ b/cad/jspice3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (jspice3-2.5-011109.tar.gz) = 4fa5492584fb201b0f396ce805424b3128db4a70450506158854788aea68d7bf
-SIZE (jspice3-2.5-011109.tar.gz) = 1149738
+SHA256 (jspice3-2.5-110615.tar.gz) = f40e23b2d5c554a5b7be7037fe41c6f179c33e07ab9da365d97c2b517dcd6af6
+SIZE (jspice3-2.5-110615.tar.gz) = 1145726
diff --git a/cad/jspice3/files/patch-build b/cad/jspice3/files/patch-build
index 9fd79ecfdc13..5e5068c493c5 100644
--- a/cad/jspice3/files/patch-build
+++ b/cad/jspice3/files/patch-build
@@ -1,6 +1,6 @@
---- build.orig Tue May 1 13:37:12 2001
-+++ build Sat Nov 25 00:38:47 2006
-@@ -22,7 +22,7 @@
+--- build.orig 2015-11-05 18:10:02 UTC
++++ build
+@@ -22,7 +22,7 @@ if [ -d conf/unixconf ]; then
echo '#######################################################################'> conf/mkheader.in
echo '####### Makefile generated by build script ############################'>> conf/mkheader.in
echo VERSION = $version>> conf/mkheader.in
@@ -9,16 +9,16 @@
echo '#######################################################################'>> conf/mkheader.in
cat conf/unixconf/mkheader.0 >> conf/mkheader.in
else
-@@ -43,7 +43,7 @@
+@@ -51,7 +51,7 @@ if [ -f conf/util/configure ]; then
+ if [ `uname -s` = Darwin -a -d /opt/X11 ]; then
+ util/configure --x-includes=/opt/X11/include --x-libraries=/opt/X11/lib -srcdir .
+ else
+- util/configure -srcdir .
++ util/configure --prefix=${PREFIX} --x-includes=${LOCALBASE}/include --x-libraries=${LOCALBASE}/lib -srcdir .
+ fi
- if [ -f conf/util/configure ]; then
- cd conf
-- util/configure -srcdir .
-+ util/configure -srcdir . --prefix=${PREFIX} -x-includes="${LOCALBASE}/include" -x-libraries="${LOCALBASE}/lib"
if [ ! -f ../src/include/config.h ] || \
- [ "`diff config.h ../src/include/config.h |head`" ]; then
- echo Installing config.h
-@@ -92,8 +92,14 @@
+@@ -102,8 +102,14 @@ if [ -f conf/mkheader ]; then
fi
echo Creating makefiles in the subdirectories...
$makeprog make
diff --git a/cad/jspice3/files/patch-conf+unixconf+mkheader.0 b/cad/jspice3/files/patch-conf+unixconf+mkheader.0
deleted file mode 100644
index aa176fedc96e..000000000000
--- a/cad/jspice3/files/patch-conf+unixconf+mkheader.0
+++ /dev/null
@@ -1,19 +0,0 @@
---- conf/unixconf/mkheader.0.orig Tue Jan 15 19:15:36 2002
-+++ conf/unixconf/mkheader.0 Fri Jul 21 06:11:55 2006
-@@ -18,7 +18,7 @@
- BUG_ADDR = stevew@srware.com
-
- # name of host for remote spice runs
--SPICE_HOST =
-+SPICE_HOST = localhost
-
- # spice daemon log file
- SPICED_LOG = /tmp/spiced.log
-@@ -43,6 +43,6 @@
- LDFLAGS = @LIBS@
- RANLIB = @RANLIB@
- INCX = @X_CFLAGS@
--LIBX = @X_PRE_LIBS@ @X_LIBS@ -lXaw -lXt -lXext -lXmu -lX11 @X_EXTRA_LIBS@
-+#%%WITH_X%%LIBX = @X_PRE_LIBS@ @X_LIBS@ -lXaw -lXt -lXext -lXmu -lX11 @X_EXTRA_LIBS@
- INTERFACE_OPTS = -DWANT_MFB -DWANT_X11
- MFB = mfb
diff --git a/cad/jspice3/files/patch-conf_util_configure b/cad/jspice3/files/patch-conf_util_configure
index 1b2966585d99..ba94f82853b7 100644
--- a/cad/jspice3/files/patch-conf_util_configure
+++ b/cad/jspice3/files/patch-conf_util_configure
@@ -1,4 +1,4 @@
---- conf/util/configure.orig 2002-01-15 19:21:25.000000000 +0000
+--- conf/util/configure.orig 2002-01-15 19:21:25 UTC
+++ conf/util/configure
@@ -805,11 +805,7 @@ else
fi
diff --git a/cad/jspice3/files/patch-src+bin+help.c b/cad/jspice3/files/patch-src+bin+help.c
deleted file mode 100644
index 36b0e428d1f6..000000000000
--- a/cad/jspice3/files/patch-src+bin+help.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/bin/help.c.orig Fri Jul 21 06:16:08 2006
-+++ src/bin/help.c Fri Jul 21 06:18:15 2006
-@@ -14,6 +14,7 @@
- #include <pwd.h>
- #endif
-
-+static char *hcopydev;
- #ifdef HAVE_X11
-
- #include <X11/Intrinsic.h>
-@@ -22,7 +23,6 @@
- Display *Xdisplay;
- static XtAppContext app_con;
- static Widget toplevel;
--static char *hcopydev;
-
- static String fallback_resources[] = {
-
-@@ -188,7 +188,7 @@
- {
- if (!strcmp(n, kw_hcopydev)) {
- strcpy(r, hcopydev);
-- return (True);
-+ return (1);
- }
- return (false);
- }
diff --git a/cad/jspice3/files/patch-src+lib+dev+ltra+ltramisc.c b/cad/jspice3/files/patch-src+lib+dev+ltra+ltramisc.c
deleted file mode 100644
index c34055c7b520..000000000000
--- a/cad/jspice3/files/patch-src+lib+dev+ltra+ltramisc.c
+++ /dev/null
@@ -1,31 +0,0 @@
---- src/lib/dev/ltra/ltramisc.c.orig Wed Jan 5 03:25:41 2005
-+++ src/lib/dev/ltra/ltramisc.c Thu Jul 20 23:59:44 2006
-@@ -965,10 +965,12 @@
- double ax = fabs(x);
- if (ax < 3.75) {
- double y = x/3.75;
-+ double ans1;
-+ double ans2;
- y *= y;
-- double ans1 = 1.0+y*(3.5156229+y*(3.0899424+y*(1.2067492
-+ ans1 = 1.0+y*(3.5156229+y*(3.0899424+y*(1.2067492
- +y*(0.2659732+y*(0.360768e-1+y*0.45813e-2)))));
-- double ans2 = ax*(0.5+y*(0.87890594+y*(0.51498869+y*(0.15084934
-+ ans2 = ax*(0.5+y*(0.87890594+y*(0.51498869+y*(0.15084934
- +y*(0.2658733e-1+y*(0.301532e-2+y*0.32411e-3))))));
- if (x > 0)
- ans1 += ans2;
-@@ -978,11 +980,12 @@
- }
- else {
- double y = 3.75/ax;
-+ double ans2;
- double ans1 = (0.39894228+y*(0.1328592e-1
- +y*(0.225319e-2+y*(-0.157565e-2+y*(0.916281e-2
- +y*(-0.2057706e-1+y*(0.2635537e-1+y*(-0.1647633e-1
- +y*0.392377e-2))))))));
-- double ans2 = 0.2282967e-1+y*(-0.2895312e-1+y*(0.1787654e-1
-+ ans2 = 0.2282967e-1+y*(-0.2895312e-1+y*(0.1787654e-1
- -y*0.420059e-2));
- ans2 = 0.39894228+y*(-0.3988024e-1+y*(-0.362018e-2
- +y*(0.163801e-2+y*(-0.1031555e-1+y*ans2))));
diff --git a/cad/jspice3/files/patch-src_bin_help.c b/cad/jspice3/files/patch-src_bin_help.c
index d9c60623d818..1ca588c6470c 100644
--- a/cad/jspice3/files/patch-src_bin_help.c
+++ b/cad/jspice3/files/patch-src_bin_help.c
@@ -1,11 +1,27 @@
---- src/bin/help.c.intermediate 2014-08-18 06:30:22.000000000 +0000
+--- src/bin/help.c.orig 2015-11-05 17:57:50 UTC
+++ src/bin/help.c
-@@ -53,7 +53,7 @@ XErrorEvent *errorev;
+@@ -14,6 +14,7 @@ Authors: 1986 Wayne A. Christopher
+ #include <pwd.h>
+ #endif
- XGetErrorText(display, errorev->error_code, ErrorMessage, 1024);
- printf(ErrorMessage);
-- return;
-+ return (NULL);
- }
++static char *hcopydev;
+ #ifdef HAVE_X11
+ #include <X11/Intrinsic.h>
+@@ -22,7 +23,6 @@ Authors: 1986 Wayne A. Christopher
+ Display *Xdisplay;
+ static XtAppContext app_con;
+ static Widget toplevel;
+-static char *hcopydev;
+ static String fallback_resources[] = {
+
+@@ -188,7 +188,7 @@ int t;
+ {
+ if (!strcmp(n, kw_hcopydev)) {
+ strcpy(r, hcopydev);
+- return (True);
++ return (1);
+ }
+ return (false);
+ }
diff --git a/cad/jspice3/files/patch-src_bin_spiced.c b/cad/jspice3/files/patch-src_bin_spiced.c
index 4b9eb6a5e261..7e391a1415b5 100644
--- a/cad/jspice3/files/patch-src_bin_spiced.c
+++ b/cad/jspice3/files/patch-src_bin_spiced.c
@@ -1,4 +1,4 @@
---- src/bin/spiced.c.orig 2001-05-01 21:56:08.000000000 +0000
+--- src/bin/spiced.c.orig 2015-11-05 17:58:45 UTC
+++ src/bin/spiced.c
@@ -16,12 +16,11 @@ Author: 1985 Wayne A. Christopher, U. C.
@@ -16,12 +16,3 @@
#include <sys/types.h>
#ifdef HAVE_SOCKET
-@@ -293,7 +292,7 @@ sigchild()
- (void) fclose(fp);
- } else
- nrunning--;
-- return;
-+ return 0;
- }
-
- #else /* not HAVE_SOCKET */
diff --git a/cad/jspice3/files/patch-src_lib_ckt_cktdelt.c b/cad/jspice3/files/patch-src_lib_ckt_cktdelt.c
deleted file mode 100644
index 85fe9b848126..000000000000
--- a/cad/jspice3/files/patch-src_lib_ckt_cktdelt.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/lib/ckt/cktdelt.c.orig 1997-03-21 22:04:30.000000000 +0000
-+++ src/lib/ckt/cktdelt.c
-@@ -20,7 +20,7 @@ GENERIC *task;
- {
- JOB *job, *next;
-
-- if (task == NULL) return;
-+ if (task == NULL) return (OK);
-
- for (job = ((TSKtask*)task)->jobs; job; job = next) {
- next = job->JOBnextJob;
diff --git a/cad/jspice3/files/patch-src+lib+fte+misccoms.c b/cad/jspice3/files/patch-src_lib_fte_misccoms.c
index 713a397d2d3d..3d355747d161 100644
--- a/cad/jspice3/files/patch-src+lib+fte+misccoms.c
+++ b/cad/jspice3/files/patch-src_lib_fte_misccoms.c
@@ -1,6 +1,6 @@
---- src/lib/fte/misccoms.c.orig Tue Feb 28 16:57:47 2006
-+++ src/lib/fte/misccoms.c Tue Feb 28 16:59:28 2006
-@@ -284,7 +284,7 @@
+--- src/lib/fte/misccoms.c.orig 2001-05-01 20:58:18 UTC
++++ src/lib/fte/misccoms.c
+@@ -284,7 +284,7 @@ wordlist *wl;
pl->pl_title,
pl->pl_name);
}
diff --git a/cad/jspice3/files/patch-src_lib_fte_options.c b/cad/jspice3/files/patch-src_lib_fte_options.c
deleted file mode 100644
index 0c4be5b2f785..000000000000
--- a/cad/jspice3/files/patch-src_lib_fte_options.c
+++ /dev/null
@@ -1,45 +0,0 @@
---- src/lib/fte/options.c.orig 2009-01-11 20:27:11.000000000 +0000
-+++ src/lib/fte/options.c
-@@ -66,7 +66,7 @@ def_fn(_iv_cpdebug)
-
- def_fn(_iv_history)
- {
-- if (!flag) return;
-+ if (!flag) return (US_OK);
- if (v->va_type == VT_NUM)
- cp_maxhistlength = v->va_num;
- else if (v->va_type == VT_REAL)
-@@ -930,27 +930,27 @@ struct variable **v1, **v2;
- v = va_copy(plot_cur->pl_env);
- else
- v = NULL;
-- if (tv = cp_enqvar(kw_plots)) {
-+ if ((tv = cp_enqvar(kw_plots))) {
- tv->va_next = v;
- v = tv;
- }
-- if (tv = cp_enqvar(kw_curplot)) {
-+ if ((tv = cp_enqvar(kw_curplot))) {
- tv->va_next = v;
- v = tv;
- }
-- if (tv = cp_enqvar(kw_curplottitle)) {
-+ if ((tv = cp_enqvar(kw_curplottitle))) {
- tv->va_next = v;
- v = tv;
- }
-- if (tv = cp_enqvar(kw_curplotname)) {
-+ if ((tv = cp_enqvar(kw_curplotname))) {
- tv->va_next = v;
- v = tv;
- }
-- if (tv = cp_enqvar(kw_curplotdate)) {
-+ if ((tv = cp_enqvar(kw_curplotdate))) {
- tv->va_next = v;
- v = tv;
- }
-- if (tv = cp_enqvar(kw_display)) {
-+ if ((tv = cp_enqvar(kw_display))) {
- tv->va_next = v;
- v = tv;
- }
diff --git a/cad/jspice3/files/patch-src_lib_fte_resource.c b/cad/jspice3/files/patch-src_lib_fte_resource.c
index 641ce7b4dae4..71caa541fcd9 100644
--- a/cad/jspice3/files/patch-src_lib_fte_resource.c
+++ b/cad/jspice3/files/patch-src_lib_fte_resource.c
@@ -1,6 +1,6 @@
---- src/lib/fte/resource.c.orig Tue Nov 14 18:23:27 2006
-+++ src/lib/fte/resource.c Tue Nov 14 18:23:33 2006
-@@ -36,7 +36,7 @@
+--- src/lib/fte/resource.c.orig 1997-03-21 22:03:41 UTC
++++ src/lib/fte/resource.c
+@@ -36,7 +36,7 @@ static struct timeb lasttime;
#endif
#endif
#endif
diff --git a/cad/jspice3/files/patch-src_lib_inp_ifeval.c b/cad/jspice3/files/patch-src_lib_inp_ifeval.c
deleted file mode 100644
index 49a2625bac72..000000000000
--- a/cad/jspice3/files/patch-src_lib_inp_ifeval.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/lib/inp/ifeval.c.orig 1997-03-21 22:04:12.000000000 +0000
-+++ src/lib/inp/ifeval.c
-@@ -37,7 +37,7 @@ double step, finaltime;
- int i;
-
- if (!tree)
-- return;
-+ return (OK);
- for (i = 0; i < tree->numVars; i++)
- init_node(pt->derivs[i],step,finaltime);
- init_node(pt->tree,step,finaltime);
diff --git a/cad/jspice3/files/patch-src_lib_mfb_mfbgnc.c b/cad/jspice3/files/patch-src_lib_mfb_mfbgnc.c
deleted file mode 100644
index 0684c7f09ad8..000000000000
--- a/cad/jspice3/files/patch-src_lib_mfb_mfbgnc.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/lib/mfb/mfbgnc.c.orig 2001-05-01 19:45:26.000000000 +0000
-+++ src/lib/mfb/mfbgnc.c
-@@ -120,7 +120,7 @@ char *PM;
- cp = PM;
- dp = result;
- if (cp == NULL) {
-- return;
-+ return (NULL);
- }
- while (c = *cp++) {
- if(c == '$') {
-@@ -300,7 +300,7 @@ char *PM;
- y1 = reg;
- }
- else
-- return;
-+ return (NULL);
- hiy = (y1 >> 7) & 037;
- extra = x1 & 03 | ((y1 & 03) << 2);
- loy = (y1 >> 2) & 037;
-@@ -427,7 +427,7 @@ char *PM;
- continue;
-
- default:
-- return;
-+ return (NULL);
- }
- }
- *dp='\0';
diff --git a/cad/jspice3/files/patch-src_lib_plot_postsc.c b/cad/jspice3/files/patch-src_lib_plot_postsc.c
deleted file mode 100644
index c9d5cad54c66..000000000000
--- a/cad/jspice3/files/patch-src_lib_plot_postsc.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/lib/plot/postsc.c.orig 1997-03-21 22:03:37.000000000 +0000
-+++ src/lib/plot/postsc.c
-@@ -343,12 +343,12 @@ int linestyleid;
- get it when PS_Text restores a -1 linestyle */
- if (linestyleid == -1) {
- currentgraph->linestyle = -1;
-- return;
-+ return (0);
- }
-
- if (linestyleid < 0) {
- internalerror("bad linestyleid");
-- return;
-+ return (0);
- }
-
- if (linestyleid > dispdev->numlinestyles)
-@@ -407,7 +407,7 @@ int x, y, Xform;
-
- if (Xform == (char)0) {
- PS_Text(text,x,y);
-- return;
-+ return (0);
- }
-
- s = tbuf;
diff --git a/cad/jspice3/files/patch-src+lib+plot+x11.c b/cad/jspice3/files/patch-src_lib_plot_x11.c
index 1a909a6ec70e..895f3483b1e8 100644
--- a/cad/jspice3/files/patch-src+lib+plot+x11.c
+++ b/cad/jspice3/files/patch-src_lib_plot_x11.c
@@ -1,6 +1,6 @@
---- src/lib/plot/x11.c.orig Thu Sep 2 21:43:35 2004
-+++ src/lib/plot/x11.c Fri Jul 21 06:06:00 2006
-@@ -2205,7 +2205,7 @@
+--- src/lib/plot/x11.c.orig 2004-09-02 21:43:35 UTC
++++ src/lib/plot/x11.c
+@@ -2205,7 +2205,7 @@ ScedESC()
void
com_setrdb(wl)
@@ -9,7 +9,7 @@
{
/* be silent */
}
-@@ -2213,7 +2213,7 @@
+@@ -2213,7 +2213,7 @@ wordlist *wl;
int
PopUpErrMessage(fp)
diff --git a/cad/jspice3/files/patch-src_lib_sced_labeltxt.c b/cad/jspice3/files/patch-src_lib_sced_labeltxt.c
deleted file mode 100644
index a16d7289896e..000000000000
--- a/cad/jspice3/files/patch-src_lib_sced_labeltxt.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/lib/sced/labeltxt.c.orig 1997-03-21 22:04:16.000000000 +0000
-+++ src/lib/sced/labeltxt.c
-@@ -175,7 +175,7 @@ int x, y, degrees, scale;
- if (!strcmp(dispdev->name,"wp")) {
- /* use plain text for now */
- DevText(text,x,y);
-- return;
-+ return (0);
- }
-
- /* Hack! If degrees is >= 90, an angle is assumed.
-@@ -185,7 +185,7 @@ int x, y, degrees, scale;
-
- if (!strcmp(dispdev->name,"postscript")) {
- PS_ScaledText(text,x,y,degrees);
-- return;
-+ return (0);
- }
-
- if (degrees & 1) {
diff --git a/cad/jspice3/files/patch-src_lib_sced_scedintr.c b/cad/jspice3/files/patch-src_lib_sced_scedintr.c
deleted file mode 100644
index 7c7ef1124d9b..000000000000
--- a/cad/jspice3/files/patch-src_lib_sced_scedintr.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/lib/sced/scedintr.c.orig 2001-05-01 20:54:05.000000000 +0000
-+++ src/lib/sced/scedintr.c
-@@ -1009,7 +1009,7 @@ char *string;
- strcat(TypeOut,string);
- else
- strcat(TypeOut,"\n");
-- if (strchr(TypeOut,'\n') == NULL) return;
-+ if (strchr(TypeOut,'\n') == NULL) return (False);
- if (MoreLine(TypeOut))
- EnableMore(False);
- *TypeOut = '\0';
diff --git a/cad/jspice3/pkg-plist b/cad/jspice3/pkg-plist
index 6913cab809f4..3efbe1d92f21 100644
--- a/cad/jspice3/pkg-plist
+++ b/cad/jspice3/pkg-plist
@@ -1,5 +1,5 @@
bin/jspice3
-bin/help
+%%X11%%bin/help
bin/nutmeg
bin/proc2mod
bin/multidec