aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-12-09 16:20:31 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-12-09 16:20:31 +0000
commit785e2e9f0fab62af36d2b6e1b3b0af35e8e74536 (patch)
tree37fb4721b801e734fdcfb1c1f6c79463e6ed201e /cad
parentefb4318cde21155283eb776bc932e83b247a7be3 (diff)
downloadports-785e2e9f0fab62af36d2b6e1b3b0af35e8e74536.tar.gz
ports-785e2e9f0fab62af36d2b6e1b3b0af35e8e74536.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/magic/Makefile9
-rw-r--r--cad/magic/files/patch-ext2spice::ext2spice.c46
-rw-r--r--cad/magic/files/patch-extflat::EFint.h16
-rw-r--r--cad/magic/files/patch-extflat::EFread.c34
-rw-r--r--cad/magic/files/patch-magic::proto.magic161
-rw-r--r--cad/magic/files/patch-scmos::extract_template::scmosExt.tech42
-rw-r--r--cad/magic/files/patch-tech::tech.c54
-rw-r--r--cad/magic/files/patch-tech::tech.h8
-rw-r--r--cad/magic/files/patch-textio::textio.h15
-rw-r--r--cad/magic/files/patch-textio::textioInt.h12
-rw-r--r--cad/magic/files/patch-textio::txOutput.c178
-rw-r--r--cad/magic/files/patch-utils::LIBtextio.c51
12 files changed, 622 insertions, 4 deletions
diff --git a/cad/magic/Makefile b/cad/magic/Makefile
index bf6c1d42428c..e70b3c9d7d0e 100644
--- a/cad/magic/Makefile
+++ b/cad/magic/Makefile
@@ -7,6 +7,7 @@
PORTNAME= magic
PORTVERSION= 7.1
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= http://vlsi.cornell.edu/magic/
@@ -28,11 +29,11 @@ MAN8= prleak.8
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
post-patch:
+ @${EGREP} -lr '^#endif[^$$]' ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|\(^#endif\).*|\1|g; \
+ s|\(^#else\).*|\1|g; \
+ s|include.*<varargs\.h>|include <stdarg\.h>|'
@${FIND} ${WRKSRC} -name "Makefile" | ${XARGS} ${REINPLACE_CMD} -e \
's|make |\$$\{MAKE\} |g'
diff --git a/cad/magic/files/patch-ext2spice::ext2spice.c b/cad/magic/files/patch-ext2spice::ext2spice.c
new file mode 100644
index 000000000000..60a74a6979f3
--- /dev/null
+++ b/cad/magic/files/patch-ext2spice::ext2spice.c
@@ -0,0 +1,46 @@
+--- ext2spice/ext2spice.c.orig Tue Dec 9 16:53:56 2003
++++ ext2spice/ext2spice.c Tue Dec 9 16:55:34 2003
+@@ -18,7 +18,7 @@
+
+ #include <stdio.h>
+ #include <ctype.h>
+-#include <varargs.h>
++#include <stdarg.h>
+ #include "misc/magic.h"
+ #include "utils/malloc.h"
+ #include "utils/geometry.h"
+@@ -316,7 +316,7 @@
+ #ifdef free_all_mem
+ EFFlatDone();
+ EFDone();
+-#endif free_all_mem
++#endif
+
+ printf("Memory used: %s\n", RunStats(RS_MEM, NULL, NULL));
+ exit (0);
+@@ -1586,22 +1586,19 @@
+ }
+
+ /* debugging stuff */
+-#include <varargs.h>
++#include <stdarg.h>
+
+ #define DBG 1
+
+-DBPRINT( va_alist )
+- va_dcl
++DBPRINT( char *fmt, ... )
+ {
+ va_list args;
+- char *fmt;
+ FILE *fp;
+ char buff[ 300 ];
+
+ if ( DBG ) {
+- va_start( args );
++ va_start( args, fmt );
+ fp = stderr ;
+- fmt = va_arg( args, char * );
+ (void) vsprintf( buff, fmt, args );
+ va_end( args );
+
diff --git a/cad/magic/files/patch-extflat::EFint.h b/cad/magic/files/patch-extflat::EFint.h
new file mode 100644
index 000000000000..546c12c32efa
--- /dev/null
+++ b/cad/magic/files/patch-extflat::EFint.h
@@ -0,0 +1,16 @@
+--- extflat/EFint.h.orig Tue Dec 9 16:34:04 2003
++++ extflat/EFint.h Tue Dec 9 16:33:35 2003
+@@ -21,7 +21,7 @@
+
+ #ifndef _MAGIC
+ int err0 = Need_to_include_misc/magic_header;
+-#endif _MAGIC
++#endif
+
+
+ /*
+@@ -306,3 +306,4 @@
+ extern Void efBuildConnect();
+ extern Void efBuildResistor();
+ extern Void efBuildCap();
++extern Void efReadError(char *fmt, ...);
diff --git a/cad/magic/files/patch-extflat::EFread.c b/cad/magic/files/patch-extflat::EFread.c
new file mode 100644
index 000000000000..0db5c40fd29f
--- /dev/null
+++ b/cad/magic/files/patch-extflat::EFread.c
@@ -0,0 +1,34 @@
+--- extflat/EFread.c.orig Tue Dec 9 16:24:57 2003
++++ extflat/EFread.c Tue Dec 9 16:25:13 2003
+@@ -19,12 +19,12 @@
+
+ #ifndef lint
+ static char rcsid[] = "$Header: /ufs/repository/magic/extflat/EFread.c,v 1.2 2001/01/12 22:12:35 jsolomon Exp $";
+-#endif not lint
++#endif
+
+ #include <stdio.h>
+ #include <ctype.h>
+ #include <stdlib.h>
+-#include <varargs.h>
++#include <stdarg.h>
+ #include "misc/magic.h"
+ #include "utils/geometry.h"
+ #include "utils/hash.h"
+@@ -534,14 +534,12 @@
+ */
+
+ /*VARARGS1*/
+-efReadError(fmt, va_alist)
+- char *fmt;
+- va_dcl
++efReadError(char *fmt, ... )
+ {
+ va_list args;
+
+ (void) printf("%s, line %d: ", efReadFileName, efReadLineNum);
+- va_start(args);
++ va_start(args, fmt);
+ vfprintf(stdout, fmt, args);
+ va_end(args);
+ (void) fflush(stdout);
diff --git a/cad/magic/files/patch-magic::proto.magic b/cad/magic/files/patch-magic::proto.magic
new file mode 100644
index 000000000000..806b3da3b56b
--- /dev/null
+++ b/cad/magic/files/patch-magic::proto.magic
@@ -0,0 +1,161 @@
+--- magic/proto.magic.orig Tue Dec 9 16:50:51 2003
++++ magic/proto.magic Tue Dec 9 16:51:06 2003
+@@ -1,12 +1,4 @@
+-# $(CAD_HOME)/lib/sys/.magic
+-# System wide start up file for magic, defines default macros.
+-#
+-# rcsid $Header: /ufs/repository/magic/magic/proto.magic,v 1.4 2001/09/26 18:24:39 tim Exp $
+-#
+ #ifndef USE_NEW_MACROS
+-###############################################################################
+-# Default .magic macro file (original)
+-###############################################################################
+ echo ""
+ macro s "select"
+ macro S "select more"
+@@ -49,104 +41,75 @@
+ macro " " "tool"
+ macro '' "iroute route -dBox"
+ macro '' "iroute route -dSelection"
+-#else (USE_NEW_MACROS)
+-###############################################################################
+-# Default .magic macro file (new macros)
+-###############################################################################
+-# A key
++#else
+ macro a "select visible"
+ macro A "select more visible"
+ macro '' "select less visible"
+-# B key
+ macro b "box"
+ macro B "findbox"
+-# C key
+ macro c "copy"
+-# D key
+ macro d "delete"
+ macro '' "erase $"
+-# E key
+ macro e "edit"
+-# F key
+ macro f "sideways"
+ macro F "upsidedown"
+-# G key
+ macro g "grid"
+ macro G "grid 2"
+-# I key
+ macro i "select cell"
+ macro I "select more cell"
+ #ifdef XLIB
+ macro Control_XK_i "select less cell"
+ #endif
+-# L key
+ #ifdef USE_READLINE
+ imacro l "label "
+ #endif
+ macro L "shell ls"
+ macro ' ' "redraw"
+-# M key
+ macro m "move"
+ macro M "stretch"
+-# N key
+ macro '' ""
+-# O key
+ macro o "openwindow"
+ macro O "closewindow"
+-# P key
+ #ifdef USE_READLINE
+ imacro p "paint "
+ #endif
+-# Q key
+ #ifdef XLIB
+ macro Control_Shift_XK_q "quit"
+ #endif
+-# R key
+ macro r "clockwise"
+ macro R "clockwise 270"
+ macro '' "clockwise 180"
+-# S key
+ macro s "select"
+ macro S "select more"
+ macro '' "select less"
+ #ifdef XLIB
+ macro Control_Shift_XK_s "undo ; select"
+ #endif
+-# U key
+ macro u "undo"
+ macro U "redo"
+-# V key
+ macro v "view"
+ macro V "xview"
+-# W key
+ macro w "writeall"
+ macro W "writeall force"
+-# X key
+ macro x "expand"
+ macro X "unexpand"
+ macro '' "expand toggle"
+-# Z key
+ macro z "zoom .5"
+ macro Z "zoom 2"
+ macro '' "findbox zoom"
+ #ifdef XLIB
+ macro Control_Shift_XK_z "center"
+ #endif
+-# Question mark
+ macro ? "drc why"
+ macro / "select area; what ; select clear"
+-# Comma key
+ macro , "select clear"
+-# Exclamation mark
+ #ifdef USE_READLINE
+ imacro ! "shell "
+ #endif
+-# Space bar
+ macro " " "tool"
+ #ifdef XLIB
+ macro Shift_XK_space "tool box"
+ macro Control_XK_space "tool wiring"
+-# Arrow keys (X11 versions only)
+ macro XK_Left "scroll l .1"
+ macro Shift_XK_Left "scroll l 1"
+ macro Control_XK_Left "box +l 1"
+@@ -163,8 +126,6 @@
+ macro Shift_XK_Down "scroll d 1"
+ macro Control_XK_Down "box +d 1"
+ macro Control_Shift_XK_Down "box -u 1"
+-# Keypad keys (X11 versions only)
+-# Functions duplicated for use both with Num_Lock ON and OFF
+ macro XK_KP_Delete "box w 0; box h 0"
+ macro XK_KP_0 "box w 4; box h 4"
+ macro XK_KP_Insert "box w 4; box h 4"
+@@ -208,7 +169,6 @@
+ macro XK_KP_Prior "move r 1; move u 1"
+ macro Shift_XK_KP_9 "stretch r 1; stretch u 1"
+ macro XK_9 "stretch r 1; stretch u 1"
+-# Quick macro function keys for scmos tech (X11 versions only)
+ macro XK_F1 "paint ndiff"
+ macro XK_F2 "paint pdiff"
+ macro XK_F3 "paint poly"
+@@ -222,19 +182,13 @@
+ macro XK_F11 "paint pc"
+ macro XK_F12 "paint via"
+ #endif
+-#endif (USE_NEW_MACROS)
++#endif
+ #ifndef NO_PLOT
+-#
+-# additions for plot package
+-#
+ plot parameter spoolCommand "echo use 'lpr -P%s -v -s -JMagic %s' to print plot"
+ plot parameter directory "."
+-#endif (NO_PLOT)
++#endif
+ #ifndef NO_SCHEME_INTERPRETER
+-#
+-# additions for default scm path
+-#
+ define scm-library-path "~cad/lib/magic/scm"
+ load-scm "default.scm"
+ load-scm "layout.scm"
+-#endif (NO_SCHEME_INTERPRETER)
++#endif
diff --git a/cad/magic/files/patch-scmos::extract_template::scmosExt.tech b/cad/magic/files/patch-scmos::extract_template::scmosExt.tech
new file mode 100644
index 000000000000..366ceb9768d0
--- /dev/null
+++ b/cad/magic/files/patch-scmos::extract_template::scmosExt.tech
@@ -0,0 +1,42 @@
+--- scmos/extract_template/scmosExt.tech.orig Tue Dec 9 17:06:27 2003
++++ scmos/extract_template/scmosExt.tech Tue Dec 9 17:05:57 2003
+@@ -10,9 +10,10 @@
+
+
+ /* Make sure local cap defs don't appear before regardless of what cpp does*/
+-#ifdef M1ContactsAct|M1Contacts|PNplusCap|PolyCap|\
+- M1Cap|M2Cap|M3Cap|M1CapNoDiff|NdRes|PdRes|M1Res|\
+- PolyRes|M2Res|M3Res|nothing
++#if defined(M1ContactsAct) || defined(M1Contacts) || defined(PNplusCap) ||\
++ defined(PolyCap) || defined(M1Cap) || defined(M2Cap) || defined(M3Cap) ||\
++ defined(M1CapNoDiff) || defined(NdRes) || defined(PdRes) || defined(M1Res) ||\
++ defined(PolyRes) || defined(M2Res) || defined(M3Res) || defined(nothing)
+ THERE_IS_AN_ERROR_SOME_LOCAL_CAPACITANCE_DEFINITIONS_HAVE_ALREADY_BEEN_DEFINED
+ #endif
+
+@@ -43,14 +44,14 @@
+ #define sideOverlap(l1,sep,l2,cap,shield)\
+ sideoverlap l1 sep l2 cap shield
+
+-#else /* V5 */
++#else
+
+ #define planeOrder(l,ord)
+ #define noplaneOrdering
+ #define sideOverlap(l1,sep,l2,cap,shield)\
+ sideoverlap l1 sep l2 cap
+
+-#endif /* V5 */
++#endif
+
+
+ #define extForSpice
+@@ -69,7 +70,7 @@
+ #include "scmosExt060_orb.tech"
+ #include "scmosExt34.tech"
+ #include "scmosExt26b.tech"
+-#endif /* STANDARD */
++#endif
+
+ #if defined(TIGHTMETAL)
+ #include "scmosExt34.tech"
diff --git a/cad/magic/files/patch-tech::tech.c b/cad/magic/files/patch-tech::tech.c
new file mode 100644
index 000000000000..445f8eaf4e7d
--- /dev/null
+++ b/cad/magic/files/patch-tech::tech.c
@@ -0,0 +1,54 @@
+--- tech/tech.c.orig Tue Dec 9 16:40:02 2003
++++ tech/tech.c Tue Dec 9 16:40:18 2003
+@@ -18,7 +18,7 @@
+
+ #ifndef lint
+ static char rcsid[] = "$Header: /ufs/repository/magic/tech/tech.c,v 1.3 2001/01/12 22:13:25 jsolomon Exp $";
+-#endif not lint
++#endif
+
+ #include <stdio.h>
+ #include <ctype.h>
+@@ -31,8 +31,8 @@
+ #include "utils/malloc.h"
+
+ #ifndef NO_VARARGS
+-#include <varargs.h>
+-#endif NO_VARARGS
++#include <stdarg.h>
++#endif
+
+ global char *TechDefault = NULL;
+
+@@ -415,19 +415,16 @@
+ /*VARARGS0*/
+
+ void
+-TechError(va_alist)
+-va_dcl
++TechError(char *fmt, ...)
+ {
+ va_list args;
+- char *fmt;
+
+ TechPrintLine();
+- va_start(args);
+- fmt = va_arg(args, char *);
++ va_start(args, fmt);
+ (void) GrVfprintf(stderr, fmt, args);
+ va_end(args);
+ }
+-#else NO_VARARGS
++#else
+
+ /*VARARGS0*/
+
+@@ -440,7 +437,7 @@
+ (void) GrFprintf(stderr, format, a1, a2, a3, a4, a5, a6, a7, a8, a9,
+ a10, a11, a12, a13, a14, a15, a16, a17, a18, a19, a20);
+ }
+-#endif NO_VARARGS
++#endif
+
+ /* ================== Functions local to this module ================== */
+
diff --git a/cad/magic/files/patch-tech::tech.h b/cad/magic/files/patch-tech::tech.h
new file mode 100644
index 000000000000..27155e4d1788
--- /dev/null
+++ b/cad/magic/files/patch-tech::tech.h
@@ -0,0 +1,8 @@
+--- tech/tech.h.orig Tue Dec 9 16:42:58 2003
++++ tech/tech.h Tue Dec 9 16:43:01 2003
+@@ -23,4 +23,4 @@
+ /* ----------------- Exported variables and procedures ---------------- */
+
+ extern char *TechDefault; /* Name of default technology */
+-extern void TechError();
++extern void TechError(char *fmt, ...);
diff --git a/cad/magic/files/patch-textio::textio.h b/cad/magic/files/patch-textio::textio.h
new file mode 100644
index 000000000000..2c835c7f45a6
--- /dev/null
+++ b/cad/magic/files/patch-textio::textio.h
@@ -0,0 +1,15 @@
+--- textio/textio.h.orig Tue Dec 9 16:44:37 2003
++++ textio/textio.h Tue Dec 9 16:56:52 2003
+@@ -29,10 +29,10 @@
+ #endif
+
+ /* printing procedures */
+-extern void TxPrintf();
++/* extern void TxPrintf(); */
+ extern bool TxPrintOn(); /* enables TxPrintf output */
+ extern bool TxPrintOff(); /* disables TxPrintf output */
+-extern void TxError();
++/* extern void TxError(); */
+ extern void TxFlush();
+ extern void TxVisChar();
+ extern void TxUseMore();
diff --git a/cad/magic/files/patch-textio::textioInt.h b/cad/magic/files/patch-textio::textioInt.h
new file mode 100644
index 000000000000..f459d515cd6c
--- /dev/null
+++ b/cad/magic/files/patch-textio::textioInt.h
@@ -0,0 +1,12 @@
+--- textio/textioInt.h.orig Tue Dec 9 16:41:17 2003
++++ textio/textioInt.h Tue Dec 9 16:41:29 2003
+@@ -53,7 +53,7 @@
+ struct sgttyb tx_i_sgtty;
+ struct tchars tx_i_tchars;
+ } txTermState;
+-#endif SYSV
++#endif
+
+ extern int TxGetInputEvent();
+-extern void txFprintfBasic();
++extern void txFprintfBasic(FILE *f, char *fmt, ... );
diff --git a/cad/magic/files/patch-textio::txOutput.c b/cad/magic/files/patch-textio::txOutput.c
new file mode 100644
index 000000000000..d6ba3477c1e2
--- /dev/null
+++ b/cad/magic/files/patch-textio::txOutput.c
@@ -0,0 +1,178 @@
+--- textio/txOutput.c.orig Tue Dec 9 16:38:35 2003
++++ textio/txOutput.c Tue Dec 9 16:39:01 2003
+@@ -18,7 +18,7 @@
+
+ #ifndef lint
+ static char rcsid[] = "$Header: /ufs/repository/magic/textio/txOutput.c,v 1.4 2001/02/21 15:52:52 tim Exp $";
+-#endif not lint
++#endif
+
+ #include <stdio.h>
+ #ifndef SYSV
+@@ -26,7 +26,7 @@
+ #include <strings.h>
+ #else
+ #include <string.h>
+-#endif SYSV
++#endif
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include "misc/magsgtty.h"
+@@ -42,8 +42,8 @@
+ #include "utils/malloc.h"
+
+ #ifndef NO_VARARGS
+-#include <varargs.h>
+-#endif NO_VARARGS
++#include <stdarg.h>
++#endif
+
+ /* When a pipe has been opened to "more", the following variables
+ * keep track of the file and process. The "TxMoreFile" variable is
+@@ -82,20 +82,15 @@
+ /*VARARGS0*/
+
+ void
+-txFprintfBasic(va_alist)
+-va_dcl
++txFprintfBasic(FILE *f, char *fmt, ...)
+ {
+ va_list args;
+- char *fmt;
+- FILE *f;
+
+- va_start(args);
+- f = va_arg(args, FILE *);
+- fmt = va_arg(args, char *);
++ va_start(args, fmt);
+ (void) GrVfprintf(f, fmt, args);
+ va_end(args);
+ }
+-#else NO_VARARGS
++#else
+
+ /*VARARGS0*/
+
+@@ -107,7 +102,7 @@
+ (void) GrFprintf(f, format, a1, a2, a3, a4, a5, a6, a7, a8, a9,
+ a10, a11, a12, a13, a14, a15, a16, a17, a18, a19, a20);
+ }
+-#endif NO_VARARGS
++#endif
+
+
+ /*
+@@ -135,11 +130,9 @@
+ /*VARARGS0*/
+
+ void
+-TxPrintf(va_alist)
+-va_dcl
++TxPrintf(char *fmt, ...)
+ {
+ va_list args;
+- char *fmt;
+ FILE *f;
+
+ if (txPrintFlag)
+@@ -156,16 +149,14 @@
+ if (txHavePrompt)
+ {
+ TxUnPrompt();
+- va_start(args);
+- fmt = va_arg(args, char *);
++ va_start(args, fmt);
+ (void) GrVfprintf(f, fmt, args);
+ va_end(args);
+ TxPrompt();
+ }
+ else
+ {
+- va_start(args);
+- fmt = va_arg(args, char *);
++ va_start(args, fmt);
+ (void) GrVfprintf(f, fmt, args);
+ va_end(args);
+ }
+@@ -173,7 +164,7 @@
+ return;
+ }
+ }
+-#else NO_VARARGS
++#else
+
+ /*VARARGS1*/
+
+@@ -212,7 +203,7 @@
+ return;
+ }
+ }
+-#endif NO_VARARGS
++#endif
+
+
+ /*
+@@ -306,11 +297,9 @@
+ #ifndef NO_VARARGS
+
+ void
+-TxError(va_alist)
+-va_dcl
++TxError(char *fmt, ...)
+ {
+ va_list args;
+- char *fmt;
+ FILE *f;
+
+ (void) fflush(stdout);
+@@ -321,22 +310,20 @@
+ if (txHavePrompt)
+ {
+ TxUnPrompt();
+- va_start(args);
+- fmt = va_arg(args, char *);
++ va_start(args, fmt);
+ (void) GrVfprintf(f, fmt, args);
+ va_end(args);
+ TxPrompt();
+ }
+ else {
+- va_start(args);
+- fmt = va_arg(args, char *);
++ va_start(args, fmt);
+ (void) GrVfprintf(f, fmt, args);
+ va_end(args);
+ }
+ (void) fflush(stderr);
+ }
+
+-#else NO_VARARGS
++#else
+
+ /*VARARGS1*/
+
+@@ -364,7 +351,7 @@
+ }
+ (void) fflush(stderr);
+ }
+-#endif NO_VARARGS
++#endif
+
+
+ /*
+@@ -482,7 +469,7 @@
+ int status;
+ #else
+ union wait status;
+-#endif SYSV
++#endif
+ */
+ /* TxMoreFile may be NULL if the "more" executable was not found */
+ if (TxMoreFile == NULL) return;
+@@ -532,5 +519,5 @@
+
+ return (ferror(iop) ? EOF : len);
+ }
+-#endif NEED_VFPRINTF
++#endif
+
diff --git a/cad/magic/files/patch-utils::LIBtextio.c b/cad/magic/files/patch-utils::LIBtextio.c
new file mode 100644
index 000000000000..b04ee561a209
--- /dev/null
+++ b/cad/magic/files/patch-utils::LIBtextio.c
@@ -0,0 +1,51 @@
+--- utils/LIBtextio.c.orig Tue Dec 9 16:52:38 2003
++++ utils/LIBtextio.c Tue Dec 9 16:52:53 2003
+@@ -19,10 +19,10 @@
+
+ #ifndef lint
+ static char rcsid[] = "$Header: /ufs/repository/magic/utils/LIBtextio.c,v 1.1.1.1 2000/03/29 18:35:16 rajit Exp $";
+-#endif not lint
++#endif
+
+ #include <stdio.h>
+-#include <varargs.h>
++#include <stdarg.h>
+
+ /*
+ * ----------------------------------------------------------------------------
+@@ -65,15 +65,13 @@
+ */
+
+ /*VARARGS*/
+-TxError(fmt, va_alist)
+- char *fmt;
+- va_dcl
++TxError(char *fmt, ... )
+ {
+ va_list ap;
+
+ (void) fflush(stdout);
+ (void) fflush(stderr);
+- va_start(ap);
++ va_start(ap, fmt);
+ vfprintf(stderr, fmt, ap);
+ va_end(ap);
+ (void) fflush(stderr);
+@@ -96,15 +94,13 @@
+ */
+
+ /*VARARGS*/
+-TxPrintf(fmt, va_alist)
+- char *fmt;
+- va_dcl
++TxPrintf(char *fmt, ... )
+ {
+ va_list ap;
+
+ (void) fflush(stderr);
+ (void) fflush(stdout);
+- va_start(ap);
++ va_start(ap, fmt);
+ vfprintf(stdout, fmt, ap);
+ va_end(ap);
+ (void) fflush(stdout);