aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2005-01-17 03:10:52 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2005-01-17 03:10:52 +0000
commitfbfa025a9f7868ebb97703150a47633a9f4a1f5c (patch)
tree6926956a9b518acaa03e54978e18261c6c3aafab /cad
parenta1df6f5954290a3d7b411442b6b2d23dd261977d (diff)
downloadports-fbfa025a9f7868ebb97703150a47633a9f4a1f5c.tar.gz
ports-fbfa025a9f7868ebb97703150a47633a9f4a1f5c.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/pythoncad/Makefile12
-rw-r--r--cad/pythoncad/distinfo4
-rw-r--r--cad/pythoncad/pkg-plist268
3 files changed, 11 insertions, 273 deletions
diff --git a/cad/pythoncad/Makefile b/cad/pythoncad/Makefile
index b0d08436078a..4aca4b3d154d 100644
--- a/cad/pythoncad/Makefile
+++ b/cad/pythoncad/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= pythoncad
-PORTVERSION= 16
-PORTREVISION= 1
+PORTVERSION= 21
+PORTREVISION= 0
CATEGORIES= cad
MASTER_SITES= http://www.pythoncad.org/releases/
DISTNAME= PythonCAD-DS1-R${PORTVERSION}
@@ -22,7 +22,13 @@ USE_PYTHON= 2.2+
USE_PYDISTUTILS= yes
USE_BZIP2= yes
+PLIST_FILES= bin/gtkpycad
+
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/gtkpycad.py ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/gtkpycad.py ${PREFIX}/bin/gtkpycad
+ @${FIND} ${PYTHON_SITELIBDIR}/PythonCAD* ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PYTHON_SITELIBDIR}/PythonCAD* -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.include <bsd.port.mk>
diff --git a/cad/pythoncad/distinfo b/cad/pythoncad/distinfo
index ecf250159b81..54b8e3a5b382 100644
--- a/cad/pythoncad/distinfo
+++ b/cad/pythoncad/distinfo
@@ -1,2 +1,2 @@
-MD5 (PythonCAD-DS1-R16.tar.bz2) = 66a832ab278f2068ec5b0d26cb8438a1
-SIZE (PythonCAD-DS1-R16.tar.bz2) = 292329
+MD5 (PythonCAD-DS1-R21.tar.bz2) = c047b9791c696d39d69c6ddbf04c1f92
+SIZE (PythonCAD-DS1-R21.tar.bz2) = 318812
diff --git a/cad/pythoncad/pkg-plist b/cad/pythoncad/pkg-plist
deleted file mode 100644
index a57d25109720..000000000000
--- a/cad/pythoncad/pkg-plist
+++ /dev/null
@@ -1,268 +0,0 @@
-bin/gtkpycad.py
-%%PYTHON_SITELIBDIR%%/PythonCAD.pth
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/__init__.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/__init__.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/__init__.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/acline.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/acline.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/acline.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/arc.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/arc.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/arc.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/baseobject.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/baseobject.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/baseobject.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/bindump.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/bindump.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/bindump.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/ccircle.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/ccircle.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/ccircle.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/circle.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/circle.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/circle.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/cline.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/cline.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/cline.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/color.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/color.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/color.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/conobject.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/conobject.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/conobject.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/delete.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/delete.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/delete.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dimension.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dimension.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dimension.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dimtrees.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dimtrees.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dimtrees.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dwg12.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dwg12.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dwg12.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dwg1314.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dwg1314.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dwg1314.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dwg15.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dwg15.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dwg15.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dwgbase.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dwgbase.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dwgbase.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dwgutil.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dwgutil.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dwgutil.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dxf.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dxf.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/dxf.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/ellipse.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/ellipse.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/ellipse.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/entity.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/entity.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/entity.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/fileio.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/fileio.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/fileio.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/globals.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/globals.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/globals.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/graphicobject.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/graphicobject.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/graphicobject.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/hatch.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/hatch.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/hatch.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/hcline.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/hcline.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/hcline.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/image.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/image.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/image.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/imageio.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/imageio.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/imageio.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/intersections.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/intersections.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/intersections.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/keywords.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/keywords.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/keywords.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/layer.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/layer.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/layer.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/leader.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/leader.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/leader.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/linetype.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/linetype.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/linetype.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/logger.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/logger.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/logger.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/maptree.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/maptree.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/maptree.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/menus.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/menus.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/menus.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/message.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/message.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/message.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/mirror.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/mirror.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/mirror.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/move.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/move.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/move.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/nurbs.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/nurbs.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/nurbs.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/options.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/options.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/options.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/point.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/point.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/point.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/polyline.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/polyline.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/polyline.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/preferences.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/preferences.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/preferences.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/prompt.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/prompt.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/prompt.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/quadtree.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/quadtree.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/quadtree.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/segjoint.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/segjoint.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/segjoint.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/segment.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/segment.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/segment.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/selections.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/selections.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/selections.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/split.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/split.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/split.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/style.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/style.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/style.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/tangent.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/tangent.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/tangent.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/text.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/text.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/text.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/tolerance.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/tolerance.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/tolerance.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/tools.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/tools.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/tools.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/transfer.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/transfer.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/transfer.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/tree.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/tree.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/tree.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/units.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/units.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/units.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/util.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/util.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/util.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/vcline.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/vcline.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Generic/vcline.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/AppController.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/AppController.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/AppController.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CADView.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CADView.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CADView.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaConobjs.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaConobjs.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaConobjs.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaDimensions.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaDimensions.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaDimensions.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaEntities.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaEntities.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaEntities.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaModify.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaModify.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaModify.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaPrompt.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaPrompt.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaPrompt.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaText.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaText.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/CocoaText.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/Globals.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/Globals.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/Globals.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/ImageDocument.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/ImageDocument.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/ImageDocument.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/ImageWindowController.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/ImageWindowController.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/ImageWindowController.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/LayerView.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/LayerView.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/LayerView.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/__init__.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/__init__.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa/__init__.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/__init__.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/__init__.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/__init__.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkconobjs.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkconobjs.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkconobjs.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkdimension.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkdimension.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkdimension.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkdimprefs.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkdimprefs.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkdimprefs.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkedit.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkedit.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkedit.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkentities.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkentities.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkentities.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkimage.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkimage.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkimage.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtklayers.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtklayers.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtklayers.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkmenus.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkmenus.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkmenus.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkmirror.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkmirror.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkmirror.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkmodify.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkmodify.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkmodify.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkprefs.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkprefs.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtkprefs.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtktext.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtktext.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk/gtktext.pyo
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/__init__.py
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/__init__.pyc
-%%PYTHON_SITELIBDIR%%/PythonCAD/Interface/__init__.pyo
-@dirrm %%PYTHON_SITELIBDIR%%/PythonCAD/Generic
-@dirrm %%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Cocoa
-@dirrm %%PYTHON_SITELIBDIR%%/PythonCAD/Interface/Gtk
-@dirrm %%PYTHON_SITELIBDIR%%/PythonCAD/Interface
-@dirrm %%PYTHON_SITELIBDIR%%/PythonCAD