aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-01-06 21:30:31 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-01-06 21:30:31 +0000
commitf6ceca63504679b05ea4fc24a195a301e2303d1f (patch)
treea6e116c43545a3682fe63db4bdca54e6fb24567e /cad
parent78a4d3df994a008dd752fd82307fd6d31aa18f3a (diff)
downloadports-f6ceca63504679b05ea4fc24a195a301e2303d1f.tar.gz
ports-f6ceca63504679b05ea4fc24a195a301e2303d1f.zip
Update Qt5 ports to 5.9.3.
This took quite a lot of time because Qt's own build system underwent several changes in 5.8.0 that took a while to adapt to. And, of course, qt5-webengine is a behemoth that we need to patch like crazy due to its bundling of Chromium. In fact, most of the Chromium patches in qt5-webengine have been imported with no changes from www/chromium@433510 ("www/chromium: update to 56.0.2924.87"). New port: accessibility/qt5-speech Bigger changes to Qt5 ports we had to make: - Qt now allows using a configure.json file to define configuration options and specify configuration checks that can be done when qmake is invoked. However, configure.json checks done in a subdirectory only propagates to subdirectories, and checks elsewhere will fail if all .pro files are being parsed at once (i.e. qmake -recursive), so several ports had to switch to USES=qmake:norecursive along with manual additional qmake invocations in subdirectories in order to work. It's been mentioned in a few places such as Qt's bug tracker that qmake's recursive mode is pretty much deprecated, so we might switch to non-recursive mode by default in the future. - Uses/qmake.mk: Introduce QMAKE_CONFIGURE_ARGS. qmake now accepts arbitrary options such as '-foo' and '-no-bar' at the end of the command-line. They can be specified in QMAKE_CONFIGURE_ARGS. - graphics/qt5-wayland: The port can only be built if graphics/mesa-libs is built with the WAYLAND option, so a corresponding option (off by default) was added to the port. - misc/qt5-doc: Switch to a pre-built documentation tarball. The existing port was not working with Qt 5.9. Instead of trying to fix it, switch to what Gentoo does and fetch a tarball that already contains all documentation so that we do not have to build anything at all. The tarball's name and location in download.qt.io look a bit weird, but it seems to work fine. - www/qt5-webengine: Use binutils from ports, Chromium's GN build system generates a build.ninja that uses ar(1) with the @file syntax that is not supported by BSD ar, so we need to use GNU ar from binutils. - x11-toolkits/qt5-declarative-render2d: This port was merged into the main Qt Declarative repository upstream, and into x11-toolkits/qt5-quick in the ports tree. Changes to other ports we had to make: - biology/ugene: Drop a '#define point "."' that is not present in more recent versions of the port. Defining a macro with such a common name causes build issues with Qt 5.9, which uses |point| as an argument name in methods. - cad/qelectrotech: Fix plist with Qt 5.9. Directories are no longer installed with `cp -f -R', but rather `qmake install qinstall', which does not install %%DATADIR%%/elements/10_electric/20_manufacturers_articles/bosch_rexroth/.directory That's a local file that should not even have been part of the tarball anyway. - chinese/gcin-qt5: Add additional private Qt directories (which should not be used in the first place) to get the port to build with Qt 5.9. - devel/qtcreator: Fix plist with Qt 5.9. Something changed in qdoc and some test classes no longer generate documentation files. - security/keepassx-devel: Import a patch sent upstream almost a year ago to fix the build with Qt 5.9. Thanks to antoine for the exp-run, and tcberner and Laurent Cimon <laurent@nuxi.ca> for landing changes in our qt-5.9 branch. PR: 224849
Notes
Notes: svn path=/head/; revision=458293
Diffstat (limited to 'cad')
-rw-r--r--cad/qelectrotech/Makefile2
-rw-r--r--cad/qelectrotech/pkg-plist1
2 files changed, 1 insertions, 2 deletions
diff --git a/cad/qelectrotech/Makefile b/cad/qelectrotech/Makefile
index 95c885d63973..612da0be1a23 100644
--- a/cad/qelectrotech/Makefile
+++ b/cad/qelectrotech/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qelectrotech
PORTVERSION= 0.5
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= http://download.tuxfamily.org/qet/tags/20151127/
diff --git a/cad/qelectrotech/pkg-plist b/cad/qelectrotech/pkg-plist
index ff46afd03e13..cf6c2f28dd0d 100644
--- a/cad/qelectrotech/pkg-plist
+++ b/cad/qelectrotech/pkg-plist
@@ -1025,7 +1025,6 @@ share/mimelnk/application/x-qet-titleblock.desktop
%%DATADIR%%/elements/10_electric/20_manufacturers_articles/beka/beka_2806_b_2_0_1_2_01_000.elmt
%%DATADIR%%/elements/10_electric/20_manufacturers_articles/beka/beka_2806_b_2_0_1_4_01_000.elmt
%%DATADIR%%/elements/10_electric/20_manufacturers_articles/beka/qet_directory
-%%DATADIR%%/elements/10_electric/20_manufacturers_articles/bosch_rexroth/.directory
%%DATADIR%%/elements/10_electric/20_manufacturers_articles/bosch_rexroth/bosch_rexroth_cdb02.1b-et-ec-ec-nn-s4-s4-nn-nn-fw.elmt
%%DATADIR%%/elements/10_electric/20_manufacturers_articles/bosch_rexroth/bosch_rexroth_hmd01.1n-w0036-a-07-nnnn.elmt
%%DATADIR%%/elements/10_electric/20_manufacturers_articles/bosch_rexroth/bosch_rexroth_hmv01.1r-w0018-a-07-nnnn.elmt