aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2009-08-02 19:36:34 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2009-08-02 19:36:34 +0000
commit789d75c728ef23566a07bf5b9bc2190bf34ff4f1 (patch)
treedc7540d42fa2d5d7c1c74515e3bdbf6ab842cd17 /cad
parentd1a9e827c98542eb35619dffa314cba50fb08b58 (diff)
downloadports-789d75c728ef23566a07bf5b9bc2190bf34ff4f1.tar.gz
ports-789d75c728ef23566a07bf5b9bc2190bf34ff4f1.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/brlcad/Makefile2
-rw-r--r--cad/fandango/Makefile2
-rw-r--r--cad/freehdl/Makefile2
-rw-r--r--cad/gerbv/Makefile2
-rw-r--r--cad/gtkwave/Makefile2
-rw-r--r--cad/opencascade/Makefile2
-rw-r--r--cad/tclspice/Makefile9
7 files changed, 11 insertions, 10 deletions
diff --git a/cad/brlcad/Makefile b/cad/brlcad/Makefile
index a75886b73a8b..d2f260fe9602 100644
--- a/cad/brlcad/Makefile
+++ b/cad/brlcad/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/tnt/jama_lu.h:${PORTSDIR}/math/jama
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
rle.1:${PORTSDIR}/graphics/urt
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_BZIP2= yes
USE_GL= gl
USE_XORG= x11 xt xi xproto xext inputproto
diff --git a/cad/fandango/Makefile b/cad/fandango/Makefile
index 71fada28ba61..c0a5b84bc706 100644
--- a/cad/fandango/Makefile
+++ b/cad/fandango/Makefile
@@ -23,7 +23,7 @@ USE_GL= yes
USE_GNOME= gnometarget
USE_GETTEXT= yes
USE_KDEBASE_VER=3
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
LDFLAGS+= -lGL
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
INSTALLS_ICONS= yes
diff --git a/cad/freehdl/Makefile b/cad/freehdl/Makefile
index 60201b2e4800..7617381be596 100644
--- a/cad/freehdl/Makefile
+++ b/cad/freehdl/Makefile
@@ -18,7 +18,7 @@ USE_LDCONFIG= yes
USE_PERL5= yes
USE_GNOME= gnomehack \
pkgconfig
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
HAS_CONFIGURE= yes
MAN1= freehdl-config.1 \
diff --git a/cad/gerbv/Makefile b/cad/gerbv/Makefile
index 90ecd39c06ba..4e8dcc14beb2 100644
--- a/cad/gerbv/Makefile
+++ b/cad/gerbv/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A Free Gerber Viewer
USE_GNOME= desktopfileutils gnomehack gtk20
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
diff --git a/cad/gtkwave/Makefile b/cad/gtkwave/Makefile
index 703f97e29376..d780839cae4d 100644
--- a/cad/gtkwave/Makefile
+++ b/cad/gtkwave/Makefile
@@ -19,7 +19,7 @@ COMMENT= Electronic Waveform Viewer
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GNOME= gtk12
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index f9a58311ab3d..1a9d60853770 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -50,7 +50,7 @@ LIB_TCLX= ${LOCALBASE}/lib/tclx${TCL_VER}/libtclx${TCL_VER}.so
PATCH_WRKSRC= ${WRKDIR}/OpenCASCADE${PORTVERSION}.0
WRKSRC= ${PATCH_WRKSRC}/ros
REINPLACE_ARGS= -i ""
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
LIBTOOLFILES= ros/configure
CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
--with-tk=${TK_LIBDIR} \
diff --git a/cad/tclspice/Makefile b/cad/tclspice/Makefile
index 69e6ca5100d0..22a322a7b35b 100644
--- a/cad/tclspice/Makefile
+++ b/cad/tclspice/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tclspice
PORTVERSION= 0.2.18
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= cad
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tclspice
@@ -17,10 +17,11 @@ COMMENT= Improved version on SPICE3 suite with TCL scripting features
BUILD_DEPENDS= bltwish:${PORTSDIR}/x11-toolkits/blt \
${LOCALBASE}/lib/libtclreadline.so:${PORTSDIR}/devel/tclreadline
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= bltwish:${PORTSDIR}/x11-toolkits/blt \
+ ${LOCALBASE}/lib/libtclreadline.so:${PORTSDIR}/devel/tclreadline
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_AUTOTOOLS= aclocal:19 automake:19 autoconf:262 libtool:15
+USE_AUTOTOOLS= aclocal:19 automake:19 autoconf:262 libtool:22
AUTOMAKE_ARGS= -c -a
USE_GMAKE= yes
ALL_TARGET= tcl
@@ -34,7 +35,7 @@ OPTIONS= EXPERIMENTAL "Enable experimental features" on \
CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.4
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include ${CFLAGS} -fPIC" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib -ltcl84 -lBLT24"
ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
WISH= ${LOCALBASE}/bin/wish8.4