aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-05-14 14:34:33 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-05-14 14:34:33 +0000
commitb33f26818dd63b549510f4132f9524fe18a0c907 (patch)
treea4448085f053432ab0004ca924d5e126eb38a25b /cad
parent1c92957e84167297926d5af8e17872fa6767b892 (diff)
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/tkgate/Makefile1
-rw-r--r--cad/tkgate/files/patch-src-tkgate_tkgate.c12
2 files changed, 10 insertions, 3 deletions
diff --git a/cad/tkgate/Makefile b/cad/tkgate/Makefile
index 164451dcb29c..0e6328a8b4e9 100644
--- a/cad/tkgate/Makefile
+++ b/cad/tkgate/Makefile
@@ -15,7 +15,6 @@ LICENSE= GPLv2 # (or later)
GNU_CONFIGURE= yes
USES= iconv
USE_TK= 84+
-INVALID_TK_VER= 86
MAKE_JOBS_SAFE= yes
MAN1= gmac.1 tkgate.1 verga.1
diff --git a/cad/tkgate/files/patch-src-tkgate_tkgate.c b/cad/tkgate/files/patch-src-tkgate_tkgate.c
index 04f32dae33af..35d1b00698d3 100644
--- a/cad/tkgate/files/patch-src-tkgate_tkgate.c
+++ b/cad/tkgate/files/patch-src-tkgate_tkgate.c
@@ -1,5 +1,5 @@
---- src/tkgate/tkgate.c.orig 2013-05-14 15:24:54.000000000 +0200
-+++ src/tkgate/tkgate.c 2013-05-14 15:25:15.000000000 +0200
+--- src/tkgate/tkgate.c.orig 2009-03-18 10:23:18.000000000 +0100
++++ src/tkgate/tkgate.c 2013-05-14 16:31:17.000000000 +0200
@@ -1034,7 +1034,7 @@
*/
r = Tk_Init(tcl);
@@ -9,3 +9,11 @@
fprintf(stderr,"Perhaps you could try setting the environment variable TK_LIBRARY\n");
fprintf(stderr,"to the directory in which tk init files can be found. You can also\n");
fprintf(stderr,"set TK_LIBRARY in options.h.\n");
+@@ -1097,6 +1097,7 @@
+ *****************************************************************************/
+ int Tkgate_Init(Tcl_Interp *tcl)
+ {
++ Tk_Init(tcl);
+ Tcl_CreateCommand(tcl,"tkgate_main",tkgate_main,0,0);
+ Tcl_CreateCommand(tcl,"tkgate_starttk",tkgate_starttk,0,0);
+ Tcl_CreateCommand(tcl,"tkgate_posttk",tkgate_posttk,0,0);