aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2015-12-01 19:35:50 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2015-12-01 19:35:50 +0000
commit04c358744567dbbcd0f730d01e74c04e229a6d64 (patch)
tree03668ec79268cbf1ac004c321328d60945eee3e1 /cad
parentc2462183c558ac222bacff39fef2ba8ec963b8cd (diff)
downloadports-04c358744567dbbcd0f730d01e74c04e229a6d64.tar.gz
ports-04c358744567dbbcd0f730d01e74c04e229a6d64.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/opencascade/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index 3e0cab3aecdc..4005013e6da1 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -3,6 +3,7 @@
PORTNAME= opencascade
PORTVERSION= 6.9.1
+PORTREVISION= 1
CATEGORIES= cad science
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= thierry
@@ -29,7 +30,7 @@ SHEBANG_FILES= adm/templates/env.sh.in adm/templates/draw.sh \
adm/templates/custom.sh.in adm/templates/custom.sh.main \
adm/start.tcl draw.sh xcode.sh env.sh custom.sh.in \
gendoc codeblocks.sh
-VTKVER= 6.1
+VTKVER= 6.2
OPTIONS_DEFINE= VIS DOCS
VIS_DESC= Build Visualizazion module (requires OpenGL, freetype, ftgl and gl2ps)
@@ -98,6 +99,10 @@ pre-configure:
${REINPLACE_CMD} -e 's|tcl8.6|tcl${TCL_VER:C|\.||}|;s|tk8.6|tk${TK_VER:C|\.||}|' \
${WRKSRC}/adm/cmake/${mod}/CMakeLists.txt
.endfor
+.for mod in TKIVtk TKIVtkDraw
+ ${REINPLACE_CMD} -E 's/(vtk[[:alnum:]]+)\-6.1/\1\-${VTKVER}/' \
+ ${WRKSRC}/adm/cmake/${mod}/CMakeLists.txt
+.endfor
.for es in env.sh adm/templates/env.sh.in
${REINPLACE_CMD} -e 's|lin|bsd|' ${WRKSRC}/${es}
.endfor