aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
commit5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /cad
parent9c92503171817f96d944009b9ea88d3c083c9a45 (diff)
downloadports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.tar.gz
ports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/kicad/Makefile2
-rw-r--r--cad/opencascade/Makefile2
-rw-r--r--cad/openvsp/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/cad/kicad/Makefile b/cad/kicad/Makefile
index ff0aca5f42d4..d06d1a29c293 100644
--- a/cad/kicad/Makefile
+++ b/cad/kicad/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= xpdf:graphics/xpdf
CONFLICTS= kicad-devel*
-USES= cmake compiler:gcc-c++11-lib desktop-file-utils dos2unix \
+USES= cmake:noninja compiler:gcc-c++11-lib desktop-file-utils dos2unix \
shared-mime-info tar:xz
DOS2UNIX_GLOB= *.cmake sch_bus_entry.h sch_line.h sch_no_connect.h
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index b715090cc6e0..20d3d23bf7b0 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= bash:shells/bash
# Check ${WRKSRC}/dox/overview/Overview.md
# and ${WRKSRC}/dox/dev_guides/building
-USES= alias:10 bison cmake compiler:c++11-lib dos2unix gmake \
+USES= alias:10 bison cmake compiler:c++11-lib dos2unix \
shebangfix tk tar:tgz
USE_XORG= xmu
DOS2UNIX_FILES= adm/templates/*
diff --git a/cad/openvsp/Makefile b/cad/openvsp/Makefile
index e5b2ff66c3cb..ca4ad55c44e2 100644
--- a/cad/openvsp/Makefile
+++ b/cad/openvsp/Makefile
@@ -32,7 +32,7 @@ GH_ACCOUNT= ${GH_PROJECT}
CMAKE_SOURCE_PATH= ${WRKSRC}/SuperProject
CMAKE_INSTALL_PREFIX= ${STAGEDIR}${PREFIX}
-USES= cmake:outsource compiler:gcc-c++11-lib jpeg
+USES= cmake:outsource,noninja compiler:gcc-c++11-lib jpeg
CMAKE_ARGS= -DVSP_USE_SYSTEM_CMINPACK:BOOLEAN=yes \
-DVSP_USE_SYSTEM_CPPTEST:BOOLEAN=yes \