aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2019-03-15 13:58:32 +0000
committerHiroki Sato <hrs@FreeBSD.org>2019-03-15 13:58:32 +0000
commit6109c93cfbd09330ff8bfc9f5f5cf6278f5689cf (patch)
treec5df5b03bee61e8c43588996b2571c1850392919 /cad
parent476f120c3d7b9ee700bbe9236d55fca3b85f00d7 (diff)
downloadports-6109c93cfbd09330ff8bfc9f5f5cf6278f5689cf.tar.gz
ports-6109c93cfbd09330ff8bfc9f5f5cf6278f5689cf.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/Makefile1
-rw-r--r--cad/py-phidl/Makefile21
-rw-r--r--cad/py-phidl/distinfo3
-rw-r--r--cad/py-phidl/pkg-descr13
4 files changed, 38 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index ecadeb2cc0d9..1f0fe8a631c7 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -80,6 +80,7 @@
SUBDIR += pdnmesh
SUBDIR += py-gdspy
SUBDIR += py-lcapy
+ SUBDIR += py-phidl
SUBDIR += py-pycam
SUBDIR += py-pyfda
SUBDIR += python-gdsii
diff --git a/cad/py-phidl/Makefile b/cad/py-phidl/Makefile
new file mode 100644
index 000000000000..1b218ffc18c4
--- /dev/null
+++ b/cad/py-phidl/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= phidl
+PORTVERSION= 1.0.1
+CATEGORIES= cad python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= GDS-based CAD tool for photonic and superconducting circuits
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gdspy>0:cad/py-gdspy@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+USE_GITHUB= yes
+GH_ACCOUNT= amccaugh
+
+.include <bsd.port.mk>
diff --git a/cad/py-phidl/distinfo b/cad/py-phidl/distinfo
new file mode 100644
index 000000000000..8d794493f207
--- /dev/null
+++ b/cad/py-phidl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1552656620
+SHA256 (amccaugh-phidl-1.0.1_GH0.tar.gz) = cc1e9a1c0a015828b4069753b3424ee89c0cd340dd541e6b00833287635d39af
+SIZE (amccaugh-phidl-1.0.1_GH0.tar.gz) = 511067
diff --git a/cad/py-phidl/pkg-descr b/cad/py-phidl/pkg-descr
new file mode 100644
index 000000000000..0443e5dc6bcd
--- /dev/null
+++ b/cad/py-phidl/pkg-descr
@@ -0,0 +1,13 @@
+PHIDL is an open-source GDS-based CAD tool for Python 2 and 3 which extends
+and simplifies the excellent gdspy. It strives to simplify GDSII geometry
+creation by making the design process layout-driven, rather than
+coordinate-driven. The base installation includes a large library of
+simple shapes (e.g. rectangles, circles), photonic structures (e.g. sine
+curve waveguides), and superconducting nanowire shapes (e.g. single
+photon detectors) which are fully parameterized. It also has a built-in
+quick-plotting function based on Qt (or matplotlib) which allows you view
+the state of any GDS object, useful when scripting geometry-making
+functions. It also has a very thorough tutorial as well which will walk you
+through the process of getting acquainted with PHIDL.
+
+WWW: https://github.com/amccaugh/phidl