aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-04-28 21:23:56 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-04-28 21:23:56 +0000
commiteb2918fe523c5d4affad401ee37a1d19d1aca5c5 (patch)
treeb5112b12ef621b341884475c73fdce1a02bdd178 /cad
parentf53196ebc931edf54afe56ab65deddc4f2d5b8fb (diff)
downloadports-eb2918fe523c5d4affad401ee37a1d19d1aca5c5.tar.gz
ports-eb2918fe523c5d4affad401ee37a1d19d1aca5c5.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/pcb/Makefile58
-rw-r--r--cad/pcb/pkg-descr2
2 files changed, 44 insertions, 16 deletions
diff --git a/cad/pcb/Makefile b/cad/pcb/Makefile
index 5586a5843055..b762bcf49c82 100644
--- a/cad/pcb/Makefile
+++ b/cad/pcb/Makefile
@@ -1,54 +1,82 @@
-# New ports collection makefile for: PCB
-# Date created: 19 October 1994
-# Whom: mr
-#
+# Created by: Michael Reifenberger <mr@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= pcb
PORTVERSION= 20110918
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= cad
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= hrs@FreeBSD.org
COMMENT= X11 interactive printed circuit board layout system
-LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd \
+LICENSE= GPLv2
+
+LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd \
gtkglext-x11-1.0:${PORTSDIR}/x11-toolkits/gtkglext
RUN_DEPENDS= m4>=1.4.11:${PORTSDIR}/devel/m4 \
${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:${PORTSDIR}/devel/dbus
BUILD_DEPENDS:= ${RUN_DEPENDS}
-GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf
USE_GMAKE= yes
-USE_TK_RUN= 84
+USE_TK_RUN= yes
INSTALLS_ICONS= yes
-CONFIGURE_ENV+= INSTALL_DATA="/usr/bin/install ${COPY} ${_SHROWNGRP} -m ${SHAREMODE}"
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= INSTALL_DATA="${BSD_INSTALL_DATA}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -pthread -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --docdir=${DOCSDIR} --disable-nls
+CONFIGURE_ARGS= --docdir=${DOCSDIR}
+MAKE_JOBS_SAFE= yes
+
PORTDOCS= pcb.html pcb.pdf refcard.pdf pad.png puller.png thermal.png \
examples tutorial gcode.png gcode_control_img.png \
gcode_tool_path.png
-.if defined(WITHOUT_X11)
+OPTIONS_DEFINE= DOCS NLS X11
+OPTIONS_SINGLE= GUI
+OPTIONS_SINGLE_GUI=MOTIF GTK NONE
+OPTIONS_DEFAULT=DOCS X11 GTK
+MOTIF_DESC= Motif widgets
+GTK_DESC= GIMP ToolKit widgets
+NONE_DESC= No GUI support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+CONFIGURE_ARGS+= \
+ --enable-nls \
+ --with-libiconv-prefix=${LOCALBASE} \
+ --with-libintl-prefix=${LOCALBASE}
+USES= gettext iconv
+.for L in fr nl ru
+PLIST_FILES+= share/locale/${L}/LC_MESSAGES/pcb.mo
+.endfor
+.else
+CONFIGURE_ARGS+= \
+ --disable-nls \
+ --without-libiconv \
+ --without-libintl
+.endif
+
+.if ${PORT_OPTIONS:MX11}
+.if ${PORT_OPTIONS:MNONE}
CONFIGURE_ARGS+= --without-gui
CONFIGURE_ENV+= WISH=${TRUE}
-.elif defined(WITH_MOTIF_GUI)
+.elif ${PORT_OPTIONS:MMOTIF}
USE_MOTIF= yes
USE_TK_RUN= yes
CONFIGURE_ARGS+= --with-gui=lesstif
CONFIGURE_ENV+= WISH=${WISH}
-.else
+.elif ${PORT_OPTIONS:MGTK}
USE_GNOME= gtk20 desktopfileutils
USE_TK_RUN= yes
CONFIGURE_ARGS+= --with-gui=gtk
CONFIGURE_ENV+= WISH=${WISH}
.endif
+.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
INFO= pcb
MAN1= pcb.1
.else
diff --git a/cad/pcb/pkg-descr b/cad/pcb/pkg-descr
index 4901cb034718..0c58fad4a712 100644
--- a/cad/pcb/pkg-descr
+++ b/cad/pcb/pkg-descr
@@ -5,4 +5,4 @@ centroid data (X-Y data) output for use in the board fabrication and
assembly process. PCB offers high end features such as an autorouter
and trace optimizer which can tremendously reduce layout time.
-WWW: http://pcb.gpleda.org/index.html
+WWW: http://pcb.geda-project.org/