aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2019-09-09 11:58:29 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2019-09-09 11:58:29 +0000
commit137b178d775cc82871e7e5c92cb59bc054773fdf (patch)
tree6c267ab6a9eb9dea9e2f0bbf1f65eb72181912b2 /cad
parenta36bcc7c35bfd8e734741ba9318af6dff3e75a06 (diff)
downloadports-137b178d775cc82871e7e5c92cb59bc054773fdf.tar.gz
ports-137b178d775cc82871e7e5c92cb59bc054773fdf.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/xcircuit/Makefile4
-rw-r--r--cad/xcircuit/distinfo6
-rw-r--r--cad/xcircuit/files/patch-svg.c15
-rw-r--r--cad/xcircuit/files/patch-tclxcircuit.c11
4 files changed, 13 insertions, 23 deletions
diff --git a/cad/xcircuit/Makefile b/cad/xcircuit/Makefile
index 3ed2097dbc30..cab56d9663d7 100644
--- a/cad/xcircuit/Makefile
+++ b/cad/xcircuit/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xcircuit
-PORTVERSION= 3.10.12
+PORTVERSION= 3.10.13
PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= http://opencircuitdesign.com/xcircuit/archive/ \
@@ -16,7 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= ghostscript:x11,run gmake gnome pkgconfig tar:tgz tk:tea
+USES= ghostscript:x11,run gmake gnome pkgconfig tar:tgz tk:tea xorg
OPTIONS_DEFINE= EXAMPLES
diff --git a/cad/xcircuit/distinfo b/cad/xcircuit/distinfo
index 2257c815c841..f3fa6e6ed88f 100644
--- a/cad/xcircuit/distinfo
+++ b/cad/xcircuit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1540589489
-SHA256 (xcircuit-3.10.12.tgz) = 92ea6366fdb58b669b62abc0c5f5662658bbaf80de01b4344b24d1eeeea0a610
-SIZE (xcircuit-3.10.12.tgz) = 1615276
+TIMESTAMP = 1567944966
+SHA256 (xcircuit-3.10.13.tgz) = 769c886531fd5f7da0142115aa67d4eb465a3da127f0ad8b8705c5b53702a2f0
+SIZE (xcircuit-3.10.13.tgz) = 1615156
diff --git a/cad/xcircuit/files/patch-svg.c b/cad/xcircuit/files/patch-svg.c
index e83e1ecf6bb8..566c880bb4c7 100644
--- a/cad/xcircuit/files/patch-svg.c
+++ b/cad/xcircuit/files/patch-svg.c
@@ -1,11 +1,12 @@
---- svg.c.orig 2009-09-23 21:50:37.000000000 +0900
-+++ svg.c 2009-11-09 22:27:21.000000000 +0900
-@@ -8,6 +8,7 @@
+--- svg.c.orig 2019-09-08 12:19:55 UTC
++++ svg.c
+@@ -7,9 +7,7 @@
+ #include <stdlib.h>
+ #include <stdint.h>
#include <string.h>
+-#ifndef XC_WIN32
+ #include <unistd.h>
+-#endif
#include <math.h>
#include <limits.h>
-+#include <unistd.h>
#include <sys/stat.h>
- #include <sys/wait.h>
-
-
diff --git a/cad/xcircuit/files/patch-tclxcircuit.c b/cad/xcircuit/files/patch-tclxcircuit.c
deleted file mode 100644
index 161c3d101dca..000000000000
--- a/cad/xcircuit/files/patch-tclxcircuit.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- tclxcircuit.c.orig 2017-04-25 12:36:04 UTC
-+++ tclxcircuit.c
-@@ -8947,7 +8947,7 @@ int defaultscript()
- sprintf(_STR2, "%s/tcl/%s", SCRIPTS_DIR, STARTUP_FILE);
- if ((fd = fopen(_STR2, "r")) == NULL) {
- Wprintf("Failed to open startup script \"%s\"\n", STARTUP_FILE);
-- return;
-+ return TCL_ERROR;
- }
- }
- }