aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-06-01 14:48:08 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-06-01 14:48:08 +0000
commit4644881909c694229ca0f310e60fb314d23143ce (patch)
tree9bcf15d4de0441a362eefc87c36e34353d4ee986 /cad
parent762078329c43196ef81bab6dd56ad97e83a2584c (diff)
downloadports-4644881909c694229ca0f310e60fb314d23143ce.tar.gz
ports-4644881909c694229ca0f310e60fb314d23143ce.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/atlc/Makefile2
-rw-r--r--cad/brlcad/Makefile3
-rw-r--r--cad/gplcver/Makefile3
-rw-r--r--cad/qfsm/Makefile7
4 files changed, 6 insertions, 9 deletions
diff --git a/cad/atlc/Makefile b/cad/atlc/Makefile
index e5e926540eee..62914230ee7c 100644
--- a/cad/atlc/Makefile
+++ b/cad/atlc/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2 # (or later)
OPTIONS_DEFINE= DOCS EXAMPLES
-USE_BZIP2= yes
+USES= tar:bzip2
GNU_CONFIGURE= yes
PORTDOCS= *
diff --git a/cad/brlcad/Makefile b/cad/brlcad/Makefile
index 100b2601902a..dd2e0dfd20a1 100644
--- a/cad/brlcad/Makefile
+++ b/cad/brlcad/Makefile
@@ -20,11 +20,10 @@ LIB_DEPENDS= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
libexpat.so:${PORTSDIR}/textproc/expat2 \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
-USE_BZIP2= yes
USE_GL= gl glu
USE_XORG= ice inputproto sm x11 xau xcb xdamage xdmcp xext xfixes xft xi \
xproto xrender xscrnsaver xt xxf86vm
-USES= bison pathfix cmake:outsource pkgconfig tk:85
+USES= tar:bzip2 bison pathfix cmake:outsource pkgconfig tk:85
USE_LDCONFIG= yes
PREFIX?= ${LOCALBASE}/${PORTNAME}
diff --git a/cad/gplcver/Makefile b/cad/gplcver/Makefile
index b056f6edbfa3..25537ee337a6 100644
--- a/cad/gplcver/Makefile
+++ b/cad/gplcver/Makefile
@@ -10,8 +10,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}.src
MAINTAINER= ports@FreeBSD.org
COMMENT= A Verilog HDL simulator
-USES= gmake
-USE_BZIP2= yes
+USES= tar:bzip2 gmake
BUILD_WRKSRC= ${WRKSRC}/src
MAKEFILE= makefile.freebsd
diff --git a/cad/qfsm/Makefile b/cad/qfsm/Makefile
index 372279906002..a43966ff4c12 100644
--- a/cad/qfsm/Makefile
+++ b/cad/qfsm/Makefile
@@ -14,11 +14,10 @@ LICENSE= GPLv3 # (or later)
OPTIONS_DEFINE= GRAPHVIZ DOCS EXAMPLES
-USE_BZIP2= yes
USE_XORG= xi
USE_QT4= corelib gui qt3support svg xml \
moc_build qmake_build rcc_build uic_build
-USES= cmake desktop-file-utils
+USES= tar:bzip2 cmake desktop-file-utils
INSTALLS_ICONS= yes
GRAPHVIZ_BUILD_DEPENDS= graphviz>=2.22:${PORTSDIR}/graphics/graphviz
@@ -47,8 +46,8 @@ do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/po/*.qm ${STAGEDIR}${DATADIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/doc/user && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/doc/user && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>