aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-10 13:54:26 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-10 13:54:26 +0000
commit5005b67362a735dc18d3d85170eae34e1fb6feab (patch)
tree3a1e73b4128190b7ed7020b2113a1d94d76b0e93 /cad
parente4eefd3f1e344c567f932fef63a6f04a0bb4eba4 (diff)
downloadports-5005b67362a735dc18d3d85170eae34e1fb6feab.tar.gz
ports-5005b67362a735dc18d3d85170eae34e1fb6feab.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/cascade/Makefile2
-rw-r--r--cad/cider/Makefile2
-rw-r--r--cad/gdsreader/Makefile2
-rw-r--r--cad/geda-gattrib/Makefile2
-rw-r--r--cad/geda-gschem/Makefile2
-rw-r--r--cad/kicad/Makefile3
-rw-r--r--cad/libgeda/Makefile2
7 files changed, 15 insertions, 0 deletions
diff --git a/cad/cascade/Makefile b/cad/cascade/Makefile
index 382ecbb0b2a0..c28e0273155e 100644
--- a/cad/cascade/Makefile
+++ b/cad/cascade/Makefile
@@ -19,6 +19,8 @@ MAN1= cascade.1
NO_STAGE= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
do-install:
diff --git a/cad/cider/Makefile b/cad/cider/Makefile
index 8de3a3f5c266..7621669beb15 100644
--- a/cad/cider/Makefile
+++ b/cad/cider/Makefile
@@ -22,6 +22,8 @@ USE_XORG= xt xaw xmu
NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
pre-patch:
diff --git a/cad/gdsreader/Makefile b/cad/gdsreader/Makefile
index ceca6fa8424d..feae2f2c1fdd 100644
--- a/cad/gdsreader/Makefile
+++ b/cad/gdsreader/Makefile
@@ -20,6 +20,8 @@ PLIST_DIRS= ${EXAMPLESDIR_REL}
NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/cad/geda-gattrib/Makefile b/cad/geda-gattrib/Makefile
index 236f807f0685..2f0101fe5071 100644
--- a/cad/geda-gattrib/Makefile
+++ b/cad/geda-gattrib/Makefile
@@ -29,6 +29,8 @@ CONFIGURE_ARGS= --with-docdir="${DOCSDIR}" --disable-update-mime-database \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/cad/geda-gschem/Makefile b/cad/geda-gschem/Makefile
index 777decfd030f..c19de150f8df 100644
--- a/cad/geda-gschem/Makefile
+++ b/cad/geda-gschem/Makefile
@@ -30,6 +30,8 @@ CONFIGURE_ARGS= --enable-gdgeda --with-docdir=${DOCSDIR} \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/cad/kicad/Makefile b/cad/kicad/Makefile
index a7b3c367169a..6d6510df5f23 100644
--- a/cad/kicad/Makefile
+++ b/cad/kicad/Makefile
@@ -39,6 +39,9 @@ WRKSRC= ${WRKDIR}/${SFNAME}
PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S|^${PREFIX}/||}
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/cad/libgeda/Makefile b/cad/libgeda/Makefile
index c1c125f295e5..78d0c4085701 100644
--- a/cad/libgeda/Makefile
+++ b/cad/libgeda/Makefile
@@ -24,6 +24,8 @@ CONFIGURE_ARGS= --disable-update-mime-database \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}