aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-04-17 07:57:22 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-04-17 07:57:22 +0000
commit8b0769cbf13bba2fefe55cfc88eb3992254d1457 (patch)
tree680febfe2aa8cd9621335804bbca2b9ccb9113cb /cad
parentac217b2c317e773ed468ca8c2ae1effbf688e3f8 (diff)
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/freecad/files/patch-boost-1.6716
1 files changed, 16 insertions, 0 deletions
diff --git a/cad/freecad/files/patch-boost-1.67 b/cad/freecad/files/patch-boost-1.67
new file mode 100644
index 000000000000..fd77117a64b4
--- /dev/null
+++ b/cad/freecad/files/patch-boost-1.67
@@ -0,0 +1,16 @@
+https://github.com/FreeCAD/FreeCAD/pull/1409
+
+--- CMakeLists.txt.orig 2017-09-08 12:52:12 UTC
++++ CMakeLists.txt
+@@ -560,6 +560,11 @@ endif(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+ find_package(Boost ${BOOST_MIN_VERSION}
+ COMPONENTS filesystem program_options regex signals system thread REQUIRED)
+
++ if(UNIX AND NOT APPLE)
++ # Boost.Thread 1.67+ headers reference pthread_condattr_*
++ list(APPEND Boost_LIBRARIES pthread)
++ endif()
++
+ IF(NOT Boost_FOUND)
+ MESSAGE(FATAL_ERROR "========================================\n"
+ "boost not found, install the components:\n"