aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2020-06-07 16:26:56 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2020-06-07 16:26:56 +0000
commit17e5b388ccf4470f26b689644dff1a6b72440f90 (patch)
tree63b20ec3d5dd97f9a0352bfebed394efa4568e9e /cad
parentb765daea1b6d53ea1620653d553941150d098827 (diff)
downloadports-17e5b388ccf4470f26b689644dff1a6b72440f90.tar.gz
ports-17e5b388ccf4470f26b689644dff1a6b72440f90.zip
freecad: don't compress QResources for python code
rcc automatically compresses resources above a certain size, but as we found out the hard way, loading compressed resources from python fails and may even coredump. As a workaround, force-disable compression on resources in python code (c++ code seems to be fine compressed or not), which re-enables several workbenches (most notably: Draft) at the cost of a few megabytes of disk space. Reported by: jeff@ MFH: 2020Q2
Notes
Notes: svn path=/head/; revision=538164
Diffstat (limited to 'cad')
-rw-r--r--cad/freecad/Makefile2
-rw-r--r--cad/freecad/files/patch-cMake_FindPySide2Tools.cmake2
2 files changed, 2 insertions, 2 deletions
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index 8a24163efd1f..526f2a20363a 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -2,7 +2,7 @@
PORTNAME= FreeCAD
DISTVERSION= 0.18.4
-PORTREVISION= 8
+PORTREVISION= 9
# use these for bugfixes/snapshots
# DISTVERSION= 0.18-16093 # git rev-list --count
# DISTVERSIONSUFFIX= -g690774c0e
diff --git a/cad/freecad/files/patch-cMake_FindPySide2Tools.cmake b/cad/freecad/files/patch-cMake_FindPySide2Tools.cmake
index fae33afa338f..1f13af998d48 100644
--- a/cad/freecad/files/patch-cMake_FindPySide2Tools.cmake
+++ b/cad/freecad/files/patch-cMake_FindPySide2Tools.cmake
@@ -15,7 +15,7 @@
ADD_CUSTOM_COMMAND(OUTPUT "${outfile}"
- COMMAND "${PYSIDE2RCCBINARY}" "${infile}" ${PY_ATTRIBUTE} -o "${outfile}"
- COMMAND sed -i "/^# /d" "${outfile}"
-+ COMMAND "${PYSIDE2RCCBINARY}" "${infile}" --generator python -o "${outfile}"
++ COMMAND "${PYSIDE2RCCBINARY}" "${infile}" --no-compress --generator python -o "${outfile}"
+ COMMAND sed -i \"\" "/^# /d" "${outfile}"
MAIN_DEPENDENCY "${infile}"
)