aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-02-02 03:12:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-02-02 03:12:59 +0000
commit190e1f518b834978655af437f8f7672a6988ccc7 (patch)
tree77c10a8652de5b6cc7933246f8e0a42efa32f1d3 /cad
parent7b0bd462defa80066ca7185f72f7897b1cbf289d (diff)
downloadports-190e1f518b834978655af437f8f7672a6988ccc7.tar.gz
ports-190e1f518b834978655af437f8f7672a6988ccc7.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/Makefile1
-rw-r--r--cad/veroroute/Makefile28
-rw-r--r--cad/veroroute/distinfo3
-rw-r--r--cad/veroroute/pkg-descr5
4 files changed, 37 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index c3277345347a..303980dc0a47 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -107,6 +107,7 @@
SUBDIR += varkon
SUBDIR += verilator
SUBDIR += verilog-mode.el
+ SUBDIR += veroroute
SUBDIR += xcircuit
SUBDIR += yosys
SUBDIR += z88
diff --git a/cad/veroroute/Makefile b/cad/veroroute/Makefile
new file mode 100644
index 000000000000..f1b913933b87
--- /dev/null
+++ b/cad/veroroute/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= veroroute
+DISTVERSIONPREFIX= V
+DISTVERSION= 174
+DISTVERSIONSUFFIX= _Src
+CATEGORIES= cad
+MASTER_SITES= SF/${PORTNAME}/
+DISTNAME= VeroRoute_${DISTVERSIONFULL}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= PCB (printed circuit board) design software
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/../licenses/license_GPLv3.txt
+
+USES= qmake qt:5 zip
+USE_QT= core gui network widgets buildtools_build
+
+WRKSRC= ${WRKDIR}/VeroRoute
+WRKSRC_SUBDIR= Src
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install: # https://sourceforge.net/p/veroroute/tickets/17/
+ ${INSTALL_PROGRAM} ${WRKSRC}/../${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/cad/veroroute/distinfo b/cad/veroroute/distinfo
new file mode 100644
index 000000000000..6a33fe54703e
--- /dev/null
+++ b/cad/veroroute/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1580612136
+SHA256 (VeroRoute_V174_Src.zip) = 643c583fc0cbac9ee36db40b250853646151f514f7b2887caaba4038417bd7c1
+SIZE (VeroRoute_V174_Src.zip) = 928424
diff --git a/cad/veroroute/pkg-descr b/cad/veroroute/pkg-descr
new file mode 100644
index 000000000000..942bb784d0df
--- /dev/null
+++ b/cad/veroroute/pkg-descr
@@ -0,0 +1,5 @@
+Cross-platform software for producing Veroboard (stripboard), Perfboard, and
+single-sided PCB layouts. Automatically prevents short circuits and checks for
+open circuits.
+
+WWW: https://sourceforge.net/projects/veroroute/