aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-02-07 10:47:17 +0000
committerJohn Marino <marino@FreeBSD.org>2016-02-07 10:47:17 +0000
commit3c9a0156bf097d0c4f80b6ffa44cf860ebb293d6 (patch)
tree45e624b387ee933a0672d252f4ba900effea15c4 /cad
parentbdb7890fcf441a42db9e90f2e6acdeeed0ff38a5 (diff)
downloadports-3c9a0156bf097d0c4f80b6ffa44cf860ebb293d6.tar.gz
ports-3c9a0156bf097d0c4f80b6ffa44cf860ebb293d6.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/ghdl/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/cad/ghdl/Makefile b/cad/ghdl/Makefile
index 4e80573b6507..8c34f389eb17 100644
--- a/cad/ghdl/Makefile
+++ b/cad/ghdl/Makefile
@@ -53,6 +53,7 @@ OPTIONS_SINGLE_BACKEND= GCC LLVM
GCC_DESC= Code generator is GCC (mature)
LLVM_DESC= Code generator is LLVM (experimental)
+LLVM_USES= libedit ncurses
.if exists (/sbin/hammer)
OPTIONS_DEFAULT= LLVM
@@ -118,6 +119,7 @@ post-patch:
-e 's|(INSTALL_DATA)|(BSD_INSTALL_DATA)|' \
${WRKSRC}/configure ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|clang++|clang++${LLVMVER}|' \
+ -e 's|\((LDFLAGS)\)|\1 -L${LOCALBASE}/lib|' \
${WRKSRC}/src/ortho/llvm/Makefile
.if ${PORT_OPTIONS:MGCC}