aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2014-08-22 05:05:02 +0000
committerHiroki Sato <hrs@FreeBSD.org>2014-08-22 05:05:02 +0000
commitad2594965def99df967176a095e1accc5db6989b (patch)
treef615c489afdb209b3b580c1dfec1de8d48479a0d /cad
parentb51e9d00d696c381bb38fa2d6de1538918b27aca (diff)
downloadports-ad2594965def99df967176a095e1accc5db6989b.tar.gz
ports-ad2594965def99df967176a095e1accc5db6989b.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/spice/Makefile42
-rw-r--r--cad/spice/distinfo2
-rw-r--r--cad/spice/files/FreeBSD5
-rw-r--r--cad/spice/files/FreeBSD.without_x118
-rw-r--r--cad/spice/files/Makefile60
-rw-r--r--cad/spice/files/patch-conf_defaults22
6 files changed, 75 insertions, 64 deletions
diff --git a/cad/spice/Makefile b/cad/spice/Makefile
index 9b337c90d7fe..0d1d3322939d 100644
--- a/cad/spice/Makefile
+++ b/cad/spice/Makefile
@@ -3,12 +3,14 @@
PORTNAME= spice
PORTVERSION= 3f5.2
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= cad
MASTER_SITES= http://embedded.eecs.berkeley.edu/pubs/downloads/spice/:srcs \
+ http://www-device.eecs.berkeley.edu/~bsim/Files/BSIM3/ftpv330/src/:bsim3 \
LOCAL/hrs/${PORTNAME}:docs
-PKGNAMESUFFIX= ${NOX11SUFX}
-DISTFILES= spice3f5${EXTRACT_SUFX}:srcs cp.ps:docs toc.ps:docs doc.ps:docs
+DISTFILES= spice3f5${EXTRACT_SUFX}:srcs \
+ BSIM3v330.tar.Z:bsim3 \
+ cp.ps:docs toc.ps:docs doc.ps:docs
DIST_SUBDIR= spice
EXTRACT_ONLY= spice3f5${EXTRACT_SUFX}
@@ -20,8 +22,8 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
WRKSRC= ${WRKDIR}/${PORTNAME}3f5
MAKEFILE= ${FILESDIR}/Makefile
-MAKE_ENV= WITH_INSTALL_AS_USER=yes
-ALL_TARGET= build _manpages
+CONFIGURE_ENV= CONFIGFILE="${WRKSRC}/conf/FreeBSD" \
+ LOCALBASE="${LOCALBASE}"
PORTDOCS= spice3f3.ps.gz
PORTEXAMPLES= bjtnoise.cir bsim1tst.cir bsim2tst.cir diffpair.cir \
@@ -30,27 +32,29 @@ PORTEXAMPLES= bjtnoise.cir bsim1tst.cir bsim2tst.cir diffpair.cir \
process.pro pz2.cir pzt.cir rc.cir rca3040.cir resnoise.cir \
rtlinv.cir schmitt.cir simplepz.cir
-OPTIONS_DEFINE= DOCS EXAMPLES X11
+OPTIONS_DEFINE= DOCS EXAMPLES X11 DEV_BSIM3
OPTIONS_DEFAULT=DOCS EXAMPLES X11
+X11_USE= XORG=x11,xaw,xext,xmu,xt
+X11_CONFIGURE_ENV= WITH_X11=yes
+DEV_BSIM3_DESC= BSIM3v3 MOS Transistor Model Support
+DEV_BSIM3_CONFIGURE_ENV=DEV_BSIM3=yes
+
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MX11}
-USE_XORG= x11 xaw xext xmu xt
-NOX11SUFX=
-CONFIGFILE= ${FILESDIR}/FreeBSD
-.else
-NOX11SUFX= -nox11
-CONFIGFILE= ${FILESDIR}/FreeBSD.without_x11
+.if ${PORT_OPTIONS:MDEV_BSIM3}
+post-extract:
+ @${MKDIR} ${WRKSRC}/src/lib/dev/bsim3
+ ${TAR} -xf ${DISTDIR}/${DIST_SUBDIR}/BSIM3v330.tar.Z \
+ -C ${WRKSRC}/src/lib/dev/bsim3
.endif
do-configure:
- (${CAT} ${CONFIGFILE}; \
- ${ECHO_CMD} "CC= ${CC}"; \
- ${ECHO_CMD} "MAKE= ${MAKE}"; \
- ${ECHO_CMD} "CC_OPT+= ${CFLAGS}"; \
- ${ECHO_CMD} "LOCALBASE=${LOCALBASE}"; \
- ) > ${WRKSRC}/conf/FreeBSD
+ @${SETENV} ${CONFIGURE_ENV} ${MAKE} -f ${MAKEFILE} configure
+ @(${ECHO_CMD} "CC= ${CC}"; \
+ ${ECHO_CMD} "MAKE= ${MAKE}"; \
+ ${ECHO_CMD} "CC_OPT= ${CFLAGS}"; \
+ ) >> ${WRKSRC}/conf/FreeBSD
post-install:
.if ${PORT_OPTIONS:MDOCS}
diff --git a/cad/spice/distinfo b/cad/spice/distinfo
index c7b834216675..4db27a17c094 100644
--- a/cad/spice/distinfo
+++ b/cad/spice/distinfo
@@ -1,5 +1,7 @@
SHA256 (spice/spice3f5.tar.gz) = cac11fe2a761241e6b6c9eaa31b938c7ffa76aeaecac09809609d3a4125cd269
SIZE (spice/spice3f5.tar.gz) = 1226185
+SHA256 (spice/BSIM3v330.tar.Z) = 3d8d1739c5fb7f1e56af70e5dc05a6f9014d0954a4f3c1bcf778a494ae0087b2
+SIZE (spice/BSIM3v330.tar.Z) = 113719
SHA256 (spice/cp.ps) = 3bab6c3487def4ce2e817bf7ef3c1a7d199ea8e790da3a786f936872b35d0920
SIZE (spice/cp.ps) = 10297
SHA256 (spice/toc.ps) = 22228246f98f38e39a22911251fa52782ca6a2a7fb273fd78cf3da833d1f52e8
diff --git a/cad/spice/files/FreeBSD b/cad/spice/files/FreeBSD
deleted file mode 100644
index 990cd468d47e..000000000000
--- a/cad/spice/files/FreeBSD
+++ /dev/null
@@ -1,5 +0,0 @@
-# FreeBSD config exception file
-
-INTERFACE_OPTS = -DWANT_MFB -DWANT_X11
-LDFLAGS += -L${LOCALBASE}/lib -lm -ltermcap
-SYS_CFLAGS = -Dbsd
diff --git a/cad/spice/files/FreeBSD.without_x11 b/cad/spice/files/FreeBSD.without_x11
deleted file mode 100644
index 73e2e28561f6..000000000000
--- a/cad/spice/files/FreeBSD.without_x11
+++ /dev/null
@@ -1,8 +0,0 @@
-# FreeBSD config exception file (non-x11 version)
-
-INTERFACE_OPTS = -DWANT_MFB
-LDFLAGS += -lm -ltermcap
-SYS_CFLAGS = -Dbsd
-X_DIR =
-INCX =
-LIBX =
diff --git a/cad/spice/files/Makefile b/cad/spice/files/Makefile
index 71da64550ee3..7f978b24f3b0 100644
--- a/cad/spice/files/Makefile
+++ b/cad/spice/files/Makefile
@@ -1,9 +1,33 @@
#
# $FreeBSD$
#
-build:
+all:
${SH} util/build FreeBSD default
- strip ${PROGRAMS:S,^,FreeBSD/obj/bin/,}
+
+# Configuration parameters
+DEVLIST=
+VARLIST= SYS_CFLAGS LDFLAGS INTERFACE_OPTS X_DIR
+SYS_CFLAGS= -Dbsd
+LDFLAGS= -lm -ltermcap
+INTERFACE_OPTS= -DWANT_MFB
+.if defined(WITH_X11) && !empty(WITH_X11)
+INTERFACE_OPTS+=-DWANT_X11
+.else
+VARLIST+= INCX LIBX
+.endif
+X_DIR= ${LOCALBASE}
+.if defined(DEV_BSIM3) && !empty(DEV_BSIM3)
+DEVLIST+= bsim3
+.endif
+
+configure:
+ rm -f ${CONFIGFILE}
+.for V in ${VARLIST}
+ echo "$V=${${V}}" >> ${CONFIGFILE}
+.endfor
+.for V in ${DEVLIST}
+ echo "$V+=${${V}}" >> ${CONFIGFILE}
+.endfor
PREFIX?= /usr/local
@@ -12,23 +36,35 @@ SHAREFILESDIR= ${PREFIX}/share/spice
HELPFILESDIR= ${SHAREFILESDIR}/helpdir
SCRIPTFILESDIR= ${SHAREFILESDIR}/scripts
-FILESGROUPS= PROGRAMS HELPFILES SCRIPTFILES SHAREFILES
-
-PROGRAMSMODE= ${BINMODE}
-PROGRAMSOWN= ${BINOWN}
-PROGRAMSGRP= ${BINGRP}
-
PROGRAMS= spice3 nutmeg sconvert help proc2mod multidec
HELPFILES= spice.txt
SCRIPTFILES= setplot spinit
SHAREFILES= mfbcap news
MAN= spice.1 nutmeg.1 sconvert.1 mfb.3 mfbcap.5
-MLINKS= spice.1 spice3.1
MANDIR= ${PREFIX}/man/man
-beforeinstall:
- mkdir -p ${DESTDIR}${HELPFILESDIR} ${DESTDIR}${SCRIPTFILESDIR}
+.for P in ${PROGRAMS}
+install:: ${DESTDIR}${BINDIR}/$P
+${DESTDIR}${BINDIR}/$P: $P
+ ${BSD_INSTALL_PROGRAM} ${.ALLSRC} ${.TARGET}
+.endfor
+.for n in 1 3 5
+. for M in ${MAN:M*.$n}
+install:: ${DESTDIR}${MANDIR}${n}/$M
+${DESTDIR}${MANDIR}${n}/$M: $M
+ ${BSD_INSTALL_MAN} ${.ALLSRC} ${.TARGET}
+. endfor
+.endfor
+ ln -s -f spice.1 ${DESTDIR}${MANDIR}1/spice3.1
+
+.for D in HELPFILES SCRIPTFILES SHAREFILES
+. for F in ${${D}}
+install:: ${DESTDIR}${${D}DIR}/$F
+${DESTDIR}${${D}DIR}/$F: $F
+ mkdir -p ${DESTDIR}${${D}DIR}
+ ${BSD_INSTALL_DATA} ${.ALLSRC} ${.TARGET}
+. endfor
+.endfor
.PATH: FreeBSD/obj/bin lib/helpdir lib/scripts lib man/man1 man/man3 man/man5
-.include <bsd.prog.mk>
diff --git a/cad/spice/files/patch-conf_defaults b/cad/spice/files/patch-conf_defaults
index c5d6e9b65830..aad6ab1133a1 100644
--- a/cad/spice/files/patch-conf_defaults
+++ b/cad/spice/files/patch-conf_defaults
@@ -1,5 +1,5 @@
---- conf/defaults.orig Thu Jul 17 16:40:51 2003
-+++ conf/defaults Thu Jul 17 16:51:19 2003
+--- conf/defaults.orig 1993-07-30 06:33:56.000000000 +0900
++++ conf/defaults 2014-08-22 10:49:42.000000000 +0900
@@ -65,7 +65,7 @@
# the following definition:
# SYS_DIR = $(DIST_DIR)
@@ -25,21 +25,3 @@
S_SPICE_EXEC_DIR= $(S_SPICE_DIR)/bin
# INSTALL_DIRS lists the directories that need to be created before
-@@ -133,7 +133,7 @@
-
- # CC_OPT: Default compile options (optimization/debug level, other)
-
--CC_OPT = -O
-+CC_OPT =
-
- # CC_OPT_SAFE: Special compile options to override CC_OPT for code
- # which typically causes problems for most compilers (bsim1 and bsim2).
-@@ -203,7 +203,7 @@
- # X_DIR indicates the top of the X11 lib/include hierarchy; it is only
- # a convenience that is used in the following definitions.
-
--X_DIR = /usr
-+X_DIR = ${LOCALBASE}
-
- # INCX lists the X include directories. This may be different between
- # MIT X11r5, X11r4, and your vendor's version of X11, though listing