aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-04 21:36:13 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-04 21:36:13 +0000
commitc2e845d0c8bc7c9f164cff0518da23f674677570 (patch)
tree7fc33d51c49bd9a7ccd279ab581748918852d482 /cad
parent2f557a46788f7ec9b1355f7a17e8ca1cfe208f8b (diff)
downloadports-c2e845d0c8bc7c9f164cff0518da23f674677570.tar.gz
ports-c2e845d0c8bc7c9f164cff0518da23f674677570.zip
Notes
Diffstat (limited to 'cad')
-rw-r--r--cad/calculix/Makefile2
-rw-r--r--cad/dinotrace/Makefile2
-rw-r--r--cad/feappv/Makefile2
-rw-r--r--cad/gmsh/Makefile3
-rw-r--r--cad/irsim/Makefile2
-rw-r--r--cad/kicad-devel/Makefile2
-rw-r--r--cad/kicad/Makefile2
-rw-r--r--cad/librecad/Makefile2
-rw-r--r--cad/linuxcnc-devel/Makefile3
-rw-r--r--cad/magic/Makefile2
-rw-r--r--cad/netgen/Makefile2
-rw-r--r--cad/openscad-devel/Makefile2
-rw-r--r--cad/openscad/Makefile2
-rw-r--r--cad/pcb/Makefile2
-rw-r--r--cad/qcad/Makefile2
-rw-r--r--cad/qelectrotech/Makefile3
-rw-r--r--cad/repsnapper/Makefile4
-rw-r--r--cad/solvespace/Makefile2
-rw-r--r--cad/sumo/Makefile2
-rw-r--r--cad/varkon/Makefile2
-rw-r--r--cad/z88/Makefile2
21 files changed, 25 insertions, 22 deletions
diff --git a/cad/calculix/Makefile b/cad/calculix/Makefile
index c956264dd3ae..4db0bae187cd 100644
--- a/cad/calculix/Makefile
+++ b/cad/calculix/Makefile
@@ -19,7 +19,7 @@ BROKEN_aarch64= fails to link: shapeFunctions.c:(function attach_new): relocati
RUN_DEPENDS= ccx:cad/calculix-ccx
-USES= gmake tar:bzip2 compiler:c++11-lib
+USES= gl gmake tar:bzip2 compiler:c++11-lib xorg
USE_XORG= ice sm x11 xext xi xmu xt
USE_GL= gl glu # uses its own glut
diff --git a/cad/dinotrace/Makefile b/cad/dinotrace/Makefile
index 87479ae4f20b..98ae24eda48b 100644
--- a/cad/dinotrace/Makefile
+++ b/cad/dinotrace/Makefile
@@ -14,7 +14,7 @@ COMMENT= Graphical signal trace waveform viewer
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake motif perl5 tar:tgz
+USES= gmake motif perl5 tar:tgz xorg
USE_XORG= x11 sm ice xmu xt
USE_PERL5= build
diff --git a/cad/feappv/Makefile b/cad/feappv/Makefile
index b4caa889978e..4e77a541ba1e 100644
--- a/cad/feappv/Makefile
+++ b/cad/feappv/Makefile
@@ -13,7 +13,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Finite element analysis program (personal version)
-USES= fortran gmake localbase:ldflags
+USES= fortran gmake localbase:ldflags xorg
USE_GITHUB= yes
GH_ACCOUNT= sanjayg0
USE_XORG= x11
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index d84bbbf51a5e..49984a7d4ac7 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -24,7 +24,8 @@ LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
libfreetype.so:print/freetype2
RUN_DEPENDS= getdp:science/getdp
-USES= blaslapack compiler:c++11-lang cmake fortran gl jpeg tar:tgz
+USES= blaslapack compiler:c++11-lang cmake fortran gl jpeg tar:tgz \
+ xorg
USE_GL= gl glu
USE_XORG= x11 xcursor xext xinerama xfixes xft xrender
diff --git a/cad/irsim/Makefile b/cad/irsim/Makefile
index 1a3782dab6fa..529048483ac9 100644
--- a/cad/irsim/Makefile
+++ b/cad/irsim/Makefile
@@ -25,7 +25,7 @@ TCL_USES= tk:tea
CONFIGURE_WRKSRC= ${WRKSRC}/scripts
-USES= gmake tar:tgz
+USES= gmake tar:tgz xorg
USE_XORG= x11
GNU_CONFIGURE= yes
diff --git a/cad/kicad-devel/Makefile b/cad/kicad-devel/Makefile
index a60d2af11e67..bf2d599b5639 100644
--- a/cad/kicad-devel/Makefile
+++ b/cad/kicad-devel/Makefile
@@ -47,7 +47,7 @@ BINS= cvpcb eeschema gerbview kicad pcbnew
EXTRAS2RM= linux-non_unicode linux wings3d LINUX.README \
contrib_makefiles.txt running_kicad_under_W98.txt
USES= desktop-file-utils shared-mime-info compiler:c++11-lib tar:bzip2 cmake:insource,noninja \
- gettext python:2.7 shebangfix ssl
+ gettext python:2.7 shebangfix ssl gl xorg gnome
SHEBANG_FILES= pcbnew/python/plugins/touch_slider_wizard.py
CMAKE_ARGS= -DLOCALBASE="${LOCALBASE}" \
diff --git a/cad/kicad/Makefile b/cad/kicad/Makefile
index cd557e8de138..d838ec02c6b9 100644
--- a/cad/kicad/Makefile
+++ b/cad/kicad/Makefile
@@ -28,7 +28,7 @@ GH_ACCOUNT= KiCad
GH_PROJECT= kicad-source-mirror
USES= cmake:noninja compiler:c++11-lib desktop-file-utils gl gnome \
- pkgconfig python:2.7 shared-mime-info shebangfix ssl tar:xz
+ pkgconfig python:2.7 shared-mime-info shebangfix ssl tar:xz xorg
SHEBANG_FILES= pcbnew/python/plugins/touch_slider_wizard.py
USE_XORG= ice x11 xext
diff --git a/cad/librecad/Makefile b/cad/librecad/Makefile
index b1b54a6ee5d8..4ce9402b1b67 100644
--- a/cad/librecad/Makefile
+++ b/cad/librecad/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/version.hpp:devel/boost-libs
LIB_DEPENDS= libmuparser.so:math/muparser \
libfreetype.so:print/freetype2
-USES= compiler:c++11-lib desktop-file-utils pkgconfig qmake qt:5
+USES= compiler:c++11-lib desktop-file-utils pkgconfig gl qmake qt:5
USE_GITHUB= yes
GH_ACCOUNT= LibreCAD
GH_PROJECT= LibreCAD
diff --git a/cad/linuxcnc-devel/Makefile b/cad/linuxcnc-devel/Makefile
index c2066cdacb7e..4d8ac88baee5 100644
--- a/cad/linuxcnc-devel/Makefile
+++ b/cad/linuxcnc-devel/Makefile
@@ -40,7 +40,8 @@ CONFIGURE_ARGS= --with-realtime=uspace --enable-non-distributable=yes \
--with-locale-dir="${PREFIX}/share/locale" --with-python=${PYTHON_CMD} \
--with-boost-python=boost_python27
MAKE_ENV= BUILD_VERBOSE=1
-USES= autoreconf gettext gmake ncurses pkgconfig python:2.7 readline shebangfix tk
+USES= autoreconf gettext gl gmake gnome ncurses pkgconfig python:2.7 \
+ readline shebangfix tk xorg
USE_GL= gl glu
USE_GNOME= cairo gdkpixbuf2 libgnomeprintui pygtksourceview
USE_XORG= ice sm x11 xext xft xinerama xmu xrender xscrnsaver xt
diff --git a/cad/magic/Makefile b/cad/magic/Makefile
index 6d0603d1b7b8..2373120b57d8 100644
--- a/cad/magic/Makefile
+++ b/cad/magic/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${FILESDIR}/license.txt
LIB_DEPENDS= libBLT25.so:x11-toolkits/blt
-USES= gmake tk:tea tar:tgz
+USES= gmake gl tk:tea tar:tgz xorg
USE_XORG= ice xext xi xmu
USE_GL= gl
CONFIGURE_ARGS= --with-opengl
diff --git a/cad/netgen/Makefile b/cad/netgen/Makefile
index 17561f9d535d..b0983c7ae4d7 100644
--- a/cad/netgen/Makefile
+++ b/cad/netgen/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libTix8.4.3.so:x11-toolkits/tix \
OCC_BROKEN= Does not compile because of issues with cad/opencascade
USE_LDCONFIG= yes
-USES= gmake jpeg libtool localbase tk:tea
+USES= gl gmake jpeg libtool localbase tk:tea xorg
USE_GL= gl glu
USE_XORG= x11 xmu xi
MAKE_JOBS_UNSAFE= yes
diff --git a/cad/openscad-devel/Makefile b/cad/openscad-devel/Makefile
index 9135088cf761..25ceaf3a65d5 100644
--- a/cad/openscad-devel/Makefile
+++ b/cad/openscad-devel/Makefile
@@ -32,7 +32,7 @@ LIB_DEPENDS= libzip.so:archivers/libzip \
CONFLICTS= openscad
USES= bison compiler:c++11-lib desktop-file-utils eigen:3 gettext \
- pkgconfig qmake qt:5 shared-mime-info
+ gl gnome pkgconfig qmake qt:5 shared-mime-info xorg
USE_GITHUB= yes
USE_GL= gl glu glew
USE_GNOME= glib20 libxml2
diff --git a/cad/openscad/Makefile b/cad/openscad/Makefile
index 2719719d4186..f30a57a32c74 100644
--- a/cad/openscad/Makefile
+++ b/cad/openscad/Makefile
@@ -32,7 +32,7 @@ LIB_DEPENDS= libzip.so:archivers/libzip \
CONFLICTS= openscad
USES= bison compiler:c++11-lib desktop-file-utils eigen:3 gettext \
- pkgconfig qmake qt:5 shared-mime-info
+ gl gnome pkgconfig qmake qt:5 shared-mime-info xorg
USE_GITHUB= yes
USE_GL= gl glu glew
USE_GNOME= glib20 libxml2
diff --git a/cad/pcb/Makefile b/cad/pcb/Makefile
index cf7a96249629..24c54d435002 100644
--- a/cad/pcb/Makefile
+++ b/cad/pcb/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= m4>=1.4.11:devel/m4 \
${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:devel/dbus
USES= gl gmake gnome pkgconfig tk:run shared-mime-info \
- desktop-file-utils
+ desktop-file-utils xorg
USE_GL= gl glu
USE_GNOME= intltool cairo pangox-compat
USE_XORG= x11 xrender xinerama
diff --git a/cad/qcad/Makefile b/cad/qcad/Makefile
index 84a225835683..28aa18178606 100644
--- a/cad/qcad/Makefile
+++ b/cad/qcad/Makefile
@@ -23,7 +23,7 @@ BUILD_DEPENDS= bash:shells/bash \
MAKE_JOBS_UNSAFE=yes
-USES= compiler:c++11-lang gmake qmake qt:5
+USES= compiler:c++11-lang gl gmake qmake qt:5
USE_GITHUB= yes
USE_LDCONFIG= yes
USE_QT= buildtools qmake_build \
diff --git a/cad/qelectrotech/Makefile b/cad/qelectrotech/Makefile
index bf59d626b259..1aa88b37df82 100644
--- a/cad/qelectrotech/Makefile
+++ b/cad/qelectrotech/Makefile
@@ -14,7 +14,8 @@ COMMENT= QElectroTech is application to design electric diagrams
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= compiler:c++11-lib desktop-file-utils kde:5 qmake qt:5 shared-mime-info
+USES= compiler:c++11-lib desktop-file-utils gl kde:5 qmake qt:5 \
+ shared-mime-info
USE_GL= gl
USE_QT= concurrent core gui network printsupport sql sql-sqlite3 \
svg widgets xml \
diff --git a/cad/repsnapper/Makefile b/cad/repsnapper/Makefile
index c5ab42f86911..4eac1355ab57 100644
--- a/cad/repsnapper/Makefile
+++ b/cad/repsnapper/Makefile
@@ -16,8 +16,8 @@ LIB_DEPENDS= libgtkglextmm-x11-1.2.so:x11-toolkits/gtkglextmm \
libpolyclipping.so:graphics/polyclipping \
libzip.so:archivers/libzip
-USES= compiler:c++11-lib autoreconf gettext gmake libtool localbase \
- perl5 pkgconfig
+USES= compiler:c++11-lib autoreconf gettext gl gmake gnome libtool \
+ localbase perl5 pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= timschmidt
USE_GNOME= gtkmm24 intltool libxml++26
diff --git a/cad/solvespace/Makefile b/cad/solvespace/Makefile
index f40e167048f6..2f8f978a1a3c 100644
--- a/cad/solvespace/Makefile
+++ b/cad/solvespace/Makefile
@@ -23,7 +23,7 @@ GH_PROJECT= libdxfrw:libdxfrw
GH_TAGNAME= 8f95895:libdxfrw
GH_SUBDIR= extlib/libdxfrw:libdxfrw
-USES= cmake compiler:c++11-lang gl gnome pkgconfig
+USES= cmake compiler:c++11-lang gl gnome pkgconfig xorg
USE_GL= gl glu glew
USE_GNOME= atkmm gtk20 pangomm
USE_XORG= x11
diff --git a/cad/sumo/Makefile b/cad/sumo/Makefile
index 45992d253992..0cb449d6665c 100644
--- a/cad/sumo/Makefile
+++ b/cad/sumo/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libtiff.so:graphics/tiff \
libxerces-c.so:textproc/xerces-c3
-USES= cmake jpeg python shebangfix zip
+USES= cmake gl jpeg python shebangfix zip xorg
SHEBANG_FILES= tools/*.py tools/*/*.py \
tools/*/*/*.py tools/*/*/*/*.py \
tools/*/*/*/*/*/*.py \
diff --git a/cad/varkon/Makefile b/cad/varkon/Makefile
index 6f4011ea03da..04ba7c972603 100644
--- a/cad/varkon/Makefile
+++ b/cad/varkon/Makefile
@@ -21,9 +21,9 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils
WRKSRC= ${WRKDIR}/Varkon_${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/sources
+USES= gl gmake xorg
USE_XORG= xpm
USE_GL= glu
-USES= gmake
MAKE_ENV= PLATFORM=FreeBSD
ALL_TARGET= # none
MAKE_JOBS_UNSAFE= yes
diff --git a/cad/z88/Makefile b/cad/z88/Makefile
index e5b4a71a3957..64824f709635 100644
--- a/cad/z88/Makefile
+++ b/cad/z88/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libgtkglext-x11-1.0.so:x11-toolkits/gtkglext \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= gl gnome pkgconfig
+USES= gl gnome pkgconfig xorg
USE_GITHUB= yes
USE_GL= gl glu
USE_GNOME= cairo gdkpixbuf2 gtk20